<!doctype html>
<html lang="en-US">
<head>
	<meta charset="UTF-8" />
	<meta name="viewport" content="width=device-width, initial-scale=1" />
	<link rel="profile" href="https://gmpg.org/xfn/11" />
	<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<!-- Optimized by SG Optimizer plugin version - 5.7.17 -->
	<!-- This site is optimized with the Yoast SEO plugin v16.0.2 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Naomie Harris Joins &#039;Man Who Fell to Earth&#039; Series</title>
	<meta name="description" content="Naomie Harris will star in Showtime&#039;s upcoming &quot;The Man Who Fell to Earth&quot; adaptation, starring alongside Chiwetel Ejiofor in the drama." />
	<link rel="canonical" href="https://theslanted.com/2021/03/46896/man-who-fell-to-earth-series-naomi-harris-cast-showtime/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Naomie Harris Joins &#039;Man Who Fell to Earth&#039; Series" />
	<meta property="og:description" content="Follow for more updates" />
	<meta property="og:url" content="https://theslanted.com/2021/03/46896/man-who-fell-to-earth-series-naomi-harris-cast-showtime/" />
	<meta property="og:site_name" content="Slanted" />
	<meta property="article:publisher" content="https://www.facebook.com/TheSlanted" />
	<meta property="article:published_time" content="2021-03-26T19:28:44+00:00" />
	<meta property="article:modified_time" content="2021-03-26T19:28:45+00:00" />
	<meta property="og:image" content="https://theslanted.com/wp-content/uploads/2020/04/Naomie-Harris.jpg" />
	<meta property="og:image:width" content="1200" />
	<meta property="og:image:height" content="640" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:description" content="Follow for more updates" />
	<meta name="twitter:image" content="https://theslanted.com/wp-content/uploads/2020/04/Naomie-Harris.jpg" />
	<meta name="twitter:creator" content="@https://twitter.com/sarahfoxes" />
	<meta name="twitter:site" content="@theslanted" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://theslanted.com/#organization","name":"Slanted","url":"https://theslanted.com/","sameAs":["https://www.facebook.com/TheSlanted","https://instagram.com/theslanted","https://www.linkedin.com/company/the-slanted","https://www.youtube.com/c/TheSlanted","https://www.pinterest.com/theslanted/","https://twitter.com/theslanted"],"logo":{"@type":"ImageObject","@id":"https://theslanted.com/#logo","inLanguage":"en-US","url":"https://theslanted.com/wp-content/uploads/2018/03/Slanted-Topper.png","width":335,"height":100,"caption":"Slanted"},"image":{"@id":"https://theslanted.com/#logo"}},{"@type":"WebSite","@id":"https://theslanted.com/#website","url":"https://theslanted.com/","name":"Slanted","description":"Pop Cultured","publisher":{"@id":"https://theslanted.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://theslanted.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://theslanted.com/2021/03/46896/man-who-fell-to-earth-series-naomi-harris-cast-showtime/#primaryimage","inLanguage":"en-US","url":"https://theslanted.com/wp-content/uploads/2020/04/Naomie-Harris.jpg","width":1200,"height":640,"caption":"sony pictures"},{"@type":"WebPage","@id":"https://theslanted.com/2021/03/46896/man-who-fell-to-earth-series-naomi-harris-cast-showtime/#webpage","url":"https://theslanted.com/2021/03/46896/man-who-fell-to-earth-series-naomi-harris-cast-showtime/","name":"Naomie Harris Joins 'Man Who Fell to Earth' Series","isPartOf":{"@id":"https://theslanted.com/#website"},"primaryImageOfPage":{"@id":"https://theslanted.com/2021/03/46896/man-who-fell-to-earth-series-naomi-harris-cast-showtime/#primaryimage"},"datePublished":"2021-03-26T19:28:44+00:00","dateModified":"2021-03-26T19:28:45+00:00","description":"Naomie Harris will star in Showtime's upcoming \"The Man Who Fell to Earth\" adaptation, starring alongside Chiwetel Ejiofor in the drama.","breadcrumb":{"@id":"https://theslanted.com/2021/03/46896/man-who-fell-to-earth-series-naomi-harris-cast-showtime/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://theslanted.com/2021/03/46896/man-who-fell-to-earth-series-naomi-harris-cast-showtime/"]}]},{"@type":"BreadcrumbList","@id":"https://theslanted.com/2021/03/46896/man-who-fell-to-earth-series-naomi-harris-cast-showtime/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://theslanted.com/","url":"https://theslanted.com/","name":"Slanted"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://theslanted.com/coverage/television/","url":"https://theslanted.com/coverage/television/","name":"TV"}},{"@type":"ListItem","position":3,"item":{"@type":"WebPage","@id":"https://theslanted.com/2021/03/46896/man-who-fell-to-earth-series-naomi-harris-cast-showtime/","url":"https://theslanted.com/2021/03/46896/man-who-fell-to-earth-series-naomi-harris-cast-showtime/","name":"Naomie Harris Joins &#8216;Man Who Fell to Earth&#8217; Series"}}]},{"@type":["Article","NewsArticle"],"@id":"https://theslanted.com/2021/03/46896/man-who-fell-to-earth-series-naomi-harris-cast-showtime/#article","isPartOf":{"@id":"https://theslanted.com/2021/03/46896/man-who-fell-to-earth-series-naomi-harris-cast-showtime/#webpage"},"author":{"@id":"https://theslanted.com/#/schema/person/92802e25010a358e7fdd807e1dc4f4fd"},"headline":"Naomie Harris Joins &#8216;Man Who Fell to Earth&#8217; Series","datePublished":"2021-03-26T19:28:44+00:00","dateModified":"2021-03-26T19:28:45+00:00","mainEntityOfPage":{"@id":"https://theslanted.com/2021/03/46896/man-who-fell-to-earth-series-naomi-harris-cast-showtime/#webpage"},"publisher":{"@id":"https://theslanted.com/#organization"},"image":{"@id":"https://theslanted.com/2021/03/46896/man-who-fell-to-earth-series-naomi-harris-cast-showtime/#primaryimage"},"keywords":"Casting,Showtime","articleSection":"TV News","inLanguage":"en-US","copyrightYear":"2021","copyrightHolder":{"@id":"https://theslanted.com/#organization"}},{"@type":"Person","@id":"https://theslanted.com/#/schema/person/92802e25010a358e7fdd807e1dc4f4fd","name":"Sarah Fox","image":{"@type":"ImageObject","@id":"https://theslanted.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/a6dee5f3ed42423fd798b9a8e9037311?s=96&d=mm&r=g","caption":"Sarah Fox"},"sameAs":["https://twitter.com/https://twitter.com/sarahfoxes"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel="amphtml" href="https://theslanted.com/2021/03/46896/man-who-fell-to-earth-series-naomi-harris-cast-showtime/amp/" /><meta name="generator" content="AMP for WP 1.0.76.7"/><link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Slanted &raquo; Feed" href="https://theslanted.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Slanted &raquo; Comments Feed" href="https://theslanted.com/comments/feed/" />
			<link rel="preload" href="https://theslanted.com/wp-content/plugins/canvas/assets/fonts/canvas-icons.woff" as="font" type="font/woff" crossorigin>
						<link rel="preload" href="https://theslanted.com/wp-content/plugins/powerkit/assets/fonts/powerkit-icons.woff" as="font" type="font/woff" crossorigin>
			<link rel='stylesheet' id='canvas-css'  href='https://theslanted.com/wp-content/plugins/canvas/assets/css/canvas.css?ver=2.1.8' media='all' />
<link rel='stylesheet' id='powerkit-css'  href='https://theslanted.com/wp-content/plugins/powerkit/assets/css/powerkit.css?ver=2.4.8' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://theslanted.com/wp-includes/css/dist/block-library/style.min.css?ver=5.7' media='all' />
<link rel='stylesheet' id='canvas-block-alert-style-css'  href='https://theslanted.com/wp-content/plugins/canvas/components/basic-elements/block-alert/block.css?ver=1616391421' media='all' />
<link rel='stylesheet' id='canvas-block-progress-style-css'  href='https://theslanted.com/wp-content/plugins/canvas/components/basic-elements/block-progress/block.css?ver=1616391421' media='all' />
<link rel='stylesheet' id='canvas-block-collapsibles-style-css'  href='https://theslanted.com/wp-content/plugins/canvas/components/basic-elements/block-collapsibles/block.css?ver=1616391421' media='all' />
<link rel='stylesheet' id='canvas-block-tabs-style-css'  href='https://theslanted.com/wp-content/plugins/canvas/components/basic-elements/block-tabs/block.css?ver=1616391421' media='all' />
<link rel='stylesheet' id='canvas-block-section-heading-style-css'  href='https://theslanted.com/wp-content/plugins/canvas/components/basic-elements/block-section-heading/block.css?ver=1616391421' media='all' />
<link rel='stylesheet' id='canvas-block-row-style-css'  href='https://theslanted.com/wp-content/plugins/canvas/components/layout-blocks/block-row/block-row.css?ver=1616391420' media='all' />
<link rel='stylesheet' id='canvas-justified-gallery-block-style-css'  href='https://theslanted.com/wp-content/plugins/canvas/components/justified-gallery/block/block-justified-gallery.css?ver=1616391421' media='all' />
<link rel='stylesheet' id='canvas-slider-gallery-block-style-css'  href='https://theslanted.com/wp-content/plugins/canvas/components/slider-gallery/block/block-slider-gallery.css?ver=1616391420' media='all' />
<link rel='stylesheet' id='canvas-block-posts-sidebar-css'  href='https://theslanted.com/wp-content/plugins/canvas/components/posts/block-posts-sidebar/block-posts-sidebar.css?ver=1616391421' media='all' />
<link rel='stylesheet' id='absolute-reviews-css'  href='https://theslanted.com/wp-content/plugins/absolute-reviews/public/css/absolute-reviews-public.css?ver=1.0.8' media='all' />
<link rel='stylesheet' id='advanced-popups-css'  href='https://theslanted.com/wp-content/plugins/advanced-popups/public/css/advanced-popups-public.css?ver=1.1.0' media='all' />
<link rel='stylesheet' id='canvas-block-heading-style-css'  href='https://theslanted.com/wp-content/plugins/canvas/components/content-formatting/block-heading/block.css?ver=1616391421' media='all' />
<link rel='stylesheet' id='canvas-block-list-style-css'  href='https://theslanted.com/wp-content/plugins/canvas/components/content-formatting/block-list/block.css?ver=1616391421' media='all' />
<link rel='stylesheet' id='canvas-block-paragraph-style-css'  href='https://theslanted.com/wp-content/plugins/canvas/components/content-formatting/block-paragraph/block.css?ver=1616391421' media='all' />
<link rel='stylesheet' id='canvas-block-separator-style-css'  href='https://theslanted.com/wp-content/plugins/canvas/components/content-formatting/block-separator/block.css?ver=1616391421' media='all' />
<link rel='stylesheet' id='canvas-block-group-style-css'  href='https://theslanted.com/wp-content/plugins/canvas/components/basic-elements/block-group/block.css?ver=1616391421' media='all' />
<link rel='stylesheet' id='canvas-block-cover-style-css'  href='https://theslanted.com/wp-content/plugins/canvas/components/basic-elements/block-cover/block.css?ver=1616391421' media='all' />
<link rel='stylesheet' id='powerkit-author-box-css'  href='https://theslanted.com/wp-content/plugins/powerkit/modules/author-box/public/css/public-powerkit-author-box.css?ver=2.4.8' media='all' />
<link rel='stylesheet' id='powerkit-basic-elements-css'  href='https://theslanted.com/wp-content/plugins/powerkit/modules/basic-elements/public/css/public-powerkit-basic-elements.css?ver=2.4.8' media='screen' />
<link rel='stylesheet' id='powerkit-coming-soon-css'  href='https://theslanted.com/wp-content/plugins/powerkit/modules/coming-soon/public/css/public-powerkit-coming-soon.css?ver=2.4.8' media='all' />
<link rel='stylesheet' id='powerkit-content-formatting-css'  href='https://theslanted.com/wp-content/plugins/powerkit/modules/content-formatting/public/css/public-powerkit-content-formatting.css?ver=2.4.8' media='all' />
<link rel='stylesheet' id='powerkit-сontributors-css'  href='https://theslanted.com/wp-content/plugins/powerkit/modules/contributors/public/css/public-powerkit-contributors.css?ver=2.4.8' media='all' />
<link rel='stylesheet' id='powerkit-facebook-css'  href='https://theslanted.com/wp-content/plugins/powerkit/modules/facebook/public/css/public-powerkit-facebook.css?ver=2.4.8' media='all' />
<link rel='stylesheet' id='powerkit-featured-categories-css'  href='https://theslanted.com/wp-content/plugins/powerkit/modules/featured-categories/public/css/public-powerkit-featured-categories.css?ver=2.4.8' media='all' />
<link rel='stylesheet' id='powerkit-inline-posts-css'  href='https://theslanted.com/wp-content/plugins/powerkit/modules/inline-posts/public/css/public-powerkit-inline-posts.css?ver=2.4.8' media='all' />
<link rel='stylesheet' id='powerkit-instagram-css'  href='https://theslanted.com/wp-content/plugins/powerkit/modules/instagram/public/css/public-powerkit-instagram.css?ver=2.4.8' media='all' />
<link rel='stylesheet' id='powerkit-justified-gallery-css'  href='https://theslanted.com/wp-content/plugins/powerkit/modules/justified-gallery/public/css/public-powerkit-justified-gallery.css?ver=2.4.8' media='all' />
<link rel='stylesheet' id='magnific-popup-css'  href='https://theslanted.com/wp-content/themes/newsblock/assets/css/magnific-popup.css?ver=1.1.4' media='all' />
<link rel='stylesheet' id='powerkit-lightbox-css'  href='https://theslanted.com/wp-content/plugins/powerkit/modules/lightbox/public/css/public-powerkit-lightbox.css?ver=2.4.8' media='all' />
<link rel='stylesheet' id='powerkit-opt-in-forms-css'  href='https://theslanted.com/wp-content/plugins/powerkit/modules/opt-in-forms/public/css/public-powerkit-opt-in-forms.css?ver=2.4.8' media='all' />
<link rel='stylesheet' id='powerkit-pinterest-css'  href='https://theslanted.com/wp-content/plugins/powerkit/modules/pinterest/public/css/public-powerkit-pinterest.css?ver=2.4.8' media='all' />
<link rel='stylesheet' id='powerkit-scroll-to-top-css'  href='https://theslanted.com/wp-content/plugins/powerkit/modules/scroll-to-top/public/css/public-powerkit-scroll-to-top.css?ver=2.4.8' media='all' />
<link rel='stylesheet' id='powerkit-share-buttons-css'  href='https://theslanted.com/wp-content/plugins/powerkit/modules/share-buttons/public/css/public-powerkit-share-buttons.css?ver=2.4.8' media='all' />
<link rel='stylesheet' id='powerkit-slider-gallery-css'  href='https://theslanted.com/wp-content/plugins/powerkit/modules/slider-gallery/public/css/public-powerkit-slider-gallery.css?ver=2.4.8' media='all' />
<link rel='stylesheet' id='powerkit-social-links-css'  href='https://theslanted.com/wp-content/plugins/powerkit/modules/social-links/public/css/public-powerkit-social-links.css?ver=2.4.8' media='all' />
<link rel='stylesheet' id='powerkit-table-of-contents-css'  href='https://theslanted.com/wp-content/plugins/powerkit/modules/table-of-contents/public/css/public-powerkit-table-of-contents.css?ver=2.4.8' media='all' />
<link rel='stylesheet' id='powerkit-twitter-css'  href='https://theslanted.com/wp-content/plugins/powerkit/modules/twitter/public/css/public-powerkit-twitter.css?ver=2.4.8' media='all' />
<link rel='stylesheet' id='powerkit-widget-about-css'  href='https://theslanted.com/wp-content/plugins/powerkit/modules/widget-about/public/css/public-powerkit-widget-about.css?ver=2.4.8' media='all' />
<link rel='stylesheet' id='csco-styles-css'  href='https://theslanted.com/wp-content/themes/newsblock/style.css?ver=1.1.4' media='all' />
<style id='csco-styles-inline-css'>
.searchwp-live-search-no-min-chars:after { content: "Continue typing" }
</style>
<link rel='stylesheet' id='searchwp-live-search-css'  href='https://theslanted.com/wp-content/plugins/searchwp-live-ajax-search/assets/styles/style.css?ver=1.6.1' media='all' />
<script src='https://theslanted.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>


<script defer src='https://www.googletagmanager.com/gtag/js?id=UA-40601418-1#038;siteground-async=1' id='google_gtagjs-js' async></script>
<script defer id='google_gtagjs-js-after'>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-40601418-1", {"anonymize_ip":true});
</script>
<link rel="https://api.w.org/" href="https://theslanted.com/wp-json/" /><link rel="alternate" type="application/json" href="https://theslanted.com/wp-json/wp/v2/posts/46896" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://theslanted.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://theslanted.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7" />
<link rel='shortlink' href='https://bit.ly/3swfZba' />
<link rel="alternate" type="application/json+oembed" href="https://theslanted.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftheslanted.com%2F2021%2F03%2F46896%2Fman-who-fell-to-earth-series-naomi-harris-cast-showtime%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://theslanted.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftheslanted.com%2F2021%2F03%2F46896%2Fman-who-fell-to-earth-series-naomi-harris-cast-showtime%2F&#038;format=xml" />
		<link rel="preload" href="https://theslanted.com/wp-content/plugins/absolute-reviews/fonts/absolute-reviews-icons.woff" as="font" type="font/woff" crossorigin>
				<link rel="preload" href="https://theslanted.com/wp-content/plugins/advanced-popups/fonts/advanced-popups-icons.woff" as="font" type="font/woff" crossorigin>
		
<style type="text/css" media="all" id="canvas-blocks-dynamic-styles">

</style>
<meta name="generator" content="Site Kit by Google 1.28.0" /><style id='csco-theme-typography'>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</style>
<link rel="icon" href="https://theslanted.com/wp-content/uploads/2020/11/cropped-android-chrome-512x512-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://theslanted.com/wp-content/uploads/2020/11/cropped-android-chrome-512x512-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://theslanted.com/wp-content/uploads/2020/11/cropped-android-chrome-512x512-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://theslanted.com/wp-content/uploads/2020/11/cropped-android-chrome-512x512-1-270x270.png" />
<style id="kirki-inline-styles">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</style><link rel="dns-prefetch" href="//fonts.gstatic.com" data-set-by="SG Optimizer"/><link rel="dns-prefetch" href="//platform.twitter.com" data-set-by="SG Optimizer"/><link rel="dns-prefetch" href="//googletagmanager.com" data-set-by="SG Optimizer"/><link rel="dns-prefetch" href="//google-analytics.com" data-set-by="SG Optimizer"/><link rel="dns-prefetch" href="//secure.gravatar.com" data-set-by="SG Optimizer"/><link rel="dns-prefetch" href="//assets.pinterest.com" data-set-by="SG Optimizer"/><link rel="dns-prefetch" href="//connect.facebook.net" data-set-by="SG Optimizer"/></head>

<body class="post-template-default single single-post postid-46896 single-format-standard wp-embed-responsive cs-page-layout-disabled cs-navbar-sticky-enabled cs-sticky-sidebar-enabled cs-stick-to-top" data-scheme='default' site-data-scheme='default'>



	<div class="cs-site-overlay"></div>

	<div class="cs-offcanvas">
		<div class="cs-offcanvas__header" data-scheme="default">
			
			<nav class="cs-offcanvas__nav">
						<div class="cs-logo ">
			<a class="cs-header__logo cs-logo-default " href="https://theslanted.com/">
				<img src="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png"  alt="Slanted" >			</a>

									<a class="cs-header__logo cs-logo-dark " href="https://theslanted.com/">
							<img src="https://theslanted.com/wp-content/uploads/2021/03/Slanted-Dark-Mode.png"  alt="Slanted" >						</a>
							</div>
		
				<span class="cs-offcanvas__toggle" role="button"><i class="cs-icon cs-icon-x"></i></span>
			</nav>

					</div>
		<aside class="cs-offcanvas__sidebar">
			<div class="cs-offcanvas__inner cs-offcanvas__area cs-widget-area">
				
				<div class="widget nav_menu-2 widget_nav_menu"><h5 class="cs-section-heading cnvs-block-section-heading is-style-cnvs-block-section-heading-default halignleft  "><span class="cnvs-section-title"><span>Navigation</span></span></h5><div class="menu-normal-menu-container"><ul id="menu-normal-menu" class="menu"><li id="menu-item-32978" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-32978"><a title="Slanted" href="https://theslanted.com/">Home</a></li>
<li id="menu-item-39495" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39495"><a title="Movie &#038; TV Headlines" href="https://theslanted.com/movies-tv/">Movies &#038; TV</a></li>
<li id="menu-item-39224" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39224"><a title="New Release Dates" href="https://theslanted.com/2020/03/39133/movie-releases-put-on-hold-as-coronovirus-closes-theaters-updating/">Movie Delays</a></li>
<li id="menu-item-39496" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39496"><a title="Recent Releases" href="https://theslanted.com/weekend-box-office/">Box Office | Digital</a></li>
<li id="menu-item-39497" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39497"><a title="Apps, Games and Tech" href="https://theslanted.com/lifestyle/">Tech &#038; Lifestyle</a></li>
<li id="menu-item-39498" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39498"><a title="Trending Topics" href="https://theslanted.com/culture-celebrity/">Culture &#038; Celebrity</a></li>
<li id="menu-item-32990" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32990"><a title="Your Daily Dose" href="https://theslanted.com/subscribe/">Subscribe</a></li>
<li id="menu-item-39499" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39499"><a title="Privacy Notice" href="https://theslanted.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-39500" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39500"><a title="Email" href="https://theslanted.com/about/">Contact Us</a></li>
</ul></div></div>			</div>
		</aside>
	</div>
	
<div id="page" class="cs-site">

	
	<div class="cs-site-inner">

		
		
<header class="cs-header cs-header-two" data-scheme="default">
	<div class="cs-container">
		<div class="cs-header__inner cs-header__inner-desktop">
			<div class="cs-header__col cs-col-left">
								<span class="cs-header__offcanvas-toggle " role="button">
					<i class="cs-icon cs-icon-menu"></i>
				</span>
					<span class="cs-header__search-toggle" role="button">
			<i class="cs-icon cs-icon-search"></i>
		</span>
					</div>
			<div class="cs-header__col cs-col-center">
						<div class="cs-logo ">
			<a class="cs-header__logo cs-logo-default " href="https://theslanted.com/">
				<img src="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png"  alt="Slanted" >			</a>

									<a class="cs-header__logo cs-logo-dark " href="https://theslanted.com/">
							<img src="https://theslanted.com/wp-content/uploads/2021/03/Slanted-Dark-Mode.png"  alt="Slanted" >						</a>
							</div>
					</div>
			<div class="cs-header__col cs-col-right">
							<span role="button" class="cs-header__scheme-toggle cs-site-scheme-toggle">
				<i class="cs-header__scheme-toggle-icon cs-icon cs-icon-sun"></i>
				<span class="cs-header__scheme-toggle-element"></span>
				<i class="cs-header__scheme-toggle-icon cs-icon cs-icon-moon"></i>
			</span>
					</div>
		</div>

		
<div class="cs-header__inner cs-header__inner-mobile">
	<div class="cs-header__col cs-col-left">
						<span class="cs-header__offcanvas-toggle " role="button">
					<i class="cs-icon cs-icon-menu"></i>
				</span>
				</div>
	<div class="cs-header__col cs-col-center">
				<div class="cs-logo ">
			<a class="cs-header__logo cs-logo-default " href="https://theslanted.com/">
				<img src="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png"  alt="Slanted" >			</a>

									<a class="cs-header__logo cs-logo-dark " href="https://theslanted.com/">
							<img src="https://theslanted.com/wp-content/uploads/2021/03/Slanted-Dark-Mode.png"  alt="Slanted" >						</a>
							</div>
			</div>
	<div class="cs-header__col cs-col-right">
				<span role="button" class="cs-header__scheme-toggle cs-header__scheme-toggle-mobile cs-site-scheme-toggle">
			<i class="cs-header__scheme-toggle-icon cs-icon cs-icon-sun"></i>
			<i class="cs-header__scheme-toggle-icon cs-icon cs-icon-moon"></i>
		</span>
						<span class="cs-header__search-toggle" role="button">
			<i class="cs-icon cs-icon-search"></i>
		</span>
			</div>
</div>
	</div>

	
<div class="cs-search" data-scheme="dark">
	<div class="cs-container">
		<form role="search" method="get" class="cs-search__nav-form" action="https://theslanted.com/">
			<div class="cs-search__group">
				<button class="cs-search__submit">
					<i class="cs-icon cs-icon-search"></i>
				</button>

				<input data-swpparentel=".cs-header .cs-search-live-result" required class="cs-search__input" data-swplive="true" type="search" value="" name="s" placeholder="Enter your search topic">

				<button class="cs-search__close">
					<i class="cs-icon cs-icon-x"></i>
				</button>
			</div>
		</form>

		<div class="cs-search__content">
								<div class="cs-search__posts">
						<h5 class="cs-section-heading cnvs-block-section-heading is-style-cnvs-block-section-heading-default halignleft  "><span class="cnvs-section-title"><span>The Latest</span></span></h5>
						<div class="cs-search__posts-wrapper">
															<article class="post-46901 post type-post status-publish format-standard has-post-thumbnail category-television tag-tv-trailers cs-entry cs-video-wrap">
									<div class="cs-entry__outer">
																					<div class="cs-entry__inner cs-entry__thumbnail cs-entry__overlay cs-overlay-ratio cs-ratio-square" data-scheme="inverse">
												<div class="cs-overlay-background cs-overlay-transparent">
													<img width="110" height="110" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2021/03/Fall-River-110x110.jpg" class="attachment-csco-small size-csco-small wp-post-image lazyload" alt="Fall River" data-srcset="https://theslanted.com/wp-content/uploads/2021/03/Fall-River-110x110.jpg 110w, https://theslanted.com/wp-content/uploads/2021/03/Fall-River-250x250.jpg 250w, https://theslanted.com/wp-content/uploads/2021/03/Fall-River-80x80.jpg 80w" sizes="(max-width: 110px) 100vw, 110px" /><noscript><img width="110" height="110" src="https://theslanted.com/wp-content/uploads/2021/03/Fall-River-110x110.jpg" class="attachment-csco-small size-csco-small wp-post-image lazyload" alt="Fall River" srcset="https://theslanted.com/wp-content/uploads/2021/03/Fall-River-110x110.jpg 110w, https://theslanted.com/wp-content/uploads/2021/03/Fall-River-250x250.jpg 250w, https://theslanted.com/wp-content/uploads/2021/03/Fall-River-80x80.jpg 80w" sizes="(max-width: 110px) 100vw, 110px" /></noscript>												</div>

												<a href="https://theslanted.com/2021/03/46901/fall-river-docuseries-epix-premiere-date-may/" class="cs-overlay-link"></a>
											</div>
										
										<div class="cs-entry__inner cs-entry__content">
											<h6 class="cs-entry__title"><a href="https://theslanted.com/2021/03/46901/fall-river-docuseries-epix-premiere-date-may/">Blumhouse&#8217;s &#8216;Fall River&#8217; Docuseries to Premiere in May</a></h6>
											<div class="cs-entry__post-meta" ></div>										</div>
									</div>
								</article>
															<article class="post-46898 post type-post status-publish format-standard has-post-thumbnail category-film tag-blu-ray-releases tag-trailers cs-entry cs-video-wrap">
									<div class="cs-entry__outer">
																					<div class="cs-entry__inner cs-entry__thumbnail cs-entry__overlay cs-overlay-ratio cs-ratio-square" data-scheme="inverse">
												<div class="cs-overlay-background cs-overlay-transparent">
													<img width="110" height="110" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2021/03/Wildcat-110x110.jpg" class="attachment-csco-small size-csco-small wp-post-image lazyload" alt="Wildcat" data-srcset="https://theslanted.com/wp-content/uploads/2021/03/Wildcat-110x110.jpg 110w, https://theslanted.com/wp-content/uploads/2021/03/Wildcat-250x250.jpg 250w, https://theslanted.com/wp-content/uploads/2021/03/Wildcat-80x80.jpg 80w" sizes="(max-width: 110px) 100vw, 110px" /><noscript><img width="110" height="110" src="https://theslanted.com/wp-content/uploads/2021/03/Wildcat-110x110.jpg" class="attachment-csco-small size-csco-small wp-post-image lazyload" alt="Wildcat" srcset="https://theslanted.com/wp-content/uploads/2021/03/Wildcat-110x110.jpg 110w, https://theslanted.com/wp-content/uploads/2021/03/Wildcat-250x250.jpg 250w, https://theslanted.com/wp-content/uploads/2021/03/Wildcat-80x80.jpg 80w" sizes="(max-width: 110px) 100vw, 110px" /></noscript>												</div>

												<a href="https://theslanted.com/2021/03/46898/wildcat-movie-georgina-campbell-thriller-digital-release/" class="cs-overlay-link"></a>
											</div>
										
										<div class="cs-entry__inner cs-entry__content">
											<h6 class="cs-entry__title"><a href="https://theslanted.com/2021/03/46898/wildcat-movie-georgina-campbell-thriller-digital-release/">Georgina Campbell&#8217;s &#8216;Wildcat&#8217; Goes Digital in April</a></h6>
											<div class="cs-entry__post-meta" ></div>										</div>
									</div>
								</article>
															<article class="post-46896 post type-post status-publish format-standard has-post-thumbnail category-television tag-casting tag-showtime cs-entry cs-video-wrap">
									<div class="cs-entry__outer">
																					<div class="cs-entry__inner cs-entry__thumbnail cs-entry__overlay cs-overlay-ratio cs-ratio-square" data-scheme="inverse">
												<div class="cs-overlay-background cs-overlay-transparent">
													<img width="110" height="110" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/04/Naomie-Harris-110x110.jpg" class="attachment-csco-small size-csco-small wp-post-image lazyload" alt="Naomie Harris on red carpet" data-srcset="https://theslanted.com/wp-content/uploads/2020/04/Naomie-Harris-110x110.jpg 110w, https://theslanted.com/wp-content/uploads/2020/04/Naomie-Harris-250x250.jpg 250w, https://theslanted.com/wp-content/uploads/2020/04/Naomie-Harris-80x80.jpg 80w" sizes="(max-width: 110px) 100vw, 110px" /><noscript><img width="110" height="110" src="https://theslanted.com/wp-content/uploads/2020/04/Naomie-Harris-110x110.jpg" class="attachment-csco-small size-csco-small wp-post-image lazyload" alt="Naomie Harris on red carpet" srcset="https://theslanted.com/wp-content/uploads/2020/04/Naomie-Harris-110x110.jpg 110w, https://theslanted.com/wp-content/uploads/2020/04/Naomie-Harris-250x250.jpg 250w, https://theslanted.com/wp-content/uploads/2020/04/Naomie-Harris-80x80.jpg 80w" sizes="(max-width: 110px) 100vw, 110px" /></noscript>												</div>

												<a href="https://theslanted.com/2021/03/46896/man-who-fell-to-earth-series-naomi-harris-cast-showtime/" class="cs-overlay-link"></a>
											</div>
										
										<div class="cs-entry__inner cs-entry__content">
											<h6 class="cs-entry__title"><a href="https://theslanted.com/2021/03/46896/man-who-fell-to-earth-series-naomi-harris-cast-showtime/">Naomie Harris Joins &#8216;Man Who Fell to Earth&#8217; Series</a></h6>
											<div class="cs-entry__post-meta" ></div>										</div>
									</div>
								</article>
															<article class="post-46893 post type-post status-publish format-standard has-post-thumbnail category-television tag-appletv cs-entry cs-video-wrap">
									<div class="cs-entry__outer">
																					<div class="cs-entry__inner cs-entry__thumbnail cs-entry__overlay cs-overlay-ratio cs-ratio-square" data-scheme="inverse">
												<div class="cs-overlay-background cs-overlay-transparent">
													<img width="110" height="110" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/03/Home-Before-Dark-110x110.jpg" class="attachment-csco-small size-csco-small wp-post-image lazyload" alt="Home Before Dark" data-srcset="https://theslanted.com/wp-content/uploads/2020/03/Home-Before-Dark-110x110.jpg 110w, https://theslanted.com/wp-content/uploads/2020/03/Home-Before-Dark-250x250.jpg 250w, https://theslanted.com/wp-content/uploads/2020/03/Home-Before-Dark-80x80.jpg 80w" sizes="(max-width: 110px) 100vw, 110px" /><noscript><img width="110" height="110" src="https://theslanted.com/wp-content/uploads/2020/03/Home-Before-Dark-110x110.jpg" class="attachment-csco-small size-csco-small wp-post-image lazyload" alt="Home Before Dark" srcset="https://theslanted.com/wp-content/uploads/2020/03/Home-Before-Dark-110x110.jpg 110w, https://theslanted.com/wp-content/uploads/2020/03/Home-Before-Dark-250x250.jpg 250w, https://theslanted.com/wp-content/uploads/2020/03/Home-Before-Dark-80x80.jpg 80w" sizes="(max-width: 110px) 100vw, 110px" /></noscript>												</div>

												<a href="https://theslanted.com/2021/03/46893/home-before-dark-season-2-premiere-june/" class="cs-overlay-link"></a>
											</div>
										
										<div class="cs-entry__inner cs-entry__content">
											<h6 class="cs-entry__title"><a href="https://theslanted.com/2021/03/46893/home-before-dark-season-2-premiere-june/">&#8216;Home Before Dark&#8217; Returns for Season 2 in June</a></h6>
											<div class="cs-entry__post-meta" ></div>										</div>
									</div>
								</article>
													</div>
					</div>
					
								<div class="cs-search__tags">
						<ul>
															<li>
									<a href="https://theslanted.com/topic/warner-bros-pictures/" rel="tag">
										Warner Bros Pictures									</a>
								</li>
															<li>
									<a href="https://theslanted.com/topic/universal-pictures/" rel="tag">
										Universal Pictures									</a>
								</li>
															<li>
									<a href="https://theslanted.com/topic/tv-trailers/" rel="tag">
										TV Trailers									</a>
								</li>
															<li>
									<a href="https://theslanted.com/topic/tnt/" rel="tag">
										TNT									</a>
								</li>
															<li>
									<a href="https://theslanted.com/topic/the-weinstein-company/" rel="tag">
										The Weinstein Company									</a>
								</li>
															<li>
									<a href="https://theslanted.com/topic/teen-choice-awards/" rel="tag">
										Teen Choice Awards									</a>
								</li>
															<li>
									<a href="https://theslanted.com/topic/tbs/" rel="tag">
										TBS									</a>
								</li>
															<li>
									<a href="https://theslanted.com/topic/syfy/" rel="tag">
										SyFy									</a>
								</li>
															<li>
									<a href="https://theslanted.com/topic/sxsw/" rel="tag">
										SXSW									</a>
								</li>
															<li>
									<a href="https://theslanted.com/topic/sundance-film-festival/" rel="tag">
										Sundance Film Festival									</a>
								</li>
													</ul>
					</div>
					
			<div class="cs-search-live-result"></div>
		</div>
	</div>
</div>
</header>

		
		<main id="main" class="cs-site-primary">

			
			<div class="cs-site-content cs-sidebar-disabled cs-metabar-enabled section-heading-default-style-3">

				
				<div class="cs-container">

					
					<div id="content" class="cs-main-content">

						
<div id="primary" class="cs-content-area">

	
	<div class="cs-breadcrumbs" id="breadcrumbs"><span><span><a href="https://theslanted.com/">Slanted</a> <span class="cs-separator"></span> <span><a href="https://theslanted.com/coverage/television/">TV</a> <span class="cs-separator"></span> <span class="breadcrumb_last" aria-current="page">Naomie Harris Joins &#8216;Man Who Fell to Earth&#8217; Series</span></span></span></span></div>
	<div class="cs-entry__header cs-entry__header-standard cs-video-wrap">
		<div class="cs-entry__header-inner">

							<figure class="cs-entry__post-media post-media">
					<img width="1160" height="619" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/04/Naomie-Harris-1160x619.jpg" class="attachment-csco-large-uncropped size-csco-large-uncropped wp-post-image lazyload" alt="Naomie Harris on red carpet" data-srcset="https://theslanted.com/wp-content/uploads/2020/04/Naomie-Harris-1160x619.jpg 1160w, https://theslanted.com/wp-content/uploads/2020/04/Naomie-Harris-360x192.jpg 360w, https://theslanted.com/wp-content/uploads/2020/04/Naomie-Harris-750x400.jpg 750w, https://theslanted.com/wp-content/uploads/2020/04/Naomie-Harris-768x410.jpg 768w, https://theslanted.com/wp-content/uploads/2020/04/Naomie-Harris-380x203.jpg 380w, https://theslanted.com/wp-content/uploads/2020/04/Naomie-Harris-800x427.jpg 800w, https://theslanted.com/wp-content/uploads/2020/04/Naomie-Harris.jpg 1200w" sizes="(max-width: 1160px) 100vw, 1160px" /><noscript><img width="1160" height="619" src="https://theslanted.com/wp-content/uploads/2020/04/Naomie-Harris-1160x619.jpg" class="attachment-csco-large-uncropped size-csco-large-uncropped wp-post-image lazyload" alt="Naomie Harris on red carpet" srcset="https://theslanted.com/wp-content/uploads/2020/04/Naomie-Harris-1160x619.jpg 1160w, https://theslanted.com/wp-content/uploads/2020/04/Naomie-Harris-360x192.jpg 360w, https://theslanted.com/wp-content/uploads/2020/04/Naomie-Harris-750x400.jpg 750w, https://theslanted.com/wp-content/uploads/2020/04/Naomie-Harris-768x410.jpg 768w, https://theslanted.com/wp-content/uploads/2020/04/Naomie-Harris-380x203.jpg 380w, https://theslanted.com/wp-content/uploads/2020/04/Naomie-Harris-800x427.jpg 800w, https://theslanted.com/wp-content/uploads/2020/04/Naomie-Harris.jpg 1200w" sizes="(max-width: 1160px) 100vw, 1160px" /></noscript>				</figure>
			
			<div class="cs-entry__header-info">
				<div class="cs-entry__category"><ul class="post-categories">
	<li><a href="https://theslanted.com/coverage/television/" rel="category tag">TV News</a></li></ul></div><h1 class="cs-entry__title cs-entry__title-line"><span>Naomie Harris Joins &#8216;Man Who Fell to Earth&#8217; Series</span></h1><div class="cs-entry__post-meta" ><div class="cs-meta-author"><a class="cs-meta-author-inner url fn n" href="https://theslanted.com/author/sarahfoxes/" title="View all posts by Sarah Fox"><span class="cs-photo"><img alt='' src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://secure.gravatar.com/avatar/a6dee5f3ed42423fd798b9a8e9037311?s=26&#038;d=mm&#038;r=g" data-srcset="https://secure.gravatar.com/avatar/a6dee5f3ed42423fd798b9a8e9037311?s=52&#038;d=mm&#038;r=g 2x" class='avatar avatar-26 photo lazyload' height='26' width='26' /><noscript><img alt='' src='https://secure.gravatar.com/avatar/a6dee5f3ed42423fd798b9a8e9037311?s=26&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/a6dee5f3ed42423fd798b9a8e9037311?s=52&#038;d=mm&#038;r=g 2x' class='avatar avatar-26 photo lazyload' height='26' width='26' /></noscript></span><span class="cs-by">by</span><span class="cs-author">Sarah Fox</span></a></div><div class="cs-meta-date">March 26, 2021</div></div>			</div>
		</div>
	</div>
	
	
		
			
<div class="cs-entry__wrap">

	
	<div class="cs-entry__container">

						<div class="cs-entry__metabar">
					<div class="cs-entry__metabar-inner">
								<div class="pk-share-buttons-wrap pk-share-buttons-layout-simple pk-share-buttons-scheme-simple-light pk-share-buttons-metabar-post pk-share-buttons-mode-php pk-share-buttons-mode-rest" data-post-id="46896" data-share-url="https://theslanted.com/2021/03/46896/man-who-fell-to-earth-series-naomi-harris-cast-showtime/" >

			
			<div class="pk-share-buttons-items">

										<div class="pk-share-buttons-item pk-share-buttons-facebook pk-share-buttons-no-count" data-id="facebook">

							<a href="https://www.facebook.com/sharer.php?u=https://bit.ly/3swfZba" class="pk-share-buttons-link" target="_blank">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-facebook"></i>
								
								
								
															</a>

							
							
													</div>
											<div class="pk-share-buttons-item pk-share-buttons-twitter pk-share-buttons-no-count" data-id="twitter">

							<a href="https://twitter.com/share?&text=Naomie%20Harris%20Joins%20%E2%80%98Man%20Who%20Fell%20to%20Earth%E2%80%99%20Series&via=theslanted&url=https://bit.ly/3swfZba" class="pk-share-buttons-link" target="_blank">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-twitter"></i>
								
								
								
															</a>

							
							
													</div>
											<div class="pk-share-buttons-item pk-share-buttons-reddit pk-share-buttons-no-count" data-id="reddit">

							<a href="http://www.reddit.com/submit?url=https://bit.ly/3swfZba" class="pk-share-buttons-link" target="_blank">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-reddit"></i>
								
								
								
															</a>

							
							
													</div>
											<div class="pk-share-buttons-item pk-share-buttons-mail pk-share-buttons-no-count" data-id="mail">

							<a href="mailto:?subject=Naomie%20Harris%20Joins%20%E2%80%98Man%20Who%20Fell%20to%20Earth%E2%80%99%20Series&body=Naomie%20Harris%20Joins%20%E2%80%98Man%20Who%20Fell%20to%20Earth%E2%80%99%20Series%20https://bit.ly/3swfZba" class="pk-share-buttons-link" target="_blank">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-mail"></i>
								
								
								
															</a>

							
							
													</div>
								</div>
		</div>
						</div>
				</div>
				
		<div class="cs-entry__content-wrap">
			
			<div class="entry-content">
				
<p>Showtime&#8217;s upcoming &#8220;<strong>The Man Who Fell to Earth</strong>&#8221; series added Oscar, BAFTA, Screen Actors Guild, and Golden Globe award nominee Naomie Harris to the cast list. Harris will play Justin Falls, a brilliant scientist and engineer who must conquer her own demons in the race to save two worlds.</p>



<p>“To be working with an actor of Naomie&#8217;s caliber is an absolute dream,” said Kurtzman, Lumet and Hlavin. “Her strength, her complexity and her bold artistic choices are an inspiration. We couldn’t be more thrilled to have her on board.”</p>



<p>Harris joins Oscar and Emmy nominee and BAFTA Award winner Chiwetel Ejiofor, and the series is slated to begin production in London this spring. The show was initially scheduled to premiere on Paramount+ but will now stream exclusively on Showtime in 2022.</p>



<p><a href="https://theslanted.com/2021/03/46885/dazed-and-confused-cast-reunion-special/">movies: Alamo Drafthouse Hosting a ‘Dazed and Confused’ Cast Reunion</a></p>



<p>The show&#8217;s description reads, &#8220;Based on the Walter Tevis novel of the same name and the iconic film that starred David Bowie, The Man Who Fell to Earth will follow a new alien character (Ejiofor) who arrives on Earth at a turning point in human evolution and must confront his own past to determine our future.&#8221;</p>



<p>Harris recently wrapped production on the feature film &#8220;Swan Song,&#8221; re-teaming her with Moonlight co-star, Mahershala Ali. She will next be seen in &#8220;Venom 2&#8221; and will reprise her role as Eve Moneypenny in the upcoming Bond film &#8220;No Time to Die.&#8221; Harris was nominated for Oscar, BAFTA and Golden Globe awards for Best Performance by a Supporting Actress for her work in the Oscar-winning feature film &#8220;Moonlight.&#8221;</p>



<p>The upcoming sci-fi drama is executive produced by Alex Kurtzman, Jenny Lumet, John Hlavin, Sarah Timberman, Carl Beverly, Heather Kadin and STUDIOCANAL’s Rola Bauer and Françoise Guyonnet. &#8220;The Man Who Fell to Earth&#8221; is produced by CBS Studios in association with Secret Hideout and Timberman/Beverly. </p>



<p><small>photo credit: sony pictures</small></p>



<p class="has-text-align-center"><strong><em>Subscribe to <a href="https://mailchi.mp/b0e4f9a92a86/slanted/"><span style="color:#9a58b5" class="has-inline-color">Daily Updates</span></a> and never miss a headline, or follow us on <a href="https://twitter.com/theslanted"><span style="color:#9a58b5" class="has-inline-color">Twitter</span></a></em></strong></p>
			</div>

			

<div class="cs-entry__author">
			<div class="cs-entry__author-inner">
			<a href="https://theslanted.com/author/sarahfoxes/" class="cs-entry__author-photo">
				<img alt='' src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://secure.gravatar.com/avatar/a6dee5f3ed42423fd798b9a8e9037311?s=100&#038;d=mm&#038;r=g" data-srcset="https://secure.gravatar.com/avatar/a6dee5f3ed42423fd798b9a8e9037311?s=200&#038;d=mm&#038;r=g 2x" class='avatar avatar-100 photo lazyload' height='100' width='100' /><noscript><img alt='' src='https://secure.gravatar.com/avatar/a6dee5f3ed42423fd798b9a8e9037311?s=100&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/a6dee5f3ed42423fd798b9a8e9037311?s=200&#038;d=mm&#038;r=g 2x' class='avatar avatar-100 photo lazyload' height='100' width='100' /></noscript>			</a>
			<div class="cs-entry__author-info">
				<span class="cs-entry__author-position">Author</span>
				<div class="cs-entry__author-name-wrapper">
					<a href="https://theslanted.com/author/sarahfoxes/" class="cs-entry__author-name">
						Sarah Fox					</a>

											<div class="cs-entry__author-social">
									<div class="pk-author-social-links pk-social-links-wrap pk-social-links-template-default">
			<div class="pk-social-links-items">
								<div class="pk-social-links-item pk-social-links-twitter">
					<a href="https://twitter.com/sarahfoxes" class="pk-social-links-link" target="_blank" rel="nofollow">
						<i class="pk-icon pk-icon-twitter"></i>
											</a>
				</div>
								</div>
		</div>
								</div>
									</div>
							</div>
		</div>
		</div>

		</div>

		
	</div>

	</div>

		
	
	
</div>


							
						</div>

								<div class="cs-entry__post-related">
			<h5 class="cs-section-heading cnvs-block-section-heading is-style-cnvs-block-section-heading-default halignleft  "><span class="cnvs-section-title"><span>Related Posts</span></span></h5>
			<div class="cs-entry__post-wrap">
				

<article class="post-46901 post type-post status-publish format-standard has-post-thumbnail category-television tag-tv-trailers cs-entry cs-video-wrap">

	<div class="cs-entry__outer">
						<div class="cs-entry__inner cs-entry__thumbnail cs-entry__overlay cs-overlay-ratio cs-ratio-original" data-scheme="inverse">

											<div class="cs-overlay-background">
							<img width="260" height="195" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2021/03/Fall-River-260x195.jpg" class="attachment-csco-thumbnail-small size-csco-thumbnail-small wp-post-image lazyload" alt="Fall River" data-srcset="https://theslanted.com/wp-content/uploads/2021/03/Fall-River-260x195.jpg 260w, https://theslanted.com/wp-content/uploads/2021/03/Fall-River-300x225.jpg 300w, https://theslanted.com/wp-content/uploads/2021/03/Fall-River-200x150.jpg 200w" sizes="(max-width: 260px) 100vw, 260px" /><noscript><img width="260" height="195" src="https://theslanted.com/wp-content/uploads/2021/03/Fall-River-260x195.jpg" class="attachment-csco-thumbnail-small size-csco-thumbnail-small wp-post-image lazyload" alt="Fall River" srcset="https://theslanted.com/wp-content/uploads/2021/03/Fall-River-260x195.jpg 260w, https://theslanted.com/wp-content/uploads/2021/03/Fall-River-300x225.jpg 300w, https://theslanted.com/wp-content/uploads/2021/03/Fall-River-200x150.jpg 200w" sizes="(max-width: 260px) 100vw, 260px" /></noscript>						</div>

						<div class="cs-overlay-content">
															<span class="cs-entry__read-more">Read More</span>
							
													</div>
					
					
					
					<a href="https://theslanted.com/2021/03/46901/fall-river-docuseries-epix-premiere-date-may/" class="cs-overlay-link"></a>
				</div>
			
		<div class="cs-entry__inner cs-entry__content">

			
			<h2 class="cs-entry__title"><a href="https://theslanted.com/2021/03/46901/fall-river-docuseries-epix-premiere-date-may/">Blumhouse&#8217;s &#8216;Fall River&#8217; Docuseries to Premiere in May</a></h2>
							<div class="cs-entry__excerpt">
					The four-part docuseries &#8220;Fall River&#8221; will premiere on Epix on May 16th. The network announced the premiere date&hellip;				</div>
			
					</div>
	</div>
</article>



<article class="post-46893 post type-post status-publish format-standard has-post-thumbnail category-television tag-appletv cs-entry cs-video-wrap">

	<div class="cs-entry__outer">
						<div class="cs-entry__inner cs-entry__thumbnail cs-entry__overlay cs-overlay-ratio cs-ratio-original" data-scheme="inverse">

											<div class="cs-overlay-background">
							<img width="260" height="195" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/03/Home-Before-Dark-260x195.jpg" class="attachment-csco-thumbnail-small size-csco-thumbnail-small wp-post-image lazyload" alt="Home Before Dark" data-srcset="https://theslanted.com/wp-content/uploads/2020/03/Home-Before-Dark-260x195.jpg 260w, https://theslanted.com/wp-content/uploads/2020/03/Home-Before-Dark-300x225.jpg 300w, https://theslanted.com/wp-content/uploads/2020/03/Home-Before-Dark-200x150.jpg 200w" sizes="(max-width: 260px) 100vw, 260px" /><noscript><img width="260" height="195" src="https://theslanted.com/wp-content/uploads/2020/03/Home-Before-Dark-260x195.jpg" class="attachment-csco-thumbnail-small size-csco-thumbnail-small wp-post-image lazyload" alt="Home Before Dark" srcset="https://theslanted.com/wp-content/uploads/2020/03/Home-Before-Dark-260x195.jpg 260w, https://theslanted.com/wp-content/uploads/2020/03/Home-Before-Dark-300x225.jpg 300w, https://theslanted.com/wp-content/uploads/2020/03/Home-Before-Dark-200x150.jpg 200w" sizes="(max-width: 260px) 100vw, 260px" /></noscript>						</div>

						<div class="cs-overlay-content">
															<span class="cs-entry__read-more">Read More</span>
							
													</div>
					
					
					
					<a href="https://theslanted.com/2021/03/46893/home-before-dark-season-2-premiere-june/" class="cs-overlay-link"></a>
				</div>
			
		<div class="cs-entry__inner cs-entry__content">

			
			<h2 class="cs-entry__title"><a href="https://theslanted.com/2021/03/46893/home-before-dark-season-2-premiere-june/">&#8216;Home Before Dark&#8217; Returns for Season 2 in June</a></h2>
							<div class="cs-entry__excerpt">
					Apple&#8217;s &#8220;Home Before Dark&#8221; series will return with new episodes in June. AppleTV confirmed that the show&#8217;s second&hellip;				</div>
			
					</div>
	</div>
</article>



<article class="post-46882 post type-post status-publish format-standard has-post-thumbnail category-television tag-amc tag-tv-trailers cs-entry cs-video-wrap">

	<div class="cs-entry__outer">
						<div class="cs-entry__inner cs-entry__thumbnail cs-entry__overlay cs-overlay-ratio cs-ratio-original" data-scheme="inverse">

											<div class="cs-overlay-background">
							<img width="260" height="195" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2021/03/Boys-From-County-Hell-260x195.jpg" class="attachment-csco-thumbnail-small size-csco-thumbnail-small wp-post-image lazyload" alt="Boys From County Hell" data-srcset="https://theslanted.com/wp-content/uploads/2021/03/Boys-From-County-Hell-260x195.jpg 260w, https://theslanted.com/wp-content/uploads/2021/03/Boys-From-County-Hell-300x225.jpg 300w, https://theslanted.com/wp-content/uploads/2021/03/Boys-From-County-Hell-200x150.jpg 200w" sizes="(max-width: 260px) 100vw, 260px" /><noscript><img width="260" height="195" src="https://theslanted.com/wp-content/uploads/2021/03/Boys-From-County-Hell-260x195.jpg" class="attachment-csco-thumbnail-small size-csco-thumbnail-small wp-post-image lazyload" alt="Boys From County Hell" srcset="https://theslanted.com/wp-content/uploads/2021/03/Boys-From-County-Hell-260x195.jpg 260w, https://theslanted.com/wp-content/uploads/2021/03/Boys-From-County-Hell-300x225.jpg 300w, https://theslanted.com/wp-content/uploads/2021/03/Boys-From-County-Hell-200x150.jpg 200w" sizes="(max-width: 260px) 100vw, 260px" /></noscript>						</div>

						<div class="cs-overlay-content">
															<span class="cs-entry__read-more">Read More</span>
							
													</div>
					
					
					
					<a href="https://theslanted.com/2021/03/46882/boys-from-county-hell-movie-shudder-april-premiere/" class="cs-overlay-link"></a>
				</div>
			
		<div class="cs-entry__inner cs-entry__content">

			
			<h2 class="cs-entry__title"><a href="https://theslanted.com/2021/03/46882/boys-from-county-hell-movie-shudder-april-premiere/">Irish Horror-Comedy &#8216;The Boys from County Hell&#8217; to Stream in April</a></h2>
							<div class="cs-entry__excerpt">
					Shudder has another horror exclusive to watch this spring. The streaming platform gave &#8220;The Boys from County Hell&#8221;&hellip;				</div>
			
					</div>
	</div>
</article>



<article class="post-46879 post type-post status-publish format-standard has-post-thumbnail category-television tag-appletv cs-entry cs-video-wrap">

	<div class="cs-entry__outer">
						<div class="cs-entry__inner cs-entry__thumbnail cs-entry__overlay cs-overlay-ratio cs-ratio-original" data-scheme="inverse">

											<div class="cs-overlay-background">
							<img width="260" height="195" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2021/03/Amanda-Gorman-260x195.jpg" class="attachment-csco-thumbnail-small size-csco-thumbnail-small wp-post-image lazyload" alt="Amanda Gorman" data-srcset="https://theslanted.com/wp-content/uploads/2021/03/Amanda-Gorman-260x195.jpg 260w, https://theslanted.com/wp-content/uploads/2021/03/Amanda-Gorman-300x225.jpg 300w, https://theslanted.com/wp-content/uploads/2021/03/Amanda-Gorman-200x150.jpg 200w" sizes="(max-width: 260px) 100vw, 260px" /><noscript><img width="260" height="195" src="https://theslanted.com/wp-content/uploads/2021/03/Amanda-Gorman-260x195.jpg" class="attachment-csco-thumbnail-small size-csco-thumbnail-small wp-post-image lazyload" alt="Amanda Gorman" srcset="https://theslanted.com/wp-content/uploads/2021/03/Amanda-Gorman-260x195.jpg 260w, https://theslanted.com/wp-content/uploads/2021/03/Amanda-Gorman-300x225.jpg 300w, https://theslanted.com/wp-content/uploads/2021/03/Amanda-Gorman-200x150.jpg 200w" sizes="(max-width: 260px) 100vw, 260px" /></noscript>						</div>

						<div class="cs-overlay-content">
															<span class="cs-entry__read-more">Read More</span>
							
													</div>
					
					
					
					<a href="https://theslanted.com/2021/03/46879/amanda-gorman-oprah-interview-appletv/" class="cs-overlay-link"></a>
				</div>
			
		<div class="cs-entry__inner cs-entry__content">

			
			<h2 class="cs-entry__title"><a href="https://theslanted.com/2021/03/46879/amanda-gorman-oprah-interview-appletv/">Amanda Gorman to Join Oprah on &#8216;The Oprah Conversation&#8217;</a></h2>
							<div class="cs-entry__excerpt">
					Amanda Gorman, the inspirational 23-year-old author and activist that found national attention and praise during the Presidential inauguration&hellip;				</div>
			
					</div>
	</div>
</article>



<article class="post-46870 post type-post status-publish format-standard has-post-thumbnail category-television tag-cbs cs-entry cs-video-wrap">

	<div class="cs-entry__outer">
						<div class="cs-entry__inner cs-entry__thumbnail cs-entry__overlay cs-overlay-ratio cs-ratio-original" data-scheme="inverse">

											<div class="cs-overlay-background">
							<img width="260" height="195" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/10/FBI-CBS-260x195.jpg" class="attachment-csco-thumbnail-small size-csco-thumbnail-small wp-post-image lazyload" alt="FBI Series" data-srcset="https://theslanted.com/wp-content/uploads/2020/10/FBI-CBS-260x195.jpg 260w, https://theslanted.com/wp-content/uploads/2020/10/FBI-CBS-300x225.jpg 300w, https://theslanted.com/wp-content/uploads/2020/10/FBI-CBS-200x150.jpg 200w" sizes="(max-width: 260px) 100vw, 260px" /><noscript><img width="260" height="195" src="https://theslanted.com/wp-content/uploads/2020/10/FBI-CBS-260x195.jpg" class="attachment-csco-thumbnail-small size-csco-thumbnail-small wp-post-image lazyload" alt="FBI Series" srcset="https://theslanted.com/wp-content/uploads/2020/10/FBI-CBS-260x195.jpg 260w, https://theslanted.com/wp-content/uploads/2020/10/FBI-CBS-300x225.jpg 300w, https://theslanted.com/wp-content/uploads/2020/10/FBI-CBS-200x150.jpg 200w" sizes="(max-width: 260px) 100vw, 260px" /></noscript>						</div>

						<div class="cs-overlay-content">
															<span class="cs-entry__read-more">Read More</span>
							
													</div>
					
					
					
					<a href="https://theslanted.com/2021/03/46870/fbi-international-series-cbs-season-1-order/" class="cs-overlay-link"></a>
				</div>
			
		<div class="cs-entry__inner cs-entry__content">

			
			<h2 class="cs-entry__title"><a href="https://theslanted.com/2021/03/46870/fbi-international-series-cbs-season-1-order/">CBS Orders &#8216;FBI&#8217; Spinoff &#8216;FBI International&#8217; to Series</a></h2>
							<div class="cs-entry__excerpt">
					CBS is expanding the FBI franchise with another spinoff, this one called &#8220;FBI: International.&#8221; The series will join&hellip;				</div>
			
					</div>
	</div>
</article>



<article class="post-46867 post type-post status-publish format-standard has-post-thumbnail category-television tag-casting tag-netflix cs-entry cs-video-wrap">

	<div class="cs-entry__outer">
						<div class="cs-entry__inner cs-entry__thumbnail cs-entry__overlay cs-overlay-ratio cs-ratio-original" data-scheme="inverse">

											<div class="cs-overlay-background">
							<img width="260" height="195" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2021/03/Steven-Yeun-Minari-260x195.jpg" class="attachment-csco-thumbnail-small size-csco-thumbnail-small wp-post-image lazyload" alt="Steven Yeun" data-srcset="https://theslanted.com/wp-content/uploads/2021/03/Steven-Yeun-Minari-260x195.jpg 260w, https://theslanted.com/wp-content/uploads/2021/03/Steven-Yeun-Minari-300x225.jpg 300w, https://theslanted.com/wp-content/uploads/2021/03/Steven-Yeun-Minari-200x150.jpg 200w" sizes="(max-width: 260px) 100vw, 260px" /><noscript><img width="260" height="195" src="https://theslanted.com/wp-content/uploads/2021/03/Steven-Yeun-Minari-260x195.jpg" class="attachment-csco-thumbnail-small size-csco-thumbnail-small wp-post-image lazyload" alt="Steven Yeun" srcset="https://theslanted.com/wp-content/uploads/2021/03/Steven-Yeun-Minari-260x195.jpg 260w, https://theslanted.com/wp-content/uploads/2021/03/Steven-Yeun-Minari-300x225.jpg 300w, https://theslanted.com/wp-content/uploads/2021/03/Steven-Yeun-Minari-200x150.jpg 200w" sizes="(max-width: 260px) 100vw, 260px" /></noscript>						</div>

						<div class="cs-overlay-content">
															<span class="cs-entry__read-more">Read More</span>
							
													</div>
					
					
					
					<a href="https://theslanted.com/2021/03/46867/beef-series-steven-yeun-ali-wong-cast/" class="cs-overlay-link"></a>
				</div>
			
		<div class="cs-entry__inner cs-entry__content">

			
			<h2 class="cs-entry__title"><a href="https://theslanted.com/2021/03/46867/beef-series-steven-yeun-ali-wong-cast/">Steven Yeun and Ali Wong to Star in A24 Series &#8216;Beef&#8217; on Netflix</a></h2>
							<div class="cs-entry__excerpt">
					Netflix ordered the new series &#8220;Beef&#8221; from Lee Sung Jin and A24 Studios. The new show will star&hellip;				</div>
			
					</div>
	</div>
</article>



<article class="post-46864 post type-post status-publish format-standard has-post-thumbnail category-television tag-cw tag-hbo cs-entry cs-video-wrap">

	<div class="cs-entry__outer">
						<div class="cs-entry__inner cs-entry__thumbnail cs-entry__overlay cs-overlay-ratio cs-ratio-original" data-scheme="inverse">

											<div class="cs-overlay-background">
							<img width="260" height="195" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2021/03/What-We-Do-in-the-Shadows-260x195.jpg" class="attachment-csco-thumbnail-small size-csco-thumbnail-small wp-post-image lazyload" alt="Wellington Paranormal" data-srcset="https://theslanted.com/wp-content/uploads/2021/03/What-We-Do-in-the-Shadows-260x195.jpg 260w, https://theslanted.com/wp-content/uploads/2021/03/What-We-Do-in-the-Shadows-300x225.jpg 300w, https://theslanted.com/wp-content/uploads/2021/03/What-We-Do-in-the-Shadows-200x150.jpg 200w" sizes="(max-width: 260px) 100vw, 260px" /><noscript><img width="260" height="195" src="https://theslanted.com/wp-content/uploads/2021/03/What-We-Do-in-the-Shadows-260x195.jpg" class="attachment-csco-thumbnail-small size-csco-thumbnail-small wp-post-image lazyload" alt="Wellington Paranormal" srcset="https://theslanted.com/wp-content/uploads/2021/03/What-We-Do-in-the-Shadows-260x195.jpg 260w, https://theslanted.com/wp-content/uploads/2021/03/What-We-Do-in-the-Shadows-300x225.jpg 300w, https://theslanted.com/wp-content/uploads/2021/03/What-We-Do-in-the-Shadows-200x150.jpg 200w" sizes="(max-width: 260px) 100vw, 260px" /></noscript>						</div>

						<div class="cs-overlay-content">
															<span class="cs-entry__read-more">Read More</span>
							
													</div>
					
					
					
					<a href="https://theslanted.com/2021/03/46864/wellington-paranormal-series-cw-hbo-acquisition/" class="cs-overlay-link"></a>
				</div>
			
		<div class="cs-entry__inner cs-entry__content">

			
			<h2 class="cs-entry__title"><a href="https://theslanted.com/2021/03/46864/wellington-paranormal-series-cw-hbo-acquisition/">&#8216;What We Do in the Shadows&#8217; Spinoff &#8216; Heads to CW and HBO</a></h2>
							<div class="cs-entry__excerpt">
					The mockumentary &#8220;What We Do in the Shadows&#8221; is getting a spinoff series called &#8220;Wellington Paranormal.&#8221; The CW&hellip;				</div>
			
					</div>
	</div>
</article>



<article class="post-46861 post type-post status-publish format-standard has-post-thumbnail category-television tag-casting tag-nbc cs-entry cs-video-wrap">

	<div class="cs-entry__outer">
						<div class="cs-entry__inner cs-entry__thumbnail cs-entry__overlay cs-overlay-ratio cs-ratio-original" data-scheme="inverse">

											<div class="cs-overlay-background">
							<img width="260" height="195" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2021/03/We-Are-Lady-Parts-260x195.jpg" class="attachment-csco-thumbnail-small size-csco-thumbnail-small wp-post-image lazyload" alt="We Are Lady Parts" data-srcset="https://theslanted.com/wp-content/uploads/2021/03/We-Are-Lady-Parts-260x195.jpg 260w, https://theslanted.com/wp-content/uploads/2021/03/We-Are-Lady-Parts-300x225.jpg 300w, https://theslanted.com/wp-content/uploads/2021/03/We-Are-Lady-Parts-200x150.jpg 200w" sizes="(max-width: 260px) 100vw, 260px" /><noscript><img width="260" height="195" src="https://theslanted.com/wp-content/uploads/2021/03/We-Are-Lady-Parts-260x195.jpg" class="attachment-csco-thumbnail-small size-csco-thumbnail-small wp-post-image lazyload" alt="We Are Lady Parts" srcset="https://theslanted.com/wp-content/uploads/2021/03/We-Are-Lady-Parts-260x195.jpg 260w, https://theslanted.com/wp-content/uploads/2021/03/We-Are-Lady-Parts-300x225.jpg 300w, https://theslanted.com/wp-content/uploads/2021/03/We-Are-Lady-Parts-200x150.jpg 200w" sizes="(max-width: 260px) 100vw, 260px" /></noscript>						</div>

						<div class="cs-overlay-content">
															<span class="cs-entry__read-more">Read More</span>
							
													</div>
					
					
					
					<a href="https://theslanted.com/2021/03/46861/we-are-lady-parts-series-peacock-first-look-band/" class="cs-overlay-link"></a>
				</div>
			
		<div class="cs-entry__inner cs-entry__content">

			
			<h2 class="cs-entry__title"><a href="https://theslanted.com/2021/03/46861/we-are-lady-parts-series-peacock-first-look-band/">Nida Manzoor&#8217;s Punk-Rock Comedy &#8216;We Are Lady Parts&#8217; Shares a Look at the Band</a></h2>
							<div class="cs-entry__excerpt">
					Peacock shared a first-look photo from the upcoming series &#8220;We Are Lady Parts,&#8221; a music comedy following a&hellip;				</div>
			
					</div>
	</div>
</article>



<article class="post-46858 post type-post status-publish format-standard has-post-thumbnail category-television tag-hbo cs-entry cs-video-wrap">

	<div class="cs-entry__outer">
						<div class="cs-entry__inner cs-entry__thumbnail cs-entry__overlay cs-overlay-ratio cs-ratio-original" data-scheme="inverse">

											<div class="cs-overlay-background">
							<img width="260" height="195" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2021/03/Issa-Rae-260x195.jpg" class="attachment-csco-thumbnail-small size-csco-thumbnail-small wp-post-image lazyload" alt="Issa Rae" data-srcset="https://theslanted.com/wp-content/uploads/2021/03/Issa-Rae-260x195.jpg 260w, https://theslanted.com/wp-content/uploads/2021/03/Issa-Rae-300x225.jpg 300w, https://theslanted.com/wp-content/uploads/2021/03/Issa-Rae-200x150.jpg 200w" sizes="(max-width: 260px) 100vw, 260px" /><noscript><img width="260" height="195" src="https://theslanted.com/wp-content/uploads/2021/03/Issa-Rae-260x195.jpg" class="attachment-csco-thumbnail-small size-csco-thumbnail-small wp-post-image lazyload" alt="Issa Rae" srcset="https://theslanted.com/wp-content/uploads/2021/03/Issa-Rae-260x195.jpg 260w, https://theslanted.com/wp-content/uploads/2021/03/Issa-Rae-300x225.jpg 300w, https://theslanted.com/wp-content/uploads/2021/03/Issa-Rae-200x150.jpg 200w" sizes="(max-width: 260px) 100vw, 260px" /></noscript>						</div>

						<div class="cs-overlay-content">
															<span class="cs-entry__read-more">Read More</span>
							
													</div>
					
					
					
					<a href="https://theslanted.com/2021/03/46858/issa-rae-warnermedia-overall-deal-projects-upcoming/" class="cs-overlay-link"></a>
				</div>
			
		<div class="cs-entry__inner cs-entry__content">

			
			<h2 class="cs-entry__title"><a href="https://theslanted.com/2021/03/46858/issa-rae-warnermedia-overall-deal-projects-upcoming/">Issa Rae Signs Overall Deal with WarnerMedia</a></h2>
							<div class="cs-entry__excerpt">
					WarnerMedia announced a five-year overall deal with Issa Rae, extending the company&#8217;s relationship with the Emmy-nominated creator, executive&hellip;				</div>
			
					</div>
	</div>
</article>



<article class="post-46855 post type-post status-publish format-standard has-post-thumbnail category-television tag-casting tag-tv-trailers cs-entry cs-video-wrap">

	<div class="cs-entry__outer">
						<div class="cs-entry__inner cs-entry__thumbnail cs-entry__overlay cs-overlay-ratio cs-ratio-original" data-scheme="inverse">

											<div class="cs-overlay-background">
							<img width="260" height="195" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2019/07/Lord-of-the-Rings-260x195.jpg" class="attachment-csco-thumbnail-small size-csco-thumbnail-small wp-post-image lazyload" alt="Elrond in The Lord of the Rings" data-srcset="https://theslanted.com/wp-content/uploads/2019/07/Lord-of-the-Rings-260x195.jpg 260w, https://theslanted.com/wp-content/uploads/2019/07/Lord-of-the-Rings-300x225.jpg 300w, https://theslanted.com/wp-content/uploads/2019/07/Lord-of-the-Rings-200x150.jpg 200w" sizes="(max-width: 260px) 100vw, 260px" /><noscript><img width="260" height="195" src="https://theslanted.com/wp-content/uploads/2019/07/Lord-of-the-Rings-260x195.jpg" class="attachment-csco-thumbnail-small size-csco-thumbnail-small wp-post-image lazyload" alt="Elrond in The Lord of the Rings" srcset="https://theslanted.com/wp-content/uploads/2019/07/Lord-of-the-Rings-260x195.jpg 260w, https://theslanted.com/wp-content/uploads/2019/07/Lord-of-the-Rings-300x225.jpg 300w, https://theslanted.com/wp-content/uploads/2019/07/Lord-of-the-Rings-200x150.jpg 200w" sizes="(max-width: 260px) 100vw, 260px" /></noscript>						</div>

						<div class="cs-overlay-content">
															<span class="cs-entry__read-more">Read More</span>
							
													</div>
					
					
					
					<a href="https://theslanted.com/2021/03/46855/lord-of-the-rings-series-amazon-director-wayne-che-yip/" class="cs-overlay-link"></a>
				</div>
			
		<div class="cs-entry__inner cs-entry__content">

			
			<h2 class="cs-entry__title"><a href="https://theslanted.com/2021/03/46855/lord-of-the-rings-series-amazon-director-wayne-che-yip/">Wayne Che Yip to Direct Multiple &#8216;Lord of the Rings&#8217; Episodes</a></h2>
							<div class="cs-entry__excerpt">
					Amazon Studios announced that British Chinese director Wayne Che Yip has joined the Amazon Original The Lord of&hellip;				</div>
			
					</div>
	</div>
</article>



<article class="post-46852 post type-post status-publish format-standard has-post-thumbnail category-television tag-amc tag-tv-trailers cs-entry cs-video-wrap">

	<div class="cs-entry__outer">
						<div class="cs-entry__inner cs-entry__thumbnail cs-entry__overlay cs-overlay-ratio cs-ratio-original" data-scheme="inverse">

											<div class="cs-overlay-background">
							<img width="260" height="195" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2021/03/The-Banishing-260x195.jpg" class="attachment-csco-thumbnail-small size-csco-thumbnail-small wp-post-image lazyload" alt="The Banishing" data-srcset="https://theslanted.com/wp-content/uploads/2021/03/The-Banishing-260x195.jpg 260w, https://theslanted.com/wp-content/uploads/2021/03/The-Banishing-300x225.jpg 300w, https://theslanted.com/wp-content/uploads/2021/03/The-Banishing-200x150.jpg 200w" sizes="(max-width: 260px) 100vw, 260px" /><noscript><img width="260" height="195" src="https://theslanted.com/wp-content/uploads/2021/03/The-Banishing-260x195.jpg" class="attachment-csco-thumbnail-small size-csco-thumbnail-small wp-post-image lazyload" alt="The Banishing" srcset="https://theslanted.com/wp-content/uploads/2021/03/The-Banishing-260x195.jpg 260w, https://theslanted.com/wp-content/uploads/2021/03/The-Banishing-300x225.jpg 300w, https://theslanted.com/wp-content/uploads/2021/03/The-Banishing-200x150.jpg 200w" sizes="(max-width: 260px) 100vw, 260px" /></noscript>						</div>

						<div class="cs-overlay-content">
															<span class="cs-entry__read-more">Read More</span>
							
													</div>
					
					
					
					<a href="https://theslanted.com/2021/03/46852/the-banishing-movie-jessica-brown-findlay/" class="cs-overlay-link"></a>
				</div>
			
		<div class="cs-entry__inner cs-entry__content">

			
			<h2 class="cs-entry__title"><a href="https://theslanted.com/2021/03/46852/the-banishing-movie-jessica-brown-findlay/">Jessica Brown Findlay&#8217;s &#8216;The Banishing&#8217; Lands on Shudder in April</a></h2>
							<div class="cs-entry__excerpt">
					Shudder released an official trailer for &#8220;The Banishing,&#8221; a Christopher Smith-directed horror-thriller slated to premiere on the platform&hellip;				</div>
			
					</div>
	</div>
</article>



<article class="post-46835 post type-post status-publish format-standard has-post-thumbnail category-television tag-hbo tag-tv-trailers cs-entry cs-video-wrap">

	<div class="cs-entry__outer">
						<div class="cs-entry__inner cs-entry__thumbnail cs-entry__overlay cs-overlay-ratio cs-ratio-original" data-scheme="inverse">

											<div class="cs-overlay-background">
							<img width="260" height="195" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2021/03/The-Nevers-260x195.jpg" class="attachment-csco-thumbnail-small size-csco-thumbnail-small wp-post-image lazyload" alt="The Nevers" data-srcset="https://theslanted.com/wp-content/uploads/2021/03/The-Nevers-260x195.jpg 260w, https://theslanted.com/wp-content/uploads/2021/03/The-Nevers-300x225.jpg 300w, https://theslanted.com/wp-content/uploads/2021/03/The-Nevers-200x150.jpg 200w" sizes="(max-width: 260px) 100vw, 260px" /><noscript><img width="260" height="195" src="https://theslanted.com/wp-content/uploads/2021/03/The-Nevers-260x195.jpg" class="attachment-csco-thumbnail-small size-csco-thumbnail-small wp-post-image lazyload" alt="The Nevers" srcset="https://theslanted.com/wp-content/uploads/2021/03/The-Nevers-260x195.jpg 260w, https://theslanted.com/wp-content/uploads/2021/03/The-Nevers-300x225.jpg 300w, https://theslanted.com/wp-content/uploads/2021/03/The-Nevers-200x150.jpg 200w" sizes="(max-width: 260px) 100vw, 260px" /></noscript>						</div>

						<div class="cs-overlay-content">
															<span class="cs-entry__read-more">Read More</span>
							
													</div>
					
					
					
					<a href="https://theslanted.com/2021/03/46835/the-nevers-series-hbo-preview-trailer/" class="cs-overlay-link"></a>
				</div>
			
		<div class="cs-entry__inner cs-entry__content">

			
			<h2 class="cs-entry__title"><a href="https://theslanted.com/2021/03/46835/the-nevers-series-hbo-preview-trailer/">HBO&#8217;s &#8216;The Nevers&#8217; Previews a Supernatural Story with a Victorian Twist</a></h2>
							<div class="cs-entry__excerpt">
					HBO&#8217;s drama series &#8220;The Nevers&#8221; will premiere Part One of the debut season with six episodes starting on&hellip;				</div>
			
					</div>
	</div>
</article>



<article class="post-46826 post type-post status-publish format-standard has-post-thumbnail category-television tag-showtime cs-entry cs-video-wrap">

	<div class="cs-entry__outer">
						<div class="cs-entry__inner cs-entry__thumbnail cs-entry__overlay cs-overlay-ratio cs-ratio-original" data-scheme="inverse">

											<div class="cs-overlay-background">
							<img width="260" height="195" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2019/08/The-Man-Who-Fell-From-Earth-260x195.jpg" class="attachment-csco-thumbnail-small size-csco-thumbnail-small wp-post-image lazyload" alt="David Bowie in The Man Who Fell From Earth" data-srcset="https://theslanted.com/wp-content/uploads/2019/08/The-Man-Who-Fell-From-Earth-260x195.jpg 260w, https://theslanted.com/wp-content/uploads/2019/08/The-Man-Who-Fell-From-Earth-300x225.jpg 300w, https://theslanted.com/wp-content/uploads/2019/08/The-Man-Who-Fell-From-Earth-200x150.jpg 200w" sizes="(max-width: 260px) 100vw, 260px" /><noscript><img width="260" height="195" src="https://theslanted.com/wp-content/uploads/2019/08/The-Man-Who-Fell-From-Earth-260x195.jpg" class="attachment-csco-thumbnail-small size-csco-thumbnail-small wp-post-image lazyload" alt="David Bowie in The Man Who Fell From Earth" srcset="https://theslanted.com/wp-content/uploads/2019/08/The-Man-Who-Fell-From-Earth-260x195.jpg 260w, https://theslanted.com/wp-content/uploads/2019/08/The-Man-Who-Fell-From-Earth-300x225.jpg 300w, https://theslanted.com/wp-content/uploads/2019/08/The-Man-Who-Fell-From-Earth-200x150.jpg 200w" sizes="(max-width: 260px) 100vw, 260px" /></noscript>						</div>

						<div class="cs-overlay-content">
															<span class="cs-entry__read-more">Read More</span>
							
													</div>
					
					
					
					<a href="https://theslanted.com/2021/03/46826/man-who-fell-to-earth-series-showtime-remake/" class="cs-overlay-link"></a>
				</div>
			
		<div class="cs-entry__inner cs-entry__content">

			
			<h2 class="cs-entry__title"><a href="https://theslanted.com/2021/03/46826/man-who-fell-to-earth-series-showtime-remake/">Chiwetel Ejiofor&#8217;s &#8216;The Man Who Fell to Earth&#8217; Moves to Showtime</a></h2>
							<div class="cs-entry__excerpt">
					Paramout+ will no longer be the launchpad for &#8220;The Man Who Fell to Earth.&#8221; Showtime will stream the&hellip;				</div>
			
					</div>
	</div>
</article>



<article class="post-46824 post type-post status-publish format-standard has-post-thumbnail category-television tag-showtime cs-entry cs-video-wrap">

	<div class="cs-entry__outer">
						<div class="cs-entry__inner cs-entry__thumbnail cs-entry__overlay cs-overlay-ratio cs-ratio-original" data-scheme="inverse">

											<div class="cs-overlay-background">
							<img width="260" height="195" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/04/Black-Monday-260x195.jpg" class="attachment-csco-thumbnail-small size-csco-thumbnail-small wp-post-image lazyload" alt="Showtime Black Monday" data-srcset="https://theslanted.com/wp-content/uploads/2020/04/Black-Monday-260x195.jpg 260w, https://theslanted.com/wp-content/uploads/2020/04/Black-Monday-300x225.jpg 300w, https://theslanted.com/wp-content/uploads/2020/04/Black-Monday-200x150.jpg 200w" sizes="(max-width: 260px) 100vw, 260px" /><noscript><img width="260" height="195" src="https://theslanted.com/wp-content/uploads/2020/04/Black-Monday-260x195.jpg" class="attachment-csco-thumbnail-small size-csco-thumbnail-small wp-post-image lazyload" alt="Showtime Black Monday" srcset="https://theslanted.com/wp-content/uploads/2020/04/Black-Monday-260x195.jpg 260w, https://theslanted.com/wp-content/uploads/2020/04/Black-Monday-300x225.jpg 300w, https://theslanted.com/wp-content/uploads/2020/04/Black-Monday-200x150.jpg 200w" sizes="(max-width: 260px) 100vw, 260px" /></noscript>						</div>

						<div class="cs-overlay-content">
															<span class="cs-entry__read-more">Read More</span>
							
													</div>
					
					
					
					<a href="https://theslanted.com/2021/03/46824/the-chi-season-4-black-monday-season-3-showtime/" class="cs-overlay-link"></a>
				</div>
			
		<div class="cs-entry__inner cs-entry__content">

			
			<h2 class="cs-entry__title"><a href="https://theslanted.com/2021/03/46824/the-chi-season-4-black-monday-season-3-showtime/">&#8216;Black Monday&#8217; and &#8216;The Chi&#8217; Return in May with &#8216;Flatbush Misdemeanors&#8217;</a></h2>
							<div class="cs-entry__excerpt">
					Showtime announced that the fourth season of &#8220;The Chi,&#8221; the third season of the comedy &#8220;Black Monday,&#8221; and&hellip;				</div>
			
					</div>
	</div>
</article>



<article class="post-46822 post type-post status-publish format-standard has-post-thumbnail category-television tag-disney-plus cs-entry cs-video-wrap">

	<div class="cs-entry__outer">
						<div class="cs-entry__inner cs-entry__thumbnail cs-entry__overlay cs-overlay-ratio cs-ratio-original" data-scheme="inverse">

											<div class="cs-overlay-background">
							<img width="260" height="195" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2021/02/Falcon-and-the-Wnter-Soldier-260x195.jpg" class="attachment-csco-thumbnail-small size-csco-thumbnail-small wp-post-image lazyload" alt="Falcon and the Winter Solder" data-srcset="https://theslanted.com/wp-content/uploads/2021/02/Falcon-and-the-Wnter-Soldier-260x195.jpg 260w, https://theslanted.com/wp-content/uploads/2021/02/Falcon-and-the-Wnter-Soldier-300x225.jpg 300w, https://theslanted.com/wp-content/uploads/2021/02/Falcon-and-the-Wnter-Soldier-200x150.jpg 200w" sizes="(max-width: 260px) 100vw, 260px" /><noscript><img width="260" height="195" src="https://theslanted.com/wp-content/uploads/2021/02/Falcon-and-the-Wnter-Soldier-260x195.jpg" class="attachment-csco-thumbnail-small size-csco-thumbnail-small wp-post-image lazyload" alt="Falcon and the Winter Solder" srcset="https://theslanted.com/wp-content/uploads/2021/02/Falcon-and-the-Wnter-Soldier-260x195.jpg 260w, https://theslanted.com/wp-content/uploads/2021/02/Falcon-and-the-Wnter-Soldier-300x225.jpg 300w, https://theslanted.com/wp-content/uploads/2021/02/Falcon-and-the-Wnter-Soldier-200x150.jpg 200w" sizes="(max-width: 260px) 100vw, 260px" /></noscript>						</div>

						<div class="cs-overlay-content">
															<span class="cs-entry__read-more">Read More</span>
							
													</div>
					
					
					
					<a href="https://theslanted.com/2021/03/46822/falcon-and-the-winter-soldier-debut-ratings-record/" class="cs-overlay-link"></a>
				</div>
			
		<div class="cs-entry__inner cs-entry__content">

			
			<h2 class="cs-entry__title"><a href="https://theslanted.com/2021/03/46822/falcon-and-the-winter-soldier-debut-ratings-record/">&#8216;Falcon and The Winter Soldier&#8217; Debut Tops Records for Disney+</a></h2>
							<div class="cs-entry__excerpt">
					The Marvel Cinematic Universe continues to expand on Disney+, and everything&#8217;s working out great for Disney. The debut&hellip;				</div>
			
					</div>
	</div>
</article>



<article class="post-46815 post type-post status-publish format-standard has-post-thumbnail category-television tag-amazon-prime cs-entry cs-video-wrap">

	<div class="cs-entry__outer">
						<div class="cs-entry__inner cs-entry__thumbnail cs-entry__overlay cs-overlay-ratio cs-ratio-original" data-scheme="inverse">

											<div class="cs-overlay-background">
							<img width="260" height="195" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/05/NFL-Stadium-260x195.jpg" class="attachment-csco-thumbnail-small size-csco-thumbnail-small wp-post-image lazyload" alt="Stock NFL" data-srcset="https://theslanted.com/wp-content/uploads/2020/05/NFL-Stadium-260x195.jpg 260w, https://theslanted.com/wp-content/uploads/2020/05/NFL-Stadium-300x225.jpg 300w, https://theslanted.com/wp-content/uploads/2020/05/NFL-Stadium-200x150.jpg 200w" sizes="(max-width: 260px) 100vw, 260px" /><noscript><img width="260" height="195" src="https://theslanted.com/wp-content/uploads/2020/05/NFL-Stadium-260x195.jpg" class="attachment-csco-thumbnail-small size-csco-thumbnail-small wp-post-image lazyload" alt="Stock NFL" srcset="https://theslanted.com/wp-content/uploads/2020/05/NFL-Stadium-260x195.jpg 260w, https://theslanted.com/wp-content/uploads/2020/05/NFL-Stadium-300x225.jpg 300w, https://theslanted.com/wp-content/uploads/2020/05/NFL-Stadium-200x150.jpg 200w" sizes="(max-width: 260px) 100vw, 260px" /></noscript>						</div>

						<div class="cs-overlay-content">
															<span class="cs-entry__read-more">Read More</span>
							
													</div>
					
					
					
					<a href="https://theslanted.com/2021/03/46815/prime-video-thursday-night-football-2023-streaming/" class="cs-overlay-link"></a>
				</div>
			
		<div class="cs-entry__inner cs-entry__content">

			
			<h2 class="cs-entry__title"><a href="https://theslanted.com/2021/03/46815/prime-video-thursday-night-football-2023-streaming/">Prime Video Lands Thursday Night Football Deal with NFL</a></h2>
							<div class="cs-entry__excerpt">
					Football fans will want to keep that Prime Member status heading into next year. Amazon and the National&hellip;				</div>
			
					</div>
	</div>
</article>

			</div>
		</div>
	
	
	
					</div>

					
				</div>

				
			</main>

		
		
<footer class="cs-footer cs-footer-two" data-scheme="default">
	
	<div class="cs-container">
		<div class="cs-footer__item">
			<div class="cs-footer__col cs-col-left">
				<div class="cs-footer__inner">
							<div class="cs-logo">
			<a class="cs-footer__logo cs-logo-default" href="https://theslanted.com/">
				<img src="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Topper.png"  alt="Slanted" >			</a>

									<a class="cs-footer__logo cs-logo-dark" href="https://theslanted.com/">
							<img src="https://theslanted.com/wp-content/uploads/2021/03/Slanted-Dark-Mode.png"  alt="Slanted" >						</a>
							</div>
		
							<div class="cs-footer-social-links">
				<div class="pk-social-links-wrap  pk-social-links-template-nav pk-social-links-align-default pk-social-links-scheme-default pk-social-links-titles-disabled pk-social-links-counts-disabled pk-social-links-labels-disabled">
		<div class="pk-social-links-items">
								<div class="pk-social-links-item pk-social-links-facebook  pk-social-links-no-count" data-id="facebook">
						<a href="https://facebook.com/theslanted" class="pk-social-links-link" target="_blank" rel="nofollow">
							<i class="pk-social-links-icon pk-icon pk-icon-facebook"></i>
							
							
							
													</a>
					</div>
										<div class="pk-social-links-item pk-social-links-twitter  pk-social-links-no-count" data-id="twitter">
						<a href="https://twitter.com/theslanted" class="pk-social-links-link" target="_blank" rel="nofollow">
							<i class="pk-social-links-icon pk-icon pk-icon-twitter"></i>
							
							
							
													</a>
					</div>
										<div class="pk-social-links-item pk-social-links-instagram  pk-social-links-no-count" data-id="instagram">
						<a href="https://www.instagram.com/theslanted" class="pk-social-links-link" target="_blank" rel="nofollow">
							<i class="pk-social-links-icon pk-icon pk-icon-instagram"></i>
							
							
							
													</a>
					</div>
							</div>
	</div>
			</div>
						</div>
			</div>
			<div class="cs-footer__col cs-col-center">
							</div>
			<div class="cs-footer__col cs-col-right">
							</div>
		</div>
	</div>
</footer>

		
	</div>

	
</div>


			<a href="#top" class="pk-scroll-to-top">
				<i class="pk-icon pk-icon-up"></i>
			</a>
					<div class="pk-mobile-share-overlay">
						<div class="pk-share-buttons-wrap pk-share-buttons-layout-horizontal pk-share-buttons-scheme-default pk-share-buttons-has-total-counts pk-share-buttons-mobile-share pk-share-buttons-mode-none" data-post-id="46896" data-share-url="https://theslanted.com/2021/03/46896/man-who-fell-to-earth-series-naomi-harris-cast-showtime/" >

							<div class="pk-share-buttons-total pk-share-buttons-total-no-count">
												<div class="pk-share-buttons-title pk-font-primary">Total</div>
							<div class="pk-share-buttons-count pk-font-heading">0</div>
							<div class="pk-share-buttons-label pk-font-secondary">Share</div>
										</div>
				
			<div class="pk-share-buttons-items">

										<div class="pk-share-buttons-item pk-share-buttons-facebook pk-share-buttons-no-count" data-id="facebook">

							<a href="https://www.facebook.com/sharer.php?u=https://bit.ly/3swfZba" class="pk-share-buttons-link" target="_blank">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-facebook"></i>
								
								
								
															</a>

							
							
													</div>
											<div class="pk-share-buttons-item pk-share-buttons-twitter pk-share-buttons-no-count" data-id="twitter">

							<a href="https://twitter.com/share?&text=Naomie%20Harris%20Joins%20%E2%80%98Man%20Who%20Fell%20to%20Earth%E2%80%99%20Series&via=theslanted&url=https://bit.ly/3swfZba" class="pk-share-buttons-link" target="_blank">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-twitter"></i>
								
								
								
															</a>

							
							
													</div>
											<div class="pk-share-buttons-item pk-share-buttons-reddit pk-share-buttons-no-count" data-id="reddit">

							<a href="http://www.reddit.com/submit?url=https://bit.ly/3swfZba" class="pk-share-buttons-link" target="_blank">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-reddit"></i>
								
								
								
															</a>

							
							
													</div>
								</div>
		</div>
				</div>
					<div id="fb-root"></div>
		
				
			



<script id='canvas-justified-gallery-js-extra'>
var canvasJG = {"rtl":""};
</script>



<script id='canvas-slider-gallery-js-extra'>
var canvas_sg_flickity = {"page_info_sep":" of "};
</script>

<script src='https://theslanted.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4' id='wp-polyfill-js'></script>

<script src='https://theslanted.com/wp-includes/js/dist/hooks.min.js?ver=50e23bed88bcb9e6e14023e9961698c1' id='wp-hooks-js'></script>
<script src='https://theslanted.com/wp-includes/js/dist/i18n.min.js?ver=db9a9a37da262883343e941c3731bc67' id='wp-i18n-js'></script>

<script src='https://theslanted.com/wp-includes/js/dist/vendor/lodash.min.js?ver=4.17.19' id='lodash-js'></script>

<script src='https://theslanted.com/wp-includes/js/dist/url.min.js?ver=0ac7e0472c46121366e7ce07244be1ac' id='wp-url-js'></script>

<script src='https://theslanted.com/wp-includes/js/dist/api-fetch.min.js?ver=a783d1f442d2abefc7d6dbd156a44561' id='wp-api-fetch-js'></script>
<script id='wp-api-fetch-js-after'>
wp.apiFetch.use( wp.apiFetch.createRootURLMiddleware( "https://theslanted.com/wp-json/" ) );
wp.apiFetch.nonceMiddleware = wp.apiFetch.createNonceMiddleware( "faa9eac000" );
wp.apiFetch.use( wp.apiFetch.nonceMiddleware );
wp.apiFetch.use( wp.apiFetch.mediaUploadMiddleware );
wp.apiFetch.nonceEndpoint = "https://theslanted.com/wp-admin/admin-ajax.php?action=rest-nonce";
</script>
<script id='contact-form-7-js-extra'>
var wpcf7 = [];
</script>


<script id='powerkit-justified-gallery-js-extra'>
var powerkitJG = {"rtl":""};
</script>


<script id='powerkit-lightbox-js-extra'>
var powerkit_lightbox_localize = {"text_previous":"Previous","text_next":"Next","text_close":"Close","text_loading":"Loading","text_counter":"of","single_image_selectors":".entry-content img","gallery_selectors":".wp-block-gallery,.gallery","exclude_selectors":"","zoom_icon":"1"};
</script>

<script id='powerkit-opt-in-forms-js-extra'>
var opt_in = {"ajax_url":"https:\/\/theslanted.com\/wp-admin\/admin-ajax.php","warning_privacy":"Please confirm that you agree with our policies."};
</script>

<script defer async="async" defer="defer" src='//assets.pinterest.com/js/pinit.js?ver=5.7' id='powerkit-pinterest-js'></script>
<script id='powerkit-pin-it-js-extra'>
var powerkit_pinit_localize = {"image_selectors":".entry-content img","exclude_selectors":".cnvs-block-row,.cnvs-block-section,.cnvs-block-posts .entry-thumbnail,.cnvs-post-thumbnail,.pk-block-author,.pk-featured-categories img,.pk-inline-posts-container img,.pk-instagram-image,.pk-subscribe-image,.pk-block-posts,.cs-posts-area__main,.cs-entry","only_hover":"1"};
</script>



<script id='powerkit-slider-gallery-js-extra'>
var powerkit_sg_flickity = {"page_info_sep":" of "};
</script>



<script id='csco-scripts-js-extra'>
var csLocalize = {"darkMode":"true"};
var csco_mega_menu = {"rest_url":"https:\/\/theslanted.com\/wp-json\/csco\/v1\/menu-posts"};
</script>

<script id='swp-live-search-client-js-extra'>
var searchwp_live_search_params = [];
searchwp_live_search_params = {"ajaxurl":"https:\/\/theslanted.com\/wp-admin\/admin-ajax.php","origin_id":46896,"config":{"default":{"engine":"default","input":{"delay":300,"min_chars":3},"results":{"position":"bottom","width":"auto","offset":{"x":0,"y":5}},"spinner":{"lines":12,"length":8,"width":3,"radius":8,"scale":1,"corners":1,"color":"#424242","fadeColor":"transparent","speed":1,"rotate":0,"animation":"searchwp-spinner-line-fade-quick","direction":1,"zIndex":2000000000,"className":"spinner","top":"50%","left":"50%","shadow":"0 0 1px transparent","position":"absolute"}}},"msg_no_config_found":"No valid SearchWP Live Search configuration found!","aria_instructions":"When autocomplete results are available use up and down arrows to review and enter to go to the desired page. Touch device users, explore by touch or with swipe gestures."};;
</script>


	<script type="text/javascript">
		"use strict";

		(function($) {

			$( window ).on( 'load', function() {

				// Each All Share boxes.
				$( '.pk-share-buttons-mode-rest' ).each( function() {

					var powerkitButtonsIds = [],
						powerkitButtonsBox = $( this );

					// Check Counts.
					if ( ! powerkitButtonsBox.hasClass( 'pk-share-buttons-has-counts' ) && ! powerkitButtonsBox.hasClass( 'pk-share-buttons-has-total-counts' ) ) {
						return;
					}

					powerkitButtonsBox.find( '.pk-share-buttons-item' ).each( function() {
						if ( $( this ).attr( 'data-id' ).length > 0 ) {
							powerkitButtonsIds.push( $( this ).attr( 'data-id' ) );
						}
					});

					// Generate accounts data.
					var powerkitButtonsData = {};

					if( powerkitButtonsIds.length > 0 ) {
						powerkitButtonsData = {
							'ids'     : powerkitButtonsIds.join(),
							'post_id' : powerkitButtonsBox.attr( 'data-post-id' ),
							'url'     : powerkitButtonsBox.attr( 'data-share-url' ),
						};
					}

					// Get results by REST API.
					$.ajax({
						type: 'GET',
						url: 'https://theslanted.com/wp-json/social-share/v1/get-shares',
						data: powerkitButtonsData,
						beforeSend: function(){

							// Add Loading Class.
							powerkitButtonsBox.addClass( 'pk-share-buttons-loading' );
						},
						success: function( response ) {

							if ( ! $.isEmptyObject( response ) && ! response.hasOwnProperty( 'code' ) ) {

								// Accounts loop.
								$.each( response, function( index, data ) {

									if ( index !== 'total_count' ) {

										// Find Bsa Item.
										var powerkitButtonsItem = powerkitButtonsBox.find( '.pk-share-buttons-item[data-id="' + index + '"]');

										// Set Count.
										if ( data.hasOwnProperty( 'count' ) && data.count  ) {

											powerkitButtonsItem.removeClass( 'pk-share-buttons-no-count' ).addClass( 'pk-share-buttons-item-count' );
											powerkitButtonsItem.find( '.pk-share-buttons-count' ).html( data.count );

										} else {
											powerkitButtonsItem.addClass( 'pk-share-buttons-no-count' );
										}
									}
								});

								if ( powerkitButtonsBox.hasClass( 'pk-share-buttons-has-total-counts' ) && response.hasOwnProperty( 'total_count' ) ) {
									var powerkitButtonsTotalBox = powerkitButtonsBox.find( '.pk-share-buttons-total' );

									if ( response.total_count ) {
										powerkitButtonsTotalBox.find( '.pk-share-buttons-count' ).html( response.total_count );
										powerkitButtonsTotalBox.show().removeClass( 'pk-share-buttons-total-no-count' );
									}
								}
							}

							// Remove Loading Class.
							powerkitButtonsBox.removeClass( 'pk-share-buttons-loading' );
						},
						error: function() {

							// Remove Loading Class.
							powerkitButtonsBox.removeClass( 'pk-share-buttons-loading' );
						}
					});
				});
			});

		})(jQuery);
	</script>
	
<script defer src="https://theslanted.com/wp-content/uploads/siteground-optimizer-assets/siteground-optimizer-combined-js-5ab13d434e814d665eb13409b0fbc397.js"></script></body>
</html>
