<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8" />
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<script src="/cdn-cgi/apps/head/DA62IkZObcR4JmtKYSQohGU_Yuo.js"></script><link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://theslanted.com/xmlrpc.php" />
<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png?v=2b0JJxJGxR">
<link rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png?v=2b0JJxJGxR">
<link rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png?v=2b0JJxJGxR">
<link rel="manifest" href="/site.webmanifest?v=2b0JJxJGxR">
<link rel="mask-icon" href="/safari-pinned-tab.svg?v=2b0JJxJGxR" color="#5bbad5">
<link rel="shortcut icon" href="/favicon.ico?v=2b0JJxJGxR">
<meta name="apple-mobile-web-app-title" content="Slanted">
<meta name="application-name" content="Slanted">
<meta name="msapplication-TileColor" content="#00aba9">
<meta name="msapplication-TileImage" content="/mstile-144x144.png?v=2b0JJxJGxR">
<meta name="theme-color" content="#ffffff">
<meta name="twitter:description" content="Instant coverage of Movies, TV, culture,and pop culture lifestyle.">
<title>&#039;The Twilight Zone&#039; Announces Season 2 Cast List</title>

<meta name="description" content="CBS All Access announced new casting details for &quot;The Twilight Zone: Season 2,&quot; which will start its 10-episode sophomore season this summer." />
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://theslanted.com/2020/05/39922/twilight-zone-season-2-cast-announcement/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="&#039;The Twilight Zone&#039; Announces Season 2 Cast List" />
<meta property="og:description" content="Welcome, to the Twilight Zone" />
<meta property="og:url" content="https://theslanted.com/2020/05/39922/twilight-zone-season-2-cast-announcement/" />
<meta property="og:site_name" content="Slanted" />
<meta property="article:publisher" content="https://www.facebook.com/TheSlanted" />
<meta property="article:tag" content="Casting" />
<meta property="article:tag" content="CBS" />
<meta property="article:section" content="TV News" />
<meta property="article:published_time" content="2020-05-04T16:14:56+00:00" />
<meta property="article:modified_time" content="2020-05-04T16:15:00+00:00" />
<meta property="og:updated_time" content="2020-05-04T16:15:00+00:00" />
<meta property="fb:app_id" content="663549953797892" />
<meta property="og:image" content="https://theslanted.com/wp-content/uploads/2020/05/Twilight-Zone-Season-2.jpg" />
<meta property="og:image:secure_url" content="https://theslanted.com/wp-content/uploads/2020/05/Twilight-Zone-Season-2.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="640" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="CBS All Access announced new casting details for &quot;The Twilight Zone: Season 2,&quot; which will start its 10-episode sophomore season this summer." />
<meta name="twitter:title" content="&#039;The Twilight Zone&#039; Announces Season 2 Cast List" />
<meta name="twitter:site" content="@theslanted" />
<meta name="twitter:image" content="https://theslanted.com/wp-content/uploads/2020/05/Twilight-Zone-Season-2.jpg" />
<meta name="twitter:creator" content="@theslanted" />

<link rel="amphtml" href="https://theslanted.com/2020/05/39922/twilight-zone-season-2-cast-announcement/amp/" /><meta name="generator" content="AMP for WP 1.0.41" /><link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="Slanted &raquo; Feed" href="https://theslanted.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Slanted &raquo; Comments Feed" href="https://theslanted.com/comments/feed/" />
<link rel='stylesheet' id='look_ruby_plugin_core_style-css' href='https://theslanted.com/wp-content/plugins/look-ruby-core/assets/core.css?ver=5.1' media='all' />
<link rel='stylesheet' id='google-font-playfair-display-raleway-css' href='https://fonts.googleapis.com/css?family=Raleway%3A400%2C500%2C600%2C700&#038;subset=latin-ext&#038;display=swap' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://theslanted.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.1' media='all' />
<link rel='stylesheet' id='wp-block-library-theme-css' href='https://theslanted.com/wp-includes/css/dist/block-library/theme.min.css?ver=5.4.1' media='all' />
<link rel='stylesheet' id='look_ruby_external_style-css' href='https://theslanted.com/wp-content/themes/look/assets/external/external-style.css?ver=5.1' media='all' />
<link rel='stylesheet' id='look_ruby_main_style-css' href='https://theslanted.com/wp-content/themes/look/assets/css/theme-style.css?ver=5.1' media='all' />
<link rel='stylesheet' id='look_ruby_responsive_style-css' href='https://theslanted.com/wp-content/themes/look/assets/css/theme-responsive.css?ver=5.1' media='all' />
<style id='look_ruby_responsive_style-inline-css'>
h1, h2, h3, h4, h5, h6,.post-counter, .logo-text, .banner-content-wrap, .post-review-score,.woocommerce .price, blockquote{ font-family :Playfair Display;font-weight :400;}input, textarea, h3.comment-reply-title, .comment-title h3,.counter-element-right, .pagination-wrap{ font-family :Nunito;}.post-title.is-big-title{ font-size: 26px; }.post-title.is-medium-title{ font-size: 25px; }.post-title.is-small-title, .post-title.is-mini-title{ font-size: 28px; }.single .post-title.single-title{ font-size: 46px; }.post-excerpt { font-size: 16px; }.entry { line-height:29px;}.header-style-1 .header-banner-wrap {padding-top: 1px;padding-bottom: 1px;}.main-nav-inner > li > a:hover, .main-nav-inner > li > a:focus, .nav-search-wrap a:hover {opacity: 1;color:#584585;}.ruby-trigger:hover .icon-wrap, .ruby-trigger:hover .icon-wrap:before, .ruby-trigger:hover .icon-wrap:after{background-color:#584585;}@media only screen and (min-width: 992px) { .ruby-container { max-width: 1080px; } }.post-review-score, .score-bar { background-color: #584585;}.footer-social-bar-wrap { background-color: #ffffff;}.post-share-bar-inner:before, .block-view-more a, .single-share-bar-total.share-bar-total, .header-social-wrap a:hover,.is-light-text .footer-social-wrap a:hover, .post-counter,.off-canvas-wrap .off-canvas-social-wrap a:hover, .off-canvas-wrap .off-canvas-social-wrap a:focus,.entry a:not(.button), .excerpt a, .block-fw-subscribe .subscribe-box .mc4wp-form-fields input[type=submit]:hover+i{ color: #fa7268;}button[type="submit"], input[type="submit"], .single-tag-wrap .tag-title,.page-numbers.current, a.page-numbers:hover, a.page-numbers:focus,.share-bar-el:hover i, .share-bar-icon:hover i, .sb-widget-social-counter .counter-element:hover,.ruby-trigger:hover .icon-wrap, .ruby-trigger:focus .icon-wrap,.ruby-trigger:hover .icon-wrap:before, .ruby-trigger:focus .icon-wrap:before,.ruby-trigger:hover .icon-wrap:after, .ruby-trigger:focus .icon-wrap:after{ background-color: #fa7268;}.post-grid-small:hover .post-header-inner,.page-numbers.current, a.page-numbers:hover, a.page-numbers:focus,.share-bar-el:hover i, .share-bar-icon:hover i{ border-color: #fa7268;}.header-outer {
    margin-bottom: 5px;
}

.header-banner-wrap {
    padding: 5px 5px;
}

.header-nav-holder {
    min-height: 5px;
}

.single-tag-wrap {
    display: none;
}

.post-cat-info {
    font-size: 19px;
}

.archive-page-header {
    height: 40px;
}

.logo-text {
    color: #756e6e;
    text-transform: uppercase;
    font-weight: 100;
    font-size: 40px;
    font-style: italic;
    background-color: #FFEBE0;
}

.site-tagline {
    display: none;
}

.post-wrap.post-list-mini .post-meta-info {
    display: none;
}

.archive-page-header:not(.has-bg-image) {
    height: 50px;
}

.breadcrumb_last {
    display: none;
}

.single .post-title.single-title h1 {
    background: #FFEBE0;
}

.post-header-meta {
    display: none;
}

.footer-copyright-wrap {
    display: none;
}

.post-wrap .post-title {
    margin: 0 0 2px 0;
}

.post-title.is-small-title, .post-title.is-mini-title {
    font-size: 19px;
}


.post-grid-small .post-title a {
    background: #FFEBE0;
}

.ruby-page-wrap {
    margin-top: 5px;
    margin-bottom: 5px;
}

.entry {
    margin-right: 15px;
}
</style>
<link rel='stylesheet' id='look_ruby_default_style-css' href='https://theslanted.com/wp-content/themes/look/style.css?ver=5.1' media='all' />
<link rel='stylesheet' id='redux-google-fonts-look_ruby_theme_options-css' href='https://fonts.googleapis.com/css?family=Nunito+Sans%3A200%2C300%2C400%2C600%2C700%2C800%2C900%2C200italic%2C300italic%2C400italic%2C600italic%2C700italic%2C800italic%2C900italic%7CPlayfair+Display%3A400%2C700%2C900%2C400italic%2C700italic%2C900italic%7CNunito%3A200%2C300%2C400%2C600%2C700%2C800%2C900%2C200italic%2C300italic%2C400italic%2C600italic%2C700italic%2C800italic%2C900italic%7CMuli%3A200%2C300%2C400%2C600%2C700%2C800%2C900%2C200italic%2C300italic%2C400italic%2C600italic%2C700italic%2C800italic%2C900italic&#038;subset=latin&#038;ver=1587673865' media='all' />
<script src='https://theslanted.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script src='https://theslanted.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<!--[if lt IE 9]>
<script src='https://theslanted.com/wp-content/themes/look/assets/external/html5.js?ver=3.7.3'></script>
<![endif]-->
<script defer src='https://www.googletagmanager.com/gtag/js?id=UA-40601418-1#038;siteground-async=1' async></script>
<script>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());
gtag('config', 'UA-40601418-1', {"anonymize_ip":true} );
</script>
<link rel='https://api.w.org/' href='https://theslanted.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://theslanted.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://theslanted.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.4.1" />
<link rel='shortlink' href='https://slntd.co/2yqK8Ss' />
<link rel="alternate" type="application/json+oembed" href="https://theslanted.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftheslanted.com%2F2020%2F05%2F39922%2Ftwilight-zone-season-2-cast-announcement%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://theslanted.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftheslanted.com%2F2020%2F05%2F39922%2Ftwilight-zone-season-2-cast-announcement%2F&#038;format=xml" />
<meta name="generator" content="Site Kit by Google 1.7.0" />

<script type="application/ld+json" class="saswp-schema-markup-output">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</script>
<link rel="icon" href="https://theslanted.com/wp-content/uploads/2019/01/cropped-SiteIcon-32x32.png" sizes="32x32" />
<link rel="icon" href="https://theslanted.com/wp-content/uploads/2019/01/cropped-SiteIcon-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://theslanted.com/wp-content/uploads/2019/01/cropped-SiteIcon-180x180.png" />
<meta name="msapplication-TileImage" content="https://theslanted.com/wp-content/uploads/2019/01/cropped-SiteIcon-270x270.png" />
<style type="text/css" title="dynamic-css" class="options-output">body{background-color:#f2f2f1;background-repeat:no-repeat;background-size:inherit;background-attachment:inherit;background-position:center top;}.header-banner-wrap{background-color:#ffffff;background-repeat:repeat-x;background-size:inherit;background-attachment:fixed;background-position:center center;}.footer-inner{background-color:#ffffff;background-repeat:no-repeat;background-size:contain;background-attachment:fixed;background-position:center center;}body{font-family:"Nunito Sans",Arial, Helvetica, sans-serif;text-transform:none;line-height:29px;letter-spacing:.1px;font-weight:300;font-style:normal;color:#424242;font-size:22px;}.post-title,.product_title,.widget_recent_entries li{font-family:"Playfair Display",Arial, Helvetica, sans-serif;text-transform:none;letter-spacing:1px;font-weight:400;font-style:italic;color:#363636;}.post-cat-info{font-family:Nunito,Arial, Helvetica, sans-serif;text-transform:uppercase;letter-spacing:2px;font-weight:200;font-style:normal;color:#dd3333;font-size:20px;}.post-meta-info,.share-bar-total,.block-view-more,.single-tag-wrap,.author-job,.nav-arrow,.comment-metadata time,.comment-list .reply,.edit-link{font-family:Nunito;text-transform:capitalize;letter-spacing:1px;font-weight:200;font-style:normal;color:#4c4c4c;font-size:14px;}.main-nav-wrap,.off-canvas-nav-wrap{font-family:Muli,Arial, Helvetica, sans-serif;text-transform:uppercase;letter-spacing:2px;font-weight:normal;font-style:normal;font-size:16px;}.top-bar-menu{font-family:Muli,Arial, Helvetica, sans-serif;text-transform:uppercase;letter-spacing:1px;font-weight:400;font-style:normal;font-size:16px;}.block-title,.widget-title,section.products > h2{font-family:Muli,Arial, Helvetica, sans-serif;text-transform:none;letter-spacing:1px;font-weight:normal;font-style:normal;color:#ff3c36;font-size:25px;}</style><style>
.ai-viewport-3                { display: none !important;}
.ai-viewport-2                { display: none !important;}
.ai-viewport-1                { display: inherit !important;}
.ai-viewport-0                { display: none !important;}
@media (min-width: 768px) and (max-width: 979px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-2                { display: inherit !important;}
}
@media (max-width: 767px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-3                { display: inherit !important;}
}
</style>
</head>
<body class="post-template-default single single-post postid-39922 single-format-standard ruby-body is-boxed is-site-bg is-sticky-nav is-site-smooth-scroll is-left-margin">
<div class="off-canvas-wrap is-dark-text">
<div class="off-canvas-inner">
<a href="#" id="ruby-off-canvas-close-btn"><i class="ruby-close-btn" aria-hidden="true"></i></a>
<div id="off-canvas-navigation" class="off-canvas-nav-wrap">
<ul id="menu-normal-menu" class="off-canvas-nav-inner"><li id="menu-item-32978" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-32978"><a title="Slanted" href="https://theslanted.com/">Home</a></li>
<li id="menu-item-39495" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39495"><a title="Movie &#038; TV Headlines" href="https://theslanted.com/movies-tv/">Movies &#038; TV</a></li>
<li id="menu-item-39224" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39224"><a title="New Release Dates" href="https://theslanted.com/2020/03/39133/movie-releases-put-on-hold-as-coronovirus-closes-theaters-updating/">Movie Delays</a></li>
<li id="menu-item-39496" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39496"><a title="Recent Releases" href="https://theslanted.com/weekend-box-office/">Box Office | Digital</a></li>
<li id="menu-item-39497" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39497"><a title="Apps, Games and Tech" href="https://theslanted.com/lifestyle/">Tech &#038; Lifestyle</a></li>
<li id="menu-item-39498" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39498"><a title="Trending Topics" href="https://theslanted.com/culture-celebrity/">Culture &#038; Celebrity</a></li>
<li id="menu-item-32990" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32990"><a title="Your Daily Dose" href="https://theslanted.com/subscribe/">Subscribe</a></li>
<li id="menu-item-39499" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39499"><a title="Privacy Notice" href="https://theslanted.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-39500" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39500"><a title="Email" href="https://theslanted.com/about/">Contact Us</a></li>
</ul> </div>
</div>
</div><div class="main-site-outer">
<div class="header-outer header-style-1">
<div class="header-wrap">
<div class="header-banner-wrap clearfix">
<div class="off-canvas-btn-wrap">
<div class="off-canvas-btn">
<a href="#" class="ruby-trigger" title="off canvas button">
<span class="icon-wrap"></span>
</a>
</div>
</div>
<div class="header-social-wrap">
<div class="banner-search-wrap">
<a href="#" id="ruby-banner-search" data-mfp-src="#ruby-banner-search-form" data-effect="mpf-ruby-effect" title="search" class="banner-search-icon">
<i class="fa fa-search"></i>
</a>
</div> </div>
<div class="header-logo-wrap"><a class="logo-image" href="https://theslanted.com"><img class="logo-img-data" src="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png" alt="Slanted" height="50" width="200"></a></div></div>
<div class="header-nav-wrap clearfix">
<div class="header-nav-inner">
<div class="ruby-container">
<div class="header-nav-holder clearfix">
<div class="off-canvas-btn-wrap">
<div class="off-canvas-btn">
<a href="#" class="ruby-trigger" title="off canvas button">
<span class="icon-wrap"></span>
</a>
</div>
</div>
<nav id="navigation" class="main-nav-wrap" role="navigation">
</nav>
<div class="header-logo-mobile-wrap"><a class="logo-image-mobile" href="https://theslanted.com"><img class="logo-img-data" src="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Topper.png" alt="Slanted" height="100" width="335"></a></div> <div class="nav-search-wrap">
<a href="#" id="ruby-nav-search" data-mfp-src="#ruby-banner-search-form" data-effect="mpf-ruby-effect" title="search" class="banner-search-icon">
<i class="fa fa-search"></i>
</a>
</div> </div>
</div>
</div>
</div>
</div>
<div id="ruby-banner-search-form" class="banner-search-form-wrap mfp-hide mfp-animation">
<div class="banner-search-form-inner">
<form method="get" action="https://theslanted.com/">
<div class="ruby-search">
<span class="ruby-search-input"><input type="text" class="field" placeholder="Search and hit enter&hellip;" value="" name="s" title="Search for:" /></span>
<span class="ruby-search-submit"><input type="submit" value="" /><i class="fa fa-search"></i></span>
</div>
</form>
</div>
</div>
</div>
<div class="main-site-wrap">
<div class="main-site-mask"></div>
<div id="ruby-site-content" class="main-site-content-wrap clearfix">
<div class="single-post-outer clearfix" data-post_url="https://theslanted.com/2020/05/39922/twilight-zone-season-2-cast-announcement/" data-post_id="39922" data-url="https://theslanted.com/2020/05/39922/twilight-zone-season-2-cast-announcement/"><div class="ruby-page-wrap ruby-section row single-wrap single-style-1 is-sidebar-none ruby-container"><div class="ruby-content-wrap single-inner content-without-sidebar col-xs-12"> <article id="post-39922" class="post-wrap post-39922 post type-post status-publish format-standard has-post-thumbnail category-television tag-casting tag-cbs">
<div class="single-header is-center"><div class="post-cat-info is-relative"><a class="cat-info-el is-cat-888" href="https://theslanted.com/coverage/television/" rel="category tag">TV News</a></div><header class="entry-header single-title post-title is-big-title "><h1 class="entry-title" itemprop="headline">&#8216;The Twilight Zone&#8217; Announces Season 2 Cast List</h1></header><div class="post-thumb-outer single-thumb-outer"><div class="post-thumb is-image is-image-single ruby-holder"><a href="https://theslanted.com/wp-content/uploads/2020/05/Twilight-Zone-Season-2.jpg" title="&#8216;The Twilight Zone&#8217; Announces Season 2 Cast List" rel="bookmark"><span class="thumbnail-resize"><img width="1200" height="640" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/05/Twilight-Zone-Season-2.jpg" class="attachment-full size-full wp-post-image lazyload" alt="Twilight Zone Season 2" data-srcset="https://theslanted.com/wp-content/uploads/2020/05/Twilight-Zone-Season-2.jpg 1200w, https://theslanted.com/wp-content/uploads/2020/05/Twilight-Zone-Season-2-360x192.jpg 360w, https://theslanted.com/wp-content/uploads/2020/05/Twilight-Zone-Season-2-750x400.jpg 750w, https://theslanted.com/wp-content/uploads/2020/05/Twilight-Zone-Season-2-768x410.jpg 768w" sizes="(max-width: 1200px) 100vw, 1200px" /><noscript><img width="1200" height="640" src="https://theslanted.com/wp-content/uploads/2020/05/Twilight-Zone-Season-2.jpg" class="attachment-full size-full wp-post-image lazyload" alt="Twilight Zone Season 2" srcset="https://theslanted.com/wp-content/uploads/2020/05/Twilight-Zone-Season-2.jpg 1200w, https://theslanted.com/wp-content/uploads/2020/05/Twilight-Zone-Season-2-360x192.jpg 360w, https://theslanted.com/wp-content/uploads/2020/05/Twilight-Zone-Season-2-750x400.jpg 750w, https://theslanted.com/wp-content/uploads/2020/05/Twilight-Zone-Season-2-768x410.jpg 768w" sizes="(max-width: 1200px) 100vw, 1200px" /></noscript></span></a><span class="thumb-caption">cbs</span></div></div><div class="single-meta-info-bar clearfix"><div class="post-meta-info"><span class="meta-info-el meta-info-author">
<span class="meta-info-author-thumb">
<img alt='Sarah Fox' src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://secure.gravatar.com/avatar/a6dee5f3ed42423fd798b9a8e9037311?s=50&#038;d=mm&#038;r=g" data-srcset="https://secure.gravatar.com/avatar/a6dee5f3ed42423fd798b9a8e9037311?s=100&#038;d=mm&#038;r=g 2x" class='avatar avatar-50 photo lazyload' height='50' width='50' /><noscript><img alt='Sarah Fox' src='https://secure.gravatar.com/avatar/a6dee5f3ed42423fd798b9a8e9037311?s=50&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/a6dee5f3ed42423fd798b9a8e9037311?s=100&#038;d=mm&#038;r=g 2x' class='avatar avatar-50 photo lazyload' height='50' width='50' /></noscript> </span>
<a href="https://theslanted.com/author/sarahfoxes/" rel="author" title="Post by Sarah Fox">
Sarah Fox	</a>
</span>
<span class="meta-info-el meta-info-date">
<span class="meta-date">May 4, 2020</span>
</span>
</div><div class="single-share-bar clearfix"><span class="single-share-bar-total share-bar-total"><span class="share-bar-total-text">share</span></span><div class="single-share-bar-inner"><a class="share-bar-el icon-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Ftheslanted.com%2F2020%2F05%2F39922%2Ftwilight-zone-season-2-cast-announcement%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="fa fa-facebook color-facebook"></i></a><a class="share-bar-el icon-twitter" href="https://twitter.com/intent/tweet?text=%E2%80%98The+Twilight+Zone%E2%80%99+Announces+Season+2+Cast+List&amp;url=https%3A%2F%2Ftheslanted.com%2F2020%2F05%2F39922%2Ftwilight-zone-season-2-cast-announcement%2F&amp;via=sarahfoxes"><i class="fa fa-twitter color-twitter"></i><script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></a><a class="share-bar-el icon-reddit" href="https://www.reddit.com/submit?url=https%3A%2F%2Ftheslanted.com%2F2020%2F05%2F39922%2Ftwilight-zone-season-2-cast-announcement%2F&title=%E2%80%98The+Twilight+Zone%E2%80%99+Announces+Season+2+Cast+List" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="fa fa-reddit"></i></a><a class="share-bar-el icon-email" href="/cdn-cgi/l/email-protection#3c034f495e56595f48011a1f040e0d0a076854591c684b5550555b54481c665352591a1f040e0d0b071c7d52525349525f594f1c6f595d4f53521c0e1c7f5d4f481c70554f481a5d514c077e73786501751c5a534952581c4854554f1c5d4e48555f50591c555248594e594f4855525b1c5d52581c485453495b54481c535a1c4f545d4e55525b1c55481c4b5548541c455349121c7f54595f571c55481c534948065448484c4f190f7d190e7a190e7a4854594f505d52485958125f5351190e7a0e0c0e0c190e7a0c09190e7a0f05050e0e190e7a484b5550555b54481146535259114f595d4f5352110e115f5d4f48115d52525349525f5951595248190e7a"><i class="fa fa-envelope-o"></i></a></div></div></div></div><div class="single-post-ad is-ad-custom single-post-ad-top"><a href="https://mailchi.mp/b0e4f9a92a86/slanted" target="_blank"><img src="https://theslanted.com/wp-content/uploads/2020/04/Slanted-Subscribe.jpg" alt="Slanted"></a></div><div class="entry post-content entry-content single-entry" itemprop="articleBody"><div class='code-block code-block-1' style='margin: 8px 0; clear: both;'>
<p id="breadcrumbs"><span><span><a href="https://theslanted.com/">Slanted</a> &gt; <span><a href="https://theslanted.com/coverage/television/">TV</a> &gt; <span class="breadcrumb_last" aria-current="page">&#8216;The Twilight Zone&#8217; Announces Season 2 Cast List</span></span></span></span></p></div>
<p>CBS All Access announced new casting details for &#8220;<strong>The Twilight Zone: Season 2</strong>,&#8221; which will start its 10-episode sophomore season this summer. The cast list includes Kylie Bunbury, Sky Ferreira, Topher Grace, David Krumholtz, Greta Lee, Thomas Lennon, Natalie Martinez, Brandon Jay McLaren, Gretchen Mol, Paula Newsome, Tawny Newsome, Jurnee Smollett-Bell, Paul F. Tompkins, and Damon Wayans Jr.</p>
<p>The series comes from executive producers Jordan Peele and Simon Kinberg, and the show is a modern re-imagining of the classic &#8220;Twilight Zone&#8221; series. The network stated that the new show &#8220;brings the original series’ legacy of socially conscious storytelling to new audiences, exploring the human condition and holding a lens up to the culture of our times.&#8221;</p>
<p>CBS also released additional season two cast and episode titles, in no particular order, and they include:</p>
<p>Episode: “8” : Starring (previously announced) Joel McHale and Brandon Jay McLaren.</p>
<p>Episode: “A Small Town” : Starring Damon Wayans Jr., David Krumholtz, Natalie Martinez, and Paula Newsome.</p>
<p>Episode: “Try, Try” : Starring Topher Grace and Kylie Bunbury.</p>
<p>Episode: “You Might Also Like” : Starring Gretchen Mol and Greta Lee.</p>
<p>Episode: “Ovation” : Starring Jurnee Smollett-Bell, Tawny Newsome, Sky Ferreira, Paul F. Tompkins, and Thomas Lennon.</p>
<p>Episode: “Downtime” Starring Morena Baccarin, Colman Domingo and Tony Hale.</p>
<p>Episode: “The Who of You” : Starring Ethan Embry, Daniel Sunjata, and Billy Porter.</p>
<p>Episode: “A Human Face” : Starring Jenna Elfman, Chris Meloni, and Tavi Gevinson.</p>
<p>Episode: “Among The Untrodden” : Introducing Abbie Hern and Sophia Macy.</p>
<p>Episode: “Meet in the Middle” : Starring Jimmi Simpson and Gillian Jacobs.</p>
<p>The original “The Twilight Zone” premiered on Oct. 2, 1959 on CBS. The series became a worldwide phenomenon and took fans on a journey into a wondrous land of imagination from 1959 to 1964.</p>
<p>You can find the CBS All Access app right here on &lt;a href=&#8221;https://itunes.apple.com/us/app/cbs-full-episodes-live-tv/id530168168?mt=8&#8243;>iTunes&lt;/a>, &lt;a href=&#8221;https://play.google.com/store/apps/details?id=com.cbs.app&#8221;>Google Play&lt;/a>, and &lt;a href=&#8221;https://amzn.to/2F0RNGb&#8221;>Amazon&lt;/a>.</p>
<p class="has-text-align-center"><strong><em>Subscribe to <a href="https://theslanted.com/subscribe/">Daily Updates</a> and never miss a headline.</em></strong></p>
<p style="font-size:15px" class="has-text-align-center">Slanted sometimes uses affiliate links and may earn a commission if you purchase items through those links.</p>
<div class="clearfix"></div><footer class="article-footer"> <div class="single-tag-wrap">
<span class="tag-title">Tags :</span>
<a href="https://theslanted.com/topic/casting/" rel="tag">Casting</a><a href="https://theslanted.com/topic/cbs/" rel="tag">CBS</a> </div>
</footer><aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/05/39922/twilight-zone-season-2-cast-announcement/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-05-04T12:14:56+00:00" content="2020-05-04T12:14:56+00:00">May 4, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-05-04T12:15:00+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/05/Twilight-Zone-Season-2.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
<div class="clearfix"></div></div><div class="single-post-ad is-ad-custom single-post-ad-bottom"><a href="https://theslanted.com/movies-tv/?utm_source=Article&utm_medium=banner&utm_campaign=Spring%202020" target="_blank"><img src="https://theslanted.com/wp-content/uploads/2020/04/Banner-Movies-TV.png" alt="Slanted"></a></div> </article>
<div class="single-related-wrap single-box">
<div class="single-related-header block-title">
<h3>others are reading</h3>
</div>
<div class="single-related-content row">
<div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39915 post type-post status-publish format-standard has-post-thumbnail category-television tag-nbc">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/05/39915/peoples-awards-2020-premiere-date-nbc/" title="People&#8217;s Choice Awards to Air in November 2020" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/05/Jennifer-Anniston-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Jennifer Anniston on stage" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/05/Jennifer-Anniston-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Jennifer Anniston on stage" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/05/39915/peoples-awards-2020-premiere-date-nbc/" title="People&#8217;s Choice Awards to Air in November 2020">People&#8217;s Choice Awards to Air in November 2020</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">May 3, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/05/39915/peoples-awards-2020-premiere-date-nbc/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-05-03T22:44:06+00:00" content="2020-05-03T22:44:06+00:00">May 3, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-05-03T22:44:09+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/05/Jennifer-Anniston.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39903 post type-post status-publish format-standard has-post-thumbnail category-television tag-hbo">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/05/39903/hbo-insecure-season-5-trailer/" title="HBO Renews &#8216;Insecure&#8217; for a Fifth Season" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/05/Insecure-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Insecure Season 5" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/05/Insecure-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Insecure Season 5" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/05/39903/hbo-insecure-season-5-trailer/" title="HBO Renews &#8216;Insecure&#8217; for a Fifth Season">HBO Renews &#8216;Insecure&#8217; for a Fifth Season</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">May 2, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/05/39903/hbo-insecure-season-5-trailer/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-05-02T23:35:33+00:00" content="2020-05-02T23:35:33+00:00">May 2, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-05-02T23:35:36+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/05/Insecure.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39899 post type-post status-publish format-standard has-post-thumbnail category-television tag-tv-trailers">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/05/39899/paradise-city-bella-thorne-cameron-boyce-trailer/" title="Cameron Boyce and Bella Thorne Star in &#8216;Paradise City&#8217;" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/05/Paradise-City-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Bella Thorne in Paradise City" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/05/Paradise-City-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Bella Thorne in Paradise City" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/05/39899/paradise-city-bella-thorne-cameron-boyce-trailer/" title="Cameron Boyce and Bella Thorne Star in &#8216;Paradise City&#8217;">Cameron Boyce and Bella Thorne Star in &#8216;Paradise City&#8217;</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">May 2, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/05/39899/paradise-city-bella-thorne-cameron-boyce-trailer/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-05-02T19:27:05+00:00" content="2020-05-02T19:27:05+00:00">May 2, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-05-02T19:27:07+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/05/Paradise-City.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39892 post type-post status-publish format-standard has-post-thumbnail category-television tag-amc tag-tv-trailers">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/05/39892/nos4a2-season-2-premiere-date-amc-bbc-america/" title="AMC Teasers More of &#8216;NOS4A2&#8217; Season 2" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/04/NOS4A2-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="NOS4A2 on AMC" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/04/NOS4A2-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="NOS4A2 on AMC" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/05/39892/nos4a2-season-2-premiere-date-amc-bbc-america/" title="AMC Teasers More of &#8216;NOS4A2&#8217; Season 2">AMC Teasers More of &#8216;NOS4A2&#8217; Season 2</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">May 1, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/05/39892/nos4a2-season-2-premiere-date-amc-bbc-america/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-05-01T11:37:44+00:00" content="2020-05-01T11:37:44+00:00">May 1, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-05-01T11:37:47+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/04/NOS4A2.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39889 post type-post status-publish format-standard has-post-thumbnail category-television tag-tbs">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/05/39889/tbs-wipout-reboot-summer-competition-series/" title="TBS is Bringing Back &#8216;Wipeout&#8217; Challenge Series" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/05/Wipeout-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Wipeout on TBS" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/05/Wipeout-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Wipeout on TBS" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/05/39889/tbs-wipout-reboot-summer-competition-series/" title="TBS is Bringing Back &#8216;Wipeout&#8217; Challenge Series">TBS is Bringing Back &#8216;Wipeout&#8217; Challenge Series</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">May 1, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/05/39889/tbs-wipout-reboot-summer-competition-series/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-05-01T11:29:14+00:00" content="2020-05-01T11:29:14+00:00">May 1, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-05-01T11:29:17+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/05/Wipeout.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39884 post type-post status-publish format-standard has-post-thumbnail category-television tag-appletv tag-tv-trailers">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/05/39884/ghostwriter-reboot-free-books-reading-challenge/" title="&#8216;Ghostwriter&#8217; Premieres with Reading Challenge and Free Books" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/05/Ghostwriter-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Ghostwriter AppleTV" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/05/Ghostwriter-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Ghostwriter AppleTV" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/05/39884/ghostwriter-reboot-free-books-reading-challenge/" title="&#8216;Ghostwriter&#8217; Premieres with Reading Challenge and Free Books">&#8216;Ghostwriter&#8217; Premieres with Reading Challenge and Free Books</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">May 1, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/05/39884/ghostwriter-reboot-free-books-reading-challenge/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-05-01T10:45:34+00:00" content="2020-05-01T10:45:34+00:00">May 1, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-05-01T10:45:36+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/05/Ghostwriter.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39874 post type-post status-publish format-standard has-post-thumbnail category-television tag-netflix tag-tv-trailers">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/04/39874/she-ra-princess-of-power-final-season-trailer/" title="&#8216;She-Ra and the Princess of Power&#8217; Teases the Final Season" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2019/10/She-Ra-Season-4-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="She-Ra in Season 4" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2019/10/She-Ra-Season-4-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="She-Ra in Season 4" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/04/39874/she-ra-princess-of-power-final-season-trailer/" title="&#8216;She-Ra and the Princess of Power&#8217; Teases the Final Season">&#8216;She-Ra and the Princess of Power&#8217; Teases the Final Season</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">April 30, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/04/39874/she-ra-princess-of-power-final-season-trailer/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-04-30T14:30:32+00:00" content="2020-04-30T14:30:32+00:00">April 30, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-04-30T14:31:39+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2019/10/She-Ra-Season-4.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39871 post type-post status-publish format-standard has-post-thumbnail category-television tag-hbo">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/04/39871/hbo-my-brilliant-friend-season-3-confirmation/" title="HBO Renews &#8216;My Brilliant Friend&#8217; for Season 3" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/04/My-Brillian-Friend-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="My Brillian Friend HBO" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/04/My-Brillian-Friend-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="My Brillian Friend HBO" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/04/39871/hbo-my-brilliant-friend-season-3-confirmation/" title="HBO Renews &#8216;My Brilliant Friend&#8217; for Season 3">HBO Renews &#8216;My Brilliant Friend&#8217; for Season 3</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">April 30, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/04/39871/hbo-my-brilliant-friend-season-3-confirmation/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-04-30T13:34:33+00:00" content="2020-04-30T13:34:33+00:00">April 30, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-04-30T13:34:35+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/04/My-Brillian-Friend.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39863 post type-post status-publish format-standard has-post-thumbnail category-television tag-netflix">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/04/39863/netflix-a-week-away-fath-based-movie/" title="Netflix Adds Faith-Friendly Musical &#8216;A Week Away&#8217;" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/04/A-Week-Away-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="A Week Away" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/04/A-Week-Away-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="A Week Away" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/04/39863/netflix-a-week-away-fath-based-movie/" title="Netflix Adds Faith-Friendly Musical &#8216;A Week Away&#8217;">Netflix Adds Faith-Friendly Musical &#8216;A Week Away&#8217;</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">April 29, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/04/39863/netflix-a-week-away-fath-based-movie/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-04-29T16:50:17+00:00" content="2020-04-29T16:50:17+00:00">April 29, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-04-29T16:50:19+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/04/A-Week-Away.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39860 post type-post status-publish format-standard has-post-thumbnail category-television tag-amazon-prime tag-tv-trailers">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/04/39860/hanna-season-2-trailer-prime-video/" title="&#8216;Hanna&#8217; Returns with new Episodes in July" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2019/02/Hanna-Prime-Video-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Hanna + Slanted + Prime Video" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2019/02/Hanna-Prime-Video-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Hanna + Slanted + Prime Video" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/04/39860/hanna-season-2-trailer-prime-video/" title="&#8216;Hanna&#8217; Returns with new Episodes in July">&#8216;Hanna&#8217; Returns with new Episodes in July</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">April 29, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/04/39860/hanna-season-2-trailer-prime-video/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-04-29T13:57:03+00:00" content="2020-04-29T13:57:03+00:00">April 29, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-04-29T13:57:07+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2019/02/Hanna-Prime-Video.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39857 post type-post status-publish format-standard has-post-thumbnail category-television tag-tv-trailers">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/04/39857/gordan-ramsay-uncharted-season-2-trailer/" title="&#8216;Gordon Ramsay Uncharted&#8217; Cooks Up a Second Season in June" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2017/01/Gordan-Ramsey-IVC-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="ivc" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2017/01/Gordan-Ramsey-IVC-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="ivc" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/04/39857/gordan-ramsay-uncharted-season-2-trailer/" title="&#8216;Gordon Ramsay Uncharted&#8217; Cooks Up a Second Season in June">&#8216;Gordon Ramsay Uncharted&#8217; Cooks Up a Second Season in June</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">April 29, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/04/39857/gordan-ramsay-uncharted-season-2-trailer/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-04-29T11:23:26+00:00" content="2020-04-29T11:23:26+00:00">April 29, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-04-29T11:23:28+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2017/01/Gordan-Ramsey-IVC.jpg">
<meta itemprop="width" content="750">
<meta itemprop="height" content="400">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39855 post type-post status-publish format-standard has-post-thumbnail category-television tag-abc tag-disney">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/04/39855/disney-family-singalong-vol-2-abc-mothers-day/" title="&#8216;The Disney Family Singalong Vol II&#8217; is a Mother&#8217;s Day Special" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2019/03/Ariana-Grande-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Ariana Grande + Slanted" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2019/03/Ariana-Grande-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Ariana Grande + Slanted" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/04/39855/disney-family-singalong-vol-2-abc-mothers-day/" title="&#8216;The Disney Family Singalong Vol II&#8217; is a Mother&#8217;s Day Special">&#8216;The Disney Family Singalong Vol II&#8217; is a Mother&#8217;s Day Special</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">April 29, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/04/39855/disney-family-singalong-vol-2-abc-mothers-day/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-04-29T10:48:14+00:00" content="2020-04-29T10:48:14+00:00">April 29, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-04-29T10:48:17+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2019/03/Ariana-Grande.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39853 post type-post status-publish format-standard has-post-thumbnail category-television tag-amazon-prime">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/04/39853/nfl-thursday-night-football-prime-video-amazon/" title="NFL to Stream Thursday Night Football on Prime Video This Year" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2019/04/Stock-Football-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Stock Football + theslanted.com" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2019/04/Stock-Football-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Stock Football + theslanted.com" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/04/39853/nfl-thursday-night-football-prime-video-amazon/" title="NFL to Stream Thursday Night Football on Prime Video This Year">NFL to Stream Thursday Night Football on Prime Video This Year</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">April 29, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/04/39853/nfl-thursday-night-football-prime-video-amazon/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-04-29T10:35:29+00:00" content="2020-04-29T10:35:29+00:00">April 29, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-04-29T10:35:34+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2019/04/Stock-Football.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39850 post type-post status-publish format-standard has-post-thumbnail category-television tag-marvel tag-tv-trailers">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/04/39850/marvels-agents-of-shield-season-7-trailer/" title="&#8216;Marvel’s Agents of SHIELD&#8217; Teases its Final Season" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2019/03/Agents-of-SHIELD-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Agents of Shield + Slanted" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2019/03/Agents-of-SHIELD-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Agents of Shield + Slanted" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/04/39850/marvels-agents-of-shield-season-7-trailer/" title="&#8216;Marvel’s Agents of SHIELD&#8217; Teases its Final Season">&#8216;Marvel’s Agents of SHIELD&#8217; Teases its Final Season</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">April 28, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/04/39850/marvels-agents-of-shield-season-7-trailer/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-04-28T15:03:25+00:00" content="2020-04-28T15:03:25+00:00">April 28, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-04-28T15:03:29+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2019/03/Agents-of-SHIELD.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39846 post type-post status-publish format-standard has-post-thumbnail category-television tag-netflix tag-tv-trailers">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/04/39846/netflix-michelle-obama-becoming-series/" title="Michelle Obama&#8217;s &#8216;Becoming&#8217; sets May Premiere on Netflix" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/04/Becoming_Doc_01_01_42_10_R2-scaled-e1588092972903-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Michelle Obama on Becoming" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/04/Becoming_Doc_01_01_42_10_R2-scaled-e1588092972903-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Michelle Obama on Becoming" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/04/39846/netflix-michelle-obama-becoming-series/" title="Michelle Obama&#8217;s &#8216;Becoming&#8217; sets May Premiere on Netflix">Michelle Obama&#8217;s &#8216;Becoming&#8217; sets May Premiere on Netflix</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">April 28, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/04/39846/netflix-michelle-obama-becoming-series/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-04-28T13:05:43+00:00" content="2020-04-28T13:05:43+00:00">April 28, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-04-28T13:05:46+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/04/Becoming_Doc_01_01_42_10_R2-scaled-e1588092972903.jpg">
<meta itemprop="width" content="1199">
<meta itemprop="height" content="639">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39842 post type-post status-publish format-standard has-post-thumbnail category-television tag-hbo">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/04/39842/an-american-pickle-seth-rogen-hbo/" title="Seth Rogen&#8217;s &#8216;An American Pickle&#8217; Heads to HBO Max" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2019/05/Seth-Rogan-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="seth rogan on red carpet" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2019/05/Seth-Rogan-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="seth rogan on red carpet" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/04/39842/an-american-pickle-seth-rogen-hbo/" title="Seth Rogen&#8217;s &#8216;An American Pickle&#8217; Heads to HBO Max">Seth Rogen&#8217;s &#8216;An American Pickle&#8217; Heads to HBO Max</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">April 27, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/04/39842/an-american-pickle-seth-rogen-hbo/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-04-27T23:55:07+00:00" content="2020-04-27T23:55:07+00:00">April 27, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-04-27T23:55:13+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2019/05/Seth-Rogan.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39838 post type-post status-publish format-standard has-post-thumbnail category-television tag-netflix tag-tv-trailers">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/04/39838/the-kimmy-schmidt-interactive-special-sets-may-premiere-date/" title="The &#8216;Kimmy Schmidt&#8217; Interactive Special Sets May Premiere Date" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2019/05/Unbreakable-Kimmy-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Ellie Kemper in Kimmy Schmidt" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2019/05/Unbreakable-Kimmy-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Ellie Kemper in Kimmy Schmidt" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/04/39838/the-kimmy-schmidt-interactive-special-sets-may-premiere-date/" title="The &#8216;Kimmy Schmidt&#8217; Interactive Special Sets May Premiere Date">The &#8216;Kimmy Schmidt&#8217; Interactive Special Sets May Premiere Date</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">April 27, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/04/39838/the-kimmy-schmidt-interactive-special-sets-may-premiere-date/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-04-27T15:59:55+00:00" content="2020-04-27T15:59:55+00:00">April 27, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-04-27T15:59:58+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2019/05/Unbreakable-Kimmy.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39829 post type-post status-publish format-standard has-post-thumbnail category-television">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/04/39829/love-victor-hulu-michael-cimino-series/" title="Michael Cimino&#8217;s &#8216;Love, Victor&#8217; to Premier on Hulu in June" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/04/Love-Victor-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Michael Cimino in Love Victor" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/04/Love-Victor-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Michael Cimino in Love Victor" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/04/39829/love-victor-hulu-michael-cimino-series/" title="Michael Cimino&#8217;s &#8216;Love, Victor&#8217; to Premier on Hulu in June">Michael Cimino&#8217;s &#8216;Love, Victor&#8217; to Premier on Hulu in June</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">April 26, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/04/39829/love-victor-hulu-michael-cimino-series/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-04-26T22:58:20+00:00" content="2020-04-26T22:58:20+00:00">April 26, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-04-26T22:58:25+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/04/Love-Victor.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39825 post type-post status-publish format-standard has-post-thumbnail category-television tag-hbo tag-tv-trailers">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/04/39825/michaela-coel-i-may-destroy-you-hbo-series/" title="HBO Shares a Preview of Michaela Coel&#8217;s &#8216;I May Destroy You&#8217;" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/04/I-May-Destory-You-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="I May Destory You" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/04/I-May-Destory-You-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="I May Destory You" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/04/39825/michaela-coel-i-may-destroy-you-hbo-series/" title="HBO Shares a Preview of Michaela Coel&#8217;s &#8216;I May Destroy You&#8217;">HBO Shares a Preview of Michaela Coel&#8217;s &#8216;I May Destroy You&#8217;</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">April 26, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/04/39825/michaela-coel-i-may-destroy-you-hbo-series/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-04-26T18:48:26+00:00" content="2020-04-26T18:48:26+00:00">April 26, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-04-26T18:48:31+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/04/I-May-Destory-You.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39822 post type-post status-publish format-standard has-post-thumbnail category-television tag-appletv tag-casting">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/04/39822/will-ferrell-paul-rudd-shrink-next-door-apple/" title="Will Ferrell and Paul Rudd Team Up for &#8216;The Shrink Next Door&#8217;" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/04/Rudd-and-Ferrell-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Will Ferrell and Paul Rudd" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/04/Rudd-and-Ferrell-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Will Ferrell and Paul Rudd" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/04/39822/will-ferrell-paul-rudd-shrink-next-door-apple/" title="Will Ferrell and Paul Rudd Team Up for &#8216;The Shrink Next Door&#8217;">Will Ferrell and Paul Rudd Team Up for &#8216;The Shrink Next Door&#8217;</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">April 26, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/04/39822/will-ferrell-paul-rudd-shrink-next-door-apple/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-04-26T17:11:58+00:00" content="2020-04-26T17:11:58+00:00">April 26, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-04-26T17:12:04+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/04/Rudd-and-Ferrell.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39809 post type-post status-publish format-standard has-post-thumbnail category-television tag-showtime">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/04/39809/black-monday-season-2-returns-june-showtime/" title="&#8216;Black Monday&#8217; Season 2 to Resume in June" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/04/Black-Monday-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Showtime Black Monday" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/04/Black-Monday-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Showtime Black Monday" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/04/39809/black-monday-season-2-returns-june-showtime/" title="&#8216;Black Monday&#8217; Season 2 to Resume in June">&#8216;Black Monday&#8217; Season 2 to Resume in June</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">April 25, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/04/39809/black-monday-season-2-returns-june-showtime/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-04-25T21:47:27+00:00" content="2020-04-25T21:47:27+00:00">April 25, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-04-25T21:47:32+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/04/Black-Monday.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39799 post type-post status-publish format-standard has-post-thumbnail category-television tag-netflix tag-tv-trailers">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/04/39799/dead-to-me-season-2-trailer-premiere-date/" title="&#8216;Dead to Me&#8217; Shares a Preview of Season 2" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/04/Dead-to-Me-Season-2-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Dead to Me Season 2" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/04/Dead-to-Me-Season-2-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Dead to Me Season 2" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/04/39799/dead-to-me-season-2-trailer-premiere-date/" title="&#8216;Dead to Me&#8217; Shares a Preview of Season 2">&#8216;Dead to Me&#8217; Shares a Preview of Season 2</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">April 24, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/04/39799/dead-to-me-season-2-trailer-premiere-date/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-04-24T15:33:31+00:00" content="2020-04-24T15:33:31+00:00">April 24, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-04-24T15:33:33+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/04/Dead-to-Me-Season-2.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39791 post type-post status-publish format-standard has-post-thumbnail category-television tag-showtime tag-tv-trailers">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/04/39791/penny-dreadful-city-of-angels-premiere-showtime/" title="You Can Stream the &#8216;Penny Dreadful: City of Angels&#8217; Premiere Online for Free" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/01/Penny-Dreadful-City-of-Angels-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Penny Dreadful City of Angels" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/01/Penny-Dreadful-City-of-Angels-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Penny Dreadful City of Angels" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/04/39791/penny-dreadful-city-of-angels-premiere-showtime/" title="You Can Stream the &#8216;Penny Dreadful: City of Angels&#8217; Premiere Online for Free">You Can Stream the &#8216;Penny Dreadful: City of Angels&#8217; Premiere Online for Free</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">April 24, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/04/39791/penny-dreadful-city-of-angels-premiere-showtime/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-04-24T12:39:59+00:00" content="2020-04-24T12:39:59+00:00">April 24, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-04-24T12:40:05+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/01/Penny-Dreadful-City-of-Angels.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39787 post type-post status-publish format-standard has-post-thumbnail category-television tag-tv-trailers">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/04/39787/happiness-continues-jonas-brothers-concert-film-prime-video/" title="&#8216;Happiness Continues: A Jonas Brothers Concert Film&#8217; Launches on Prime Video" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/04/Happiness-Continues-Jonas-Brothers-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Happiness Continues: A Jonas Brothers Concert Film" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/04/Happiness-Continues-Jonas-Brothers-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Happiness Continues: A Jonas Brothers Concert Film" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/04/39787/happiness-continues-jonas-brothers-concert-film-prime-video/" title="&#8216;Happiness Continues: A Jonas Brothers Concert Film&#8217; Launches on Prime Video">&#8216;Happiness Continues: A Jonas Brothers Concert Film&#8217; Launches on Prime Video</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">April 23, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/04/39787/happiness-continues-jonas-brothers-concert-film-prime-video/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-04-23T22:48:32+00:00" content="2020-04-23T22:48:32+00:00">April 23, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-04-23T22:48:35+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/04/Happiness-Continues-Jonas-Brothers.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39784 post type-post status-publish format-standard has-post-thumbnail category-television tag-nbc">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/04/39784/parks-and-rec-reunion-special-charity/" title="The &#8216;Parks &#038; Recreation&#8217; Cast is Reuniting for a Charity Special" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/04/Parks-and-Rec-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Parks and Recreation" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/04/Parks-and-Rec-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Parks and Recreation" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/04/39784/parks-and-rec-reunion-special-charity/" title="The &#8216;Parks &#038; Recreation&#8217; Cast is Reuniting for a Charity Special">The &#8216;Parks &#038; Recreation&#8217; Cast is Reuniting for a Charity Special</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">April 23, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/04/39784/parks-and-rec-reunion-special-charity/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-04-23T19:22:42+00:00" content="2020-04-23T19:22:42+00:00">April 23, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-04-23T19:22:44+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/04/Parks-and-Rec.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39778 post type-post status-publish format-standard has-post-thumbnail category-television tag-hulu tag-tv-trailers">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/04/39778/elle-fanning-the-great-hulu-trailer/" title="Add Elle Fanning and Nicholas Hoult&#8217;s &#8216;The Great&#8217; to Your May Watchlist" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/01/The-Great-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Elle Fanning in The Great" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/01/The-Great-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Elle Fanning in The Great" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/04/39778/elle-fanning-the-great-hulu-trailer/" title="Add Elle Fanning and Nicholas Hoult&#8217;s &#8216;The Great&#8217; to Your May Watchlist">Add Elle Fanning and Nicholas Hoult&#8217;s &#8216;The Great&#8217; to Your May Watchlist</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">April 23, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/04/39778/elle-fanning-the-great-hulu-trailer/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-04-23T13:40:23+00:00" content="2020-04-23T13:40:23+00:00">April 23, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-04-23T13:40:25+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/01/The-Great.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39773 post type-post status-publish format-standard has-post-thumbnail category-television tag-netflix tag-tv-trailers">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/04/39773/netflix-pokemon-journeys-animated-series-traile/" title="Ash Hits the Road in &#8216;Pokémon Journeys: The Series&#8217; This Summer" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/04/Pokemon-Journeys-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Pokemon Journeys" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/04/Pokemon-Journeys-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Pokemon Journeys" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/04/39773/netflix-pokemon-journeys-animated-series-traile/" title="Ash Hits the Road in &#8216;Pokémon Journeys: The Series&#8217; This Summer">Ash Hits the Road in &#8216;Pokémon Journeys: The Series&#8217; This Summer</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">April 23, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/04/39773/netflix-pokemon-journeys-animated-series-traile/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-04-23T11:37:29+00:00" content="2020-04-23T11:37:29+00:00">April 23, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-04-23T11:37:31+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/04/Pokemon-Journeys.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39770 post type-post status-publish format-standard has-post-thumbnail category-television tag-quibi-news">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/04/39770/quibi-horror-accidental-anthology-series/" title="Quibi Announces Horror Anthology Series &#8216;Horror Accidental&#8217;" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/04/Quibi-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Quibi" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/04/Quibi-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Quibi" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/04/39770/quibi-horror-accidental-anthology-series/" title="Quibi Announces Horror Anthology Series &#8216;Horror Accidental&#8217;">Quibi Announces Horror Anthology Series &#8216;Horror Accidental&#8217;</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">April 23, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/04/39770/quibi-horror-accidental-anthology-series/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-04-23T01:00:07+00:00" content="2020-04-23T01:00:07+00:00">April 23, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-04-23T01:00:12+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/04/Quibi.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39767 post type-post status-publish format-standard has-post-thumbnail category-television tag-disney-plus">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/04/39767/leslye-headland-star-wars-series-disney-plus/" title="A new &#8216;Star Wars&#8217; Series Might Be Coming to Disney Plus from Leslye Headland" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2019/05/Star-Wars-The-Rise-of-the-Skywalker-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Star Wars The Rise of the Skywalker Scene" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2019/05/Star-Wars-The-Rise-of-the-Skywalker-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Star Wars The Rise of the Skywalker Scene" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/04/39767/leslye-headland-star-wars-series-disney-plus/" title="A new &#8216;Star Wars&#8217; Series Might Be Coming to Disney Plus from Leslye Headland">A new &#8216;Star Wars&#8217; Series Might Be Coming to Disney Plus from Leslye Headland</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">April 22, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/04/39767/leslye-headland-star-wars-series-disney-plus/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-04-22T19:04:09+00:00" content="2020-04-22T19:04:09+00:00">April 22, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-04-22T19:04:19+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2019/05/Star-Wars-The-Rise-of-the-Skywalker.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39764 post type-post status-publish format-standard has-post-thumbnail category-television tag-dc-comics tag-syfy tag-tv-trailers">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/04/39764/syfy-harley-quinn-animated-series/" title="SYFY to air &#8216;Harley Quinn&#8217; Animated Series on Sundays in May" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2019/11/Harley-Quinn-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Harley Quinn animated series" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2019/11/Harley-Quinn-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Harley Quinn animated series" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/04/39764/syfy-harley-quinn-animated-series/" title="SYFY to air &#8216;Harley Quinn&#8217; Animated Series on Sundays in May">SYFY to air &#8216;Harley Quinn&#8217; Animated Series on Sundays in May</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">April 22, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/04/39764/syfy-harley-quinn-animated-series/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-04-22T17:04:56+00:00" content="2020-04-22T17:04:56+00:00">April 22, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-04-22T17:04:59+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2019/11/Harley-Quinn.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div> </div>
</div>
</div><aside id="sidebar" class="sidebar-wrap col-sm-4 col-xs-12 clearfix" role="complementary"><div class="sidebar-inner"></div></aside></div></div></div>
<footer id="footer" class="footer-wrap is-dark-text">
<div class="top-footer-wrap">
<div class="top-footer-inner">
</div>
</div>
<div class="footer-inner">
<div class="footer-social-bar-wrap">
<div class="ruby-container">
<div class="footer-social-bar-inner">
<div class="footer-logo">
<a href="https://theslanted.com/" class="logo" title="Slanted">
<img src="https://theslanted.com/wp-content/uploads/2018/02/Slanted-18-Retina.png" height="200" width="670" alt="Slanted">
</a>
</div>
<div class="social-link-info clearfix footer-social-wrap"><a class="color-facebook" title="Facebook" href="https://www.facebook.com/theslanted" target="_blank"><i class="fa fa-facebook"></i></a><a class="color-twitter" title="Twitter" href="https://twitter.com/theslanted" target="_blank"><i class="fa fa-twitter"></i></a><a class="color-instagram" title="Instagram" href="https://www.instagram.com/theslanted" target="_blank"><i class="fa fa-instagram"></i></a><a class="color-youtube" title="Youtube" href="https://www.youtube.com/c/TheSlanted" target="_blank"><i class="fa fa-youtube"></i></a><a class="color-Reddit" title="Reddit" href="https://www.reddit.com/r/Slanted_RSS_Feed/new/" target="_blank"><i class="fa fa-reddit"></i></a><a class="color-Apple News" title="Apple News" href="https://apple.news/TK1UJU7kBTA6GU6eR0IPK8g" target="_blank"><i class="fa fa-apple"></i></a><a class="color-Google News" title="Google News" href="https://news.google.com/publications/CAAqBwgKMOz0lQswr5itAw?oc=3&#038;ceid=US:en" target="_blank"><i class="fa fa-google"></i></a></div> </div>
<div id="footer-copyright" class="footer-copyright-wrap">
<div class='code-block code-block-1' style='margin: 8px 0; clear: both;'>
<p id="breadcrumbs"><span><span><a href="https://theslanted.com/">Slanted</a> &gt; <span><a href="https://theslanted.com/coverage/television/">TV</a> &gt; <span class="breadcrumb_last" aria-current="page">&#8216;The Twilight Zone&#8217; Announces Season 2 Cast List</span></span></span></span></p></div>
<p>the slanted is owned an operated by Grimm Media Publications LLC</p>
</div>
</div>
</div>
</div>
</footer></div>
</div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script defer src='https://theslanted.com/wp-content/plugins/look-ruby-core/assets/core.js?ver=5.1'></script>
<script defer src='https://theslanted.com/wp-content/plugins/sg-cachepress/assets/js/lazysizes.min.js?ver=5.4.6'></script>
<script defer src='https://theslanted.com/wp-content/themes/look/assets/external/external-script.js?ver=5.1'></script>
<script>
var look_ruby_ajax_url = "https:\/\/theslanted.com\/wp-admin\/admin-ajax.php";
var look_ruby_to_top = "1";
var look_ruby_to_top_mobile = "1";
</script>
<script defer src='https://theslanted.com/wp-content/themes/look/assets/js/theme-script.js?ver=5.1'></script>
<script src='https://theslanted.com/wp-includes/js/wp-embed.min.js?ver=5.4.1'></script>
</body>
</html>