<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8" />
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<script src="/cdn-cgi/apps/head/DA62IkZObcR4JmtKYSQohGU_Yuo.js"></script><link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://theslanted.com/xmlrpc.php" />
<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png?v=2b0JJxJGxR">
<link rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png?v=2b0JJxJGxR">
<link rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png?v=2b0JJxJGxR">
<link rel="manifest" href="/site.webmanifest?v=2b0JJxJGxR">
<link rel="mask-icon" href="/safari-pinned-tab.svg?v=2b0JJxJGxR" color="#5bbad5">
<link rel="shortcut icon" href="/favicon.ico?v=2b0JJxJGxR">
<meta name="apple-mobile-web-app-title" content="Slanted">
<meta name="application-name" content="Slanted">
<meta name="msapplication-TileColor" content="#00aba9">
<meta name="msapplication-TileImage" content="/mstile-144x144.png?v=2b0JJxJGxR">
<meta name="theme-color" content="#ffffff">
<meta name="twitter:description" content="Instant coverage of Movies, TV, culture,and pop culture lifestyle.">
<title>&#039;The Last Kids on Earth: Season 2&#039; Starts on April 17th</title>

<meta name="description" content="Netflix&#039;s The Last Kids on Earth: Season 2 will begin on April 17th, and the video streaming service released a first look trailer." />
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://theslanted.com/2020/04/39440/the-last-kids-on-earth-season-2-april-premiere/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="&#039;The Last Kids on Earth: Season 2&#039; Starts on April 17th" />
<meta property="og:description" content="Watch the Season 2 trailer" />
<meta property="og:url" content="https://theslanted.com/2020/04/39440/the-last-kids-on-earth-season-2-april-premiere/" />
<meta property="og:site_name" content="Slanted" />
<meta property="article:publisher" content="https://www.facebook.com/TheSlanted" />
<meta property="article:tag" content="Netflix" />
<meta property="article:tag" content="TV Trailers" />
<meta property="article:section" content="TV News" />
<meta property="article:published_time" content="2020-04-03T17:23:07+00:00" />
<meta property="fb:app_id" content="663549953797892" />
<meta property="og:image" content="https://theslanted.com/wp-content/uploads/2020/04/Last-Kids-on-Earth-Season-2.jpg" />
<meta property="og:image:secure_url" content="https://theslanted.com/wp-content/uploads/2020/04/Last-Kids-on-Earth-Season-2.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="640" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Netflix&#039;s The Last Kids on Earth: Season 2 will begin on April 17th, and the video streaming service released a first look trailer." />
<meta name="twitter:title" content="&#039;The Last Kids on Earth: Season 2&#039; Starts on April 17th" />
<meta name="twitter:site" content="@theslanted" />
<meta name="twitter:image" content="https://theslanted.com/wp-content/uploads/2020/04/Last-Kids-on-Earth-Season-2.jpg" />
<meta name="twitter:creator" content="@theslanted" />

<link rel="amphtml" href="https://theslanted.com/2020/04/39440/the-last-kids-on-earth-season-2-april-premiere/amp/" /><meta name="generator" content="AMP for WP 1.0.36" /><link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="Slanted &raquo; Feed" href="https://theslanted.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Slanted &raquo; Comments Feed" href="https://theslanted.com/comments/feed/" />
<link rel='stylesheet' id='look_ruby_plugin_core_style-css' href='https://theslanted.com/wp-content/plugins/look-ruby-core/assets/core.css?ver=2.2' media='all' />
<link rel='stylesheet' id='google-font-playfair-display-raleway-css' href='https://fonts.googleapis.com/css?family=Raleway%3A400%2C500%2C600%2C700&#038;subset=latin-ext&#038;display=swap' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://theslanted.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' media='all' />
<link rel='stylesheet' id='wp-block-library-theme-css' href='https://theslanted.com/wp-includes/css/dist/block-library/theme.min.css?ver=5.3.2' media='all' />
<link rel='stylesheet' id='look_ruby_external_style-css' href='https://theslanted.com/wp-content/themes/look/assets/external/external-style.css?ver=5.1' media='all' />
<link rel='stylesheet' id='look_ruby_main_style-css' href='https://theslanted.com/wp-content/themes/look/assets/css/theme-style.css?ver=5.1' media='all' />
<link rel='stylesheet' id='look_ruby_responsive_style-css' href='https://theslanted.com/wp-content/themes/look/assets/css/theme-responsive.css?ver=5.1' media='all' />
<style id='look_ruby_responsive_style-inline-css'>
h1, h2, h3, h4, h5, h6,.post-counter, .logo-text, .banner-content-wrap, .post-review-score,.woocommerce .price, blockquote{ font-family :Playfair Display;font-weight :400;}input, textarea, h3.comment-reply-title, .comment-title h3,.counter-element-right, .pagination-wrap{ font-family :Nunito;}.post-title.is-big-title{ font-size: 26px; }.post-title.is-medium-title{ font-size: 25px; }.post-title.is-small-title, .post-title.is-mini-title{ font-size: 28px; }.single .post-title.single-title{ font-size: 46px; }.post-excerpt { font-size: 16px; }.entry { line-height:29px;}.header-style-1 .header-banner-wrap {padding-top: 1px;padding-bottom: 1px;}.main-nav-inner > li > a:hover, .main-nav-inner > li > a:focus, .nav-search-wrap a:hover {opacity: 1;color:#584585;}.ruby-trigger:hover .icon-wrap, .ruby-trigger:hover .icon-wrap:before, .ruby-trigger:hover .icon-wrap:after{background-color:#584585;}@media only screen and (min-width: 992px) { .ruby-container { max-width: 1080px; } }.post-review-score, .score-bar { background-color: #584585;}.footer-social-bar-wrap { background-color: #ffffff;}.post-share-bar-inner:before, .block-view-more a, .single-share-bar-total.share-bar-total, .header-social-wrap a:hover,.is-light-text .footer-social-wrap a:hover, .post-counter,.off-canvas-wrap .off-canvas-social-wrap a:hover, .off-canvas-wrap .off-canvas-social-wrap a:focus,.entry a:not(.button), .excerpt a, .block-fw-subscribe .subscribe-box .mc4wp-form-fields input[type=submit]:hover+i{ color: #fa7268;}button[type="submit"], input[type="submit"], .single-tag-wrap .tag-title,.page-numbers.current, a.page-numbers:hover, a.page-numbers:focus,.share-bar-el:hover i, .share-bar-icon:hover i, .sb-widget-social-counter .counter-element:hover,.ruby-trigger:hover .icon-wrap, .ruby-trigger:focus .icon-wrap,.ruby-trigger:hover .icon-wrap:before, .ruby-trigger:focus .icon-wrap:before,.ruby-trigger:hover .icon-wrap:after, .ruby-trigger:focus .icon-wrap:after{ background-color: #fa7268;}.post-grid-small:hover .post-header-inner,.page-numbers.current, a.page-numbers:hover, a.page-numbers:focus,.share-bar-el:hover i, .share-bar-icon:hover i{ border-color: #fa7268;}.header-outer {
    margin-bottom: 5px;
}

.header-banner-wrap {
    padding: 5px 5px;
}

.header-nav-holder {
    min-height: 5px;
}

.single-tag-wrap {
    display: none;
}

.post-cat-info {
    font-size: 19px;
}

.archive-page-header {
    height: 40px;
}

.logo-text {
    color: #756e6e;
    text-transform: uppercase;
    font-weight: 100;
    font-size: 40px;
    font-style: italic;
    background-color: #FFEBE0;
}

.site-tagline {
    display: none;
}

.post-wrap.post-list-mini .post-meta-info {
    display: none;
}

.archive-page-header:not(.has-bg-image) {
    height: 50px;
}

.breadcrumb_last {
    display: none;
}

.single .post-title.single-title h1 {
    background: #FFEBE0;
}

.post-header-meta {
    display: none;
}

.footer-copyright-wrap {
    display: none;
}

.post-wrap .post-title {
    margin: 0 0 2px 0;
}

.post-title.is-small-title, .post-title.is-mini-title {
    font-size: 19px;
}


.post-grid-small .post-title a {
    background: #FFEBE0;
}

.ruby-page-wrap {
    margin-top: 5px;
    margin-bottom: 5px;
}

.entry {
    margin-right: 15px;
}
</style>
<link rel='stylesheet' id='look_ruby_default_style-css' href='https://theslanted.com/wp-content/themes/look/style.css?ver=5.1' media='all' />
<link rel='stylesheet' id='redux-google-fonts-look_ruby_theme_options-css' href='https://fonts.googleapis.com/css?family=Nunito+Sans%3A200%2C300%2C400%2C600%2C700%2C800%2C900%2C200italic%2C300italic%2C400italic%2C600italic%2C700italic%2C800italic%2C900italic%7CPlayfair+Display%3A400%2C700%2C900%2C400italic%2C700italic%2C900italic%7CNunito%3A200%2C300%2C400%2C600%2C700%2C800%2C900%2C200italic%2C300italic%2C400italic%2C600italic%2C700italic%2C800italic%2C900italic%7CMuli%3A200%2C300%2C400%2C600%2C700%2C800%2C900%2C200italic%2C300italic%2C400italic%2C600italic%2C700italic%2C800italic%2C900italic&#038;subset=latin&#038;ver=1584246920' media='all' />
<script src='https://theslanted.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script src='https://theslanted.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<!--[if lt IE 9]>
<script src='https://theslanted.com/wp-content/themes/look/assets/external/html5.js?ver=3.7.3'></script>
<![endif]-->
<script defer src='https://www.googletagmanager.com/gtag/js?id=UA-40601418-1#038;siteground-async=1' async></script>
<script>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());
gtag('config', 'UA-40601418-1', {"anonymize_ip":true} );
</script>
<link rel='https://api.w.org/' href='https://theslanted.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://theslanted.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://theslanted.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.3.2" />
<link rel='shortlink' href='https://slntd.co/3dREnNA' />
<link rel="alternate" type="application/json+oembed" href="https://theslanted.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftheslanted.com%2F2020%2F04%2F39440%2Fthe-last-kids-on-earth-season-2-april-premiere%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://theslanted.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftheslanted.com%2F2020%2F04%2F39440%2Fthe-last-kids-on-earth-season-2-april-premiere%2F&#038;format=xml" />
<meta name="generator" content="Site Kit by Google 1.6.0" />

<script type="application/ld+json" class="saswp-schema-markup-output">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</script>
<link rel="icon" href="https://theslanted.com/wp-content/uploads/2019/01/cropped-SiteIcon-32x32.png" sizes="32x32" />
<link rel="icon" href="https://theslanted.com/wp-content/uploads/2019/01/cropped-SiteIcon-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://theslanted.com/wp-content/uploads/2019/01/cropped-SiteIcon-180x180.png" />
<meta name="msapplication-TileImage" content="https://theslanted.com/wp-content/uploads/2019/01/cropped-SiteIcon-270x270.png" />
<style type="text/css" title="dynamic-css" class="options-output">body{background-color:#f2f2f1;background-repeat:no-repeat;background-size:inherit;background-attachment:inherit;background-position:center top;}.header-banner-wrap{background-color:#ffffff;background-repeat:repeat-x;background-size:inherit;background-attachment:fixed;background-position:center center;}.footer-inner{background-color:#ffffff;background-repeat:no-repeat;background-size:contain;background-attachment:fixed;background-position:center center;}body{font-family:"Nunito Sans",Arial, Helvetica, sans-serif;text-transform:none;line-height:29px;letter-spacing:.1px;font-weight:300;font-style:normal;color:#424242;font-size:22px;}.post-title,.product_title,.widget_recent_entries li{font-family:"Playfair Display",Arial, Helvetica, sans-serif;text-transform:none;letter-spacing:1px;font-weight:400;font-style:italic;color:#363636;}.post-cat-info{font-family:Nunito,Arial, Helvetica, sans-serif;text-transform:uppercase;letter-spacing:2px;font-weight:200;font-style:normal;color:#dd3333;font-size:20px;}.post-meta-info,.share-bar-total,.block-view-more,.single-tag-wrap,.author-job,.nav-arrow,.comment-metadata time,.comment-list .reply,.edit-link{font-family:Nunito;text-transform:capitalize;letter-spacing:1px;font-weight:200;font-style:normal;color:#4c4c4c;font-size:14px;}.main-nav-wrap,.off-canvas-nav-wrap{font-family:Muli,Arial, Helvetica, sans-serif;text-transform:uppercase;letter-spacing:2px;font-weight:normal;font-style:normal;font-size:16px;}.top-bar-menu{font-family:Muli,Arial, Helvetica, sans-serif;text-transform:uppercase;letter-spacing:1px;font-weight:400;font-style:normal;font-size:16px;}.block-title,.widget-title,section.products > h2{font-family:Muli,Arial, Helvetica, sans-serif;text-transform:none;letter-spacing:1px;font-weight:normal;font-style:normal;color:#ff3c36;font-size:25px;}</style><style>
.ai-viewport-3                { display: none !important;}
.ai-viewport-2                { display: none !important;}
.ai-viewport-1                { display: inherit !important;}
.ai-viewport-0                { display: none !important;}
@media (min-width: 768px) and (max-width: 979px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-2                { display: inherit !important;}
}
@media (max-width: 767px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-3                { display: inherit !important;}
}
</style>
</head>
<body class="post-template-default single single-post postid-39440 single-format-standard ruby-body is-boxed is-site-bg is-sticky-nav is-site-smooth-scroll is-left-margin">
<div class="off-canvas-wrap is-dark-text">
<div class="off-canvas-inner">
<a href="#" id="ruby-off-canvas-close-btn"><i class="ruby-close-btn" aria-hidden="true"></i></a>
<div id="off-canvas-navigation" class="off-canvas-nav-wrap">
<ul id="menu-normal-menu" class="off-canvas-nav-inner"><li id="menu-item-32978" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-32978"><a title="Slanted" href="https://theslanted.com">Home</a></li>
<li id="menu-item-32972" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32972"><a title="Headlines" href="https://theslanted.com/movies-tv/">Movies &#038; TV</a></li>
<li id="menu-item-39224" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39224"><a href="https://theslanted.com/2020/03/39133/movie-releases-put-on-hold-as-coronovirus-closes-theaters-updating/">Movie Delays</a></li>
<li id="menu-item-32974" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32974"><a title="Digital and Blu-Ray Dates" href="https://theslanted.com/weekend-box-office/">Box Office | Digital</a></li>
<li id="menu-item-32973" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32973"><a title="Games, Apps and Tech" href="https://theslanted.com/lifestyle/">Tech &#038; Lifestyle</a></li>
<li id="menu-item-32976" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32976"><a title="Headlines" href="https://theslanted.com/culture-celebrity/">Culture &#038; Celebrity</a></li>
<li id="menu-item-35179" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35179"><a href="https://theslanted.com/trailers-online/">Latest Trailers</a></li>
<li id="menu-item-32990" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32990"><a href="https://theslanted.com/subscribe/">Subscribe</a></li>
<li id="menu-item-32975" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-32975"><a title="Our TOS" href="https://theslanted.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-32977" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32977"><a title="Email" href="https://theslanted.com/about/">Contact Us</a></li>
</ul> </div>
</div>
</div><div class="main-site-outer">
<div class="header-outer header-style-1">
<div class="header-wrap">
<div class="header-banner-wrap clearfix">
<div class="off-canvas-btn-wrap">
<div class="off-canvas-btn">
<a href="#" class="ruby-trigger" title="off canvas button">
<span class="icon-wrap"></span>
</a>
</div>
</div>
<div class="header-social-wrap">
<div class="banner-search-wrap">
<a href="#" id="ruby-banner-search" data-mfp-src="#ruby-banner-search-form" data-effect="mpf-ruby-effect" title="search" class="banner-search-icon">
<i class="fa fa-search"></i>
</a>
</div> </div>
<div class="header-logo-wrap"><a class="logo-image" href="https://theslanted.com"><img class="logo-img-data" src="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png" alt="Slanted" height="50" width="200"></a></div></div>
<div class="header-nav-wrap clearfix">
<div class="header-nav-inner">
<div class="ruby-container">
<div class="header-nav-holder clearfix">
<div class="off-canvas-btn-wrap">
<div class="off-canvas-btn">
<a href="#" class="ruby-trigger" title="off canvas button">
<span class="icon-wrap"></span>
</a>
</div>
</div>
<nav id="navigation" class="main-nav-wrap" role="navigation">
</nav>
<div class="header-logo-mobile-wrap"><a class="logo-image-mobile" href="https://theslanted.com"><img class="logo-img-data" src="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Topper.png" alt="Slanted" height="100" width="335"></a></div> <div class="nav-search-wrap">
<a href="#" id="ruby-nav-search" data-mfp-src="#ruby-banner-search-form" data-effect="mpf-ruby-effect" title="search" class="banner-search-icon">
<i class="fa fa-search"></i>
</a>
</div> </div>
</div>
</div>
</div>
</div>
<div id="ruby-banner-search-form" class="banner-search-form-wrap mfp-hide mfp-animation">
<div class="banner-search-form-inner">
<form method="get" action="https://theslanted.com/">
<div class="ruby-search">
<span class="ruby-search-input"><input type="text" class="field" placeholder="Search and hit enter&hellip;" value="" name="s" title="Search for:" /></span>
<span class="ruby-search-submit"><input type="submit" value="" /><i class="fa fa-search"></i></span>
</div>
</form>
</div>
</div>
</div>
<div class="main-site-wrap">
<div class="main-site-mask"></div>
<div id="ruby-site-content" class="main-site-content-wrap clearfix">
<div class="single-post-outer clearfix" data-post_url="https://theslanted.com/2020/04/39440/the-last-kids-on-earth-season-2-april-premiere/" data-post_id="39440" data-url="https://theslanted.com/2020/04/39440/the-last-kids-on-earth-season-2-april-premiere/"><div class="ruby-page-wrap ruby-section row single-wrap single-style-1 is-sidebar-none ruby-container"><div class="ruby-content-wrap single-inner content-without-sidebar col-xs-12"> <article id="post-39440" class="post-wrap post-39440 post type-post status-publish format-standard has-post-thumbnail category-television tag-netflix tag-tv-trailers">
<div class="single-header is-center"><div class="post-cat-info is-relative"><a class="cat-info-el is-cat-888" href="https://theslanted.com/coverage/television/" rel="category tag">TV News</a></div><header class="entry-header single-title post-title is-big-title "><h1 class="entry-title" itemprop="headline">&#8216;The Last Kids on Earth: Season 2&#8217; Starts on April 17th</h1></header><div class="post-thumb-outer single-thumb-outer"><div class="post-thumb is-image is-image-single ruby-holder"><a href="https://theslanted.com/wp-content/uploads/2020/04/Last-Kids-on-Earth-Season-2.jpg" title="&#8216;The Last Kids on Earth: Season 2&#8217; Starts on April 17th" rel="bookmark"><span class="thumbnail-resize"><img width="1200" height="640" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/04/Last-Kids-on-Earth-Season-2.jpg" class="attachment-full size-full wp-post-image lazyload" alt="Last Kids on Earth" data-srcset="https://theslanted.com/wp-content/uploads/2020/04/Last-Kids-on-Earth-Season-2.jpg 1200w, https://theslanted.com/wp-content/uploads/2020/04/Last-Kids-on-Earth-Season-2-360x192.jpg 360w, https://theslanted.com/wp-content/uploads/2020/04/Last-Kids-on-Earth-Season-2-750x400.jpg 750w, https://theslanted.com/wp-content/uploads/2020/04/Last-Kids-on-Earth-Season-2-768x410.jpg 768w" sizes="(max-width: 1200px) 100vw, 1200px" /><noscript><img width="1200" height="640" src="https://theslanted.com/wp-content/uploads/2020/04/Last-Kids-on-Earth-Season-2.jpg" class="attachment-full size-full wp-post-image lazyload" alt="Last Kids on Earth" srcset="https://theslanted.com/wp-content/uploads/2020/04/Last-Kids-on-Earth-Season-2.jpg 1200w, https://theslanted.com/wp-content/uploads/2020/04/Last-Kids-on-Earth-Season-2-360x192.jpg 360w, https://theslanted.com/wp-content/uploads/2020/04/Last-Kids-on-Earth-Season-2-750x400.jpg 750w, https://theslanted.com/wp-content/uploads/2020/04/Last-Kids-on-Earth-Season-2-768x410.jpg 768w" sizes="(max-width: 1200px) 100vw, 1200px" /></noscript></span></a><span class="thumb-caption">netflix</span></div></div><div class="single-meta-info-bar clearfix"><div class="post-meta-info"><span class="meta-info-el meta-info-author">
<span class="meta-info-author-thumb">
<img alt='Sarah Fox' src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://secure.gravatar.com/avatar/a6dee5f3ed42423fd798b9a8e9037311?s=50&#038;d=mm&#038;r=g" data-srcset="https://secure.gravatar.com/avatar/a6dee5f3ed42423fd798b9a8e9037311?s=100&#038;d=mm&#038;r=g 2x" class='avatar avatar-50 photo lazyload' height='50' width='50' /><noscript><img alt='Sarah Fox' src='https://secure.gravatar.com/avatar/a6dee5f3ed42423fd798b9a8e9037311?s=50&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/a6dee5f3ed42423fd798b9a8e9037311?s=100&#038;d=mm&#038;r=g 2x' class='avatar avatar-50 photo lazyload' height='50' width='50' /></noscript> </span>
<a href="https://theslanted.com/author/sarahfoxes/" rel="author" title="Post by Sarah Fox">
Sarah Fox	</a>
</span>
<span class="meta-info-el meta-info-date">
<span class="meta-date">April 3, 2020</span>
</span>
</div><div class="single-share-bar clearfix"><span class="single-share-bar-total share-bar-total"><span class="share-bar-total-text">share</span></span><div class="single-share-bar-inner"><a class="share-bar-el icon-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Ftheslanted.com%2F2020%2F04%2F39440%2Fthe-last-kids-on-earth-season-2-april-premiere%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="fa fa-facebook color-facebook"></i></a><a class="share-bar-el icon-twitter" href="https://twitter.com/intent/tweet?text=%E2%80%98The+Last+Kids+on+Earth%3A+Season+2%E2%80%99+Starts+on+April+17th&amp;url=https%3A%2F%2Ftheslanted.com%2F2020%2F04%2F39440%2Fthe-last-kids-on-earth-season-2-april-premiere%2F&amp;via=sarahfoxes"><i class="fa fa-twitter color-twitter"></i><script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></a><a class="share-bar-el icon-reddit" href="https://www.reddit.com/submit?url=https%3A%2F%2Ftheslanted.com%2F2020%2F04%2F39440%2Fthe-last-kids-on-earth-season-2-april-premiere%2F&title=%E2%80%98The+Last+Kids+on+Earth%3A+Season+2%E2%80%99+Starts+on+April+17th" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="fa fa-reddit"></i></a><a class="share-bar-el icon-email" href="/cdn-cgi/l/email-protection#2b14585e49414e485f160d0813191a1d107f434e0b674a585f0b60424f580b44450b6e4a595f43110b784e4a5844450b190d0813191a1c100b785f4a595f580b44450b6a5b5942470b1a1c5f430d4a465b1069646f7216620b4d445e454f0b5f4342580b4a595f4248474e0b42455f4e594e585f42454c0b4a454f0b5f43445e4c435f0b444d0b58434a5942454c0b425f0b5c425f430b52445e050b68434e48400b425f0b445e5f11435f5f5b580e186a0e196d0e196d5f434e58474a455f4e4f054844460e196d191b191b0e196d1b1f0e196d18121f1f1b0e196d5f434e06474a585f0640424f58064445064e4a595f4306584e4a5844450619064a5b594247065b594e46424e594e0e196d"><i class="fa fa-envelope-o"></i></a></div></div></div></div><div class="single-post-ad is-ad-custom single-post-ad-top"><a href="https://theslanted.com/weekend-box-office/?utm_source=sidebar&utm_medium=banner&utm_campaign=fall_marketing" target="_blank"><img src="https://theslanted.com/wp-content/uploads/2020/02/Weekend-Box-Office.png" alt="Slanted"></a></div><div class="entry post-content entry-content single-entry" itemprop="articleBody"><div class='code-block code-block-1' style='margin: 8px 0; clear: both;'>
<p id="breadcrumbs"><span><span><a href="https://theslanted.com/">Slanted</a> &gt; <span><a href="https://theslanted.com/coverage/television/">TV</a> &gt; <span class="breadcrumb_last" aria-current="page">&#8216;The Last Kids on Earth: Season 2&#8217; Starts on April 17th</span></span></span></span></p></div>
<p>Netflix and Atomic Cartoons shared a first look trailer for &#8220;<strong>The Last Kids on Earth: Season 2</strong>&#8221; on Friday, and Netflix set a premiere date for the new episodes. The animated series is based on the New York Times bestselling books by Max Brailler, and the new season starts on April 17th.</p>
<p>The series is from Atomic Cartoons, and the new season is based on the second book in the franchise. Netflix stated that Season 2 will have ten, 22-minute episodes and will feature the voices of Mark Hamill, Rosario Dawson, Catherine O’Hara, Bruce Campbell, and Keith David, with Nick Wolfhard voicing the starring role. </p>
<p>“The Last Kids on Earth” is part of a larger world of IP that includes the book series as well as toys and other consumer products. The latest book installment of the series, “The Last Kids on Earth: June’s Wild Flight” published by Penguin, will be released on April 7th. You can pre-order the book and have it ready for release day right here on <a href="https://www.amazon.com/Last-Kids-Earth-Junes-Flight/dp/0593117182/ref=as_li_ss_tl?dchild=1&#038;keywords=The+Last+Kids+on+Earth:+June%E2%80%99s+Wild+Flight&#038;qid=1585934293&#038;sr=8-1&#038;linkCode=ll1&#038;tag=slanted-inarticle-20&#038;linkId=bb2cf921d588f4ce7c6735c7acef6021&#038;language=en_US">Amazon</a>.</p>
<p>The story follows Jack Sullivan (played by Nick Wolfhard) and a band of suburban middle schoolers living in a decked-out treehouse, playing video games, gorging themselves on candy and battling zombies.</p>
<p>The show is produced by showrunner Scott Peterson of Atomic Cartoons, and created and produced by Max Brallier, who also authored the books. Atomic’s productions include the Emmy-award winning &#8220;Beat Bugs,&#8221; the Disney show &#8220;101 Dalmatian Street,&#8221; &#8220;Counterfeit Cat,&#8221; &#8220;Minecraft Mini Series,&#8221; &#8220;Marvel’s Avengers Assemble,&#8221; &#8220;Rocket Monkeys,&#8221; &#8220;Max &#038; Ruby,&#8221; and &#8220;Transformers: Rescue Bots.&#8221;</p>
<p>The trailer&#8217;s description adds, &#8220;It&#8217;s all fun and games for Jack Sullivan and his friends until they realize monsters and zombies were invited to the party too.&#8221;</p>
<p>Netflix&#8217;s April schedule also includes &#8220;Nailed It: Season 3&#8221; on April 1st, followed by &#8220;Brew Brothers&#8221; on April 10th and &#8220;Outer Banks&#8221; on April 15th. &#8220;Fauda: Season 3&#8221; starts on April 16th, with &#8220;Too Hot to Handle&#8221; and &#8220;#BlackAF&#8221; on April 17th. At the end of the month, look for &#8220;The Midnight Gospel,&#8221; &#8220;Absurd Planet,&#8221; &#8220;The House of Flowers: Season 3,&#8221; &#8220;After Life: Season 2,&#8221; &#8220;The Last Kingdom: Season 4,&#8221; &#8220;Never Have I Ever,&#8221; and &#8220;Nadiya&#8217;s Time to Eat.&#8221;<iframe title="The Last Kids on Earth 🌎 Book 2 Trailer | Netflix Futures" width="1200" height="675" src="https://www.youtube.com/embed/HyXiaIrT9Kg?feature=oembed" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
<p style="text-align: center;"><strong><em>Subscribe to <a href="https://theslanted.com/subscribe/">Daily Updates</a> and never miss a headline.</em></strong></p>
<p>Slanted sometimes uses affiliate links and may earn a commission if you purchase items through those links.</p>
<div class="clearfix"></div><footer class="article-footer"> <div class="single-tag-wrap">
<span class="tag-title">Tags :</span>
<a href="https://theslanted.com/topic/netflix/" rel="tag">Netflix</a><a href="https://theslanted.com/topic/tv-trailers/" rel="tag">TV Trailers</a> </div>
</footer><aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/04/39440/the-last-kids-on-earth-season-2-april-premiere/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-04-03T13:23:07+00:00" content="2020-04-03T13:23:07+00:00">April 3, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-04-03T13:23:07+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/04/Last-Kids-on-Earth-Season-2.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
<div class="clearfix"></div></div><div class="single-post-ad is-ad-custom single-post-ad-bottom"><a href="https://theslanted.com/movies-tv/?utm_source=sidebar&utm_medium=banner&utm_campaign=fall_marketing" target="_blank"><img src="https://theslanted.com/wp-content/uploads/2020/02/Slanted-Banner-Movies-TV.png" alt="Slanted"></a></div> </article>
<div class="single-related-wrap single-box">
<div class="single-related-header block-title">
<h3>others are reading</h3>
</div>
<div class="single-related-content row">
<div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39436 post type-post status-publish format-standard has-post-thumbnail category-television tag-hbo">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/04/39436/hbo-the-third-day-fall-premiere-date/" title="HBO Moves &#8216;The Third Day&#8217; to the Fall Schedule" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/04/Naomie-Harris-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Naomie Harris on red carpet" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/04/Naomie-Harris-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Naomie Harris on red carpet" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/04/39436/hbo-the-third-day-fall-premiere-date/" title="HBO Moves &#8216;The Third Day&#8217; to the Fall Schedule">HBO Moves &#8216;The Third Day&#8217; to the Fall Schedule</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">April 3, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/04/39436/hbo-the-third-day-fall-premiere-date/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-04-03T11:49:24+00:00" content="2020-04-03T11:49:24+00:00">April 3, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-04-03T11:49:24+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/04/Naomie-Harris.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39433 post type-post status-publish format-standard has-post-thumbnail category-television tag-tnt tag-tv-trailers">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/04/39433/snowpiercer-new-premiere-date-may/" title="&#8216;Snowpiercer&#8217; to Premiere Two Weeks Early on TNT" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2019/10/Snowpiercer-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Jennifer Connelly on TNT" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2019/10/Snowpiercer-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Jennifer Connelly on TNT" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/04/39433/snowpiercer-new-premiere-date-may/" title="&#8216;Snowpiercer&#8217; to Premiere Two Weeks Early on TNT">&#8216;Snowpiercer&#8217; to Premiere Two Weeks Early on TNT</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">April 2, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/04/39433/snowpiercer-new-premiere-date-may/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-04-02T16:21:50+00:00" content="2020-04-02T16:21:50+00:00">April 2, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-04-02T16:21:50+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2019/10/Snowpiercer.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39431 post type-post status-publish format-standard has-post-thumbnail category-television tag-hbo">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/04/39431/hbo-free-social-distancing-april/" title="HBO is Offering Free HBO Content During Your Social Distancing" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2019/04/Barry-HBO-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Bill Hadder in Barry" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2019/04/Barry-HBO-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Bill Hadder in Barry" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/04/39431/hbo-free-social-distancing-april/" title="HBO is Offering Free HBO Content During Your Social Distancing">HBO is Offering Free HBO Content During Your Social Distancing</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">April 2, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/04/39431/hbo-free-social-distancing-april/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-04-02T15:45:14+00:00" content="2020-04-02T15:45:14+00:00">April 2, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-04-03T11:53:44+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2019/04/Barry-HBO.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39424 post type-post status-publish format-standard has-post-thumbnail category-television tag-amc tag-bbc">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/04/39424/nos4a2-season-2-premiere-amc-bbc/" title="&#8216;NOS4A2 Season 2&#8217; will Begin in June and will Simulcast on BBC" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/04/NOS4A2-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="NOS4A2 on AMC" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/04/NOS4A2-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="NOS4A2 on AMC" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/04/39424/nos4a2-season-2-premiere-amc-bbc/" title="&#8216;NOS4A2 Season 2&#8217; will Begin in June and will Simulcast on BBC">&#8216;NOS4A2 Season 2&#8217; will Begin in June and will Simulcast on BBC</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">April 2, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/04/39424/nos4a2-season-2-premiere-amc-bbc/"> 
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-04-02T14:06:32+00:00" content="2020-04-02T14:06:32+00:00">April 2, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-04-02T14:06:32+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/04/NOS4A2.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39408 post type-post status-publish format-standard has-post-thumbnail category-television tag-adult-swim tag-tv-trailers">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/04/39408/rick-and-morty-season-4-part-2-return-premiere/" title="&#8216;Rick and Morty&#8217; Returns with new Adventures in May" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/04/Rick-and-Morty-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Rick and Morty" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/04/Rick-and-Morty-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Rick and Morty" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/04/39408/rick-and-morty-season-4-part-2-return-premiere/" title="&#8216;Rick and Morty&#8217; Returns with new Adventures in May">&#8216;Rick and Morty&#8217; Returns with new Adventures in May</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">April 1, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/04/39408/rick-and-morty-season-4-part-2-return-premiere/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-04-01T14:22:50+00:00" content="2020-04-01T14:22:50+00:00">April 1, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-04-01T14:22:50+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/04/Rick-and-Morty.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39405 post type-post status-publish format-standard has-post-thumbnail category-television tag-tbs tag-tv-trailers">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/04/39405/american-dad-april-premiere-2020/" title="&#8216;American Dad&#8217; Returns on April 13th" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/01/American-Dad-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="American Dad" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/01/American-Dad-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="American Dad" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/04/39405/american-dad-april-premiere-2020/" title="&#8216;American Dad&#8217; Returns on April 13th">&#8216;American Dad&#8217; Returns on April 13th</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">April 1, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/04/39405/american-dad-april-premiere-2020/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-04-01T14:00:12+00:00" content="2020-04-01T14:00:12+00:00">April 1, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-04-01T14:00:12+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/01/American-Dad.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39401 post type-post status-publish format-standard has-post-thumbnail category-television tag-netflix tag-tv-trailers">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/04/39401/love-wedding-repeat-netflix-cast-trailer/" title="&#8216;Love Wedding Repeat&#8217; Cycles Through One Magical and Awkward Day" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/04/Love-Wedding-Repeat-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Love Wedding Repeat" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/04/Love-Wedding-Repeat-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Love Wedding Repeat" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/04/39401/love-wedding-repeat-netflix-cast-trailer/" title="&#8216;Love Wedding Repeat&#8217; Cycles Through One Magical and Awkward Day">&#8216;Love Wedding Repeat&#8217; Cycles Through One Magical and Awkward Day</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">April 1, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/04/39401/love-wedding-repeat-netflix-cast-trailer/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-04-01T11:11:49+00:00" content="2020-04-01T11:11:49+00:00">April 1, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-04-01T11:12:06+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/04/Love-Wedding-Repeat.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="647">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39390 post type-post status-publish format-standard has-post-thumbnail category-television tag-hbo tag-tv-trailers">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/03/39390/hbo-i-know-this-much-is-true-premiere-date/" title="HBO Moves Mark Ruffalo&#8217;s &#8216;I Know This Much is True&#8217; to May" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/03/I-Know-This-Much-True-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="I Know This Much is True" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/03/I-Know-This-Much-True-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="I Know This Much is True" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/03/39390/hbo-i-know-this-much-is-true-premiere-date/" title="HBO Moves Mark Ruffalo&#8217;s &#8216;I Know This Much is True&#8217; to May">HBO Moves Mark Ruffalo&#8217;s &#8216;I Know This Much is True&#8217; to May</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">March 31, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/03/39390/hbo-i-know-this-much-is-true-premiere-date/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-03-31T14:39:54+00:00" content="2020-03-31T14:39:54+00:00">March 31, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-03-31T14:39:54+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/03/I-Know-This-Much-True.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39386 post type-post status-publish format-standard has-post-thumbnail category-television tag-hulu tag-tv-trailers">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/03/39386/hulu-normal-people-drama-premiere-april/" title="Hulu&#8217;s &#8216;Normal People&#8217; Drama to Premiere in April" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/03/Normal-People-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Normal People on Hulu" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/03/Normal-People-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Normal People on Hulu" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/03/39386/hulu-normal-people-drama-premiere-april/" title="Hulu&#8217;s &#8216;Normal People&#8217; Drama to Premiere in April">Hulu&#8217;s &#8216;Normal People&#8217; Drama to Premiere in April</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">March 31, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/03/39386/hulu-normal-people-drama-premiere-april/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-03-31T10:41:40+00:00" content="2020-03-31T10:41:40+00:00">March 31, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-03-31T10:41:40+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/03/Normal-People.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39375 post type-post status-publish format-standard has-post-thumbnail category-television tag-nickelodeon tag-tv-trailers">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/03/39375/ollies-pack-nickelodeon-premiere-trailer/" title="&#8216;Ollie&#8217;s Pack&#8217; to Debut on Nickelodeon in April" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/03/Ollies-Pack-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Ollies Pack animated series" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/03/Ollies-Pack-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Ollies Pack animated series" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/03/39375/ollies-pack-nickelodeon-premiere-trailer/" title="&#8216;Ollie&#8217;s Pack&#8217; to Debut on Nickelodeon in April">&#8216;Ollie&#8217;s Pack&#8217; to Debut on Nickelodeon in April</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">March 30, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/03/39375/ollies-pack-nickelodeon-premiere-trailer/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-03-30T19:29:30+00:00" content="2020-03-30T19:29:30+00:00">March 30, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-03-30T19:30:04+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/03/Ollies-Pack.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39371 post type-post status-publish format-standard has-post-thumbnail category-television tag-starz tag-tv-trailers">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/03/39371/starz-hightown-premiere-cast-trailer/" title="Starz Sets &#8216;Hightown&#8217; Premiere Date in May" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/03/Hightown-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Hightown on Starz" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/03/Hightown-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Hightown on Starz" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/03/39371/starz-hightown-premiere-cast-trailer/" title="Starz Sets &#8216;Hightown&#8217; Premiere Date in May">Starz Sets &#8216;Hightown&#8217; Premiere Date in May</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">March 30, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/03/39371/starz-hightown-premiere-cast-trailer/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-03-30T16:00:36+00:00" content="2020-03-30T16:00:36+00:00">March 30, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-03-30T16:00:36+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/03/Hightown.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="647">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39367 post type-post status-publish format-standard has-post-thumbnail category-television tag-netflix">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/03/39367/locke-key-season-2-netflix-order/" title="&#8216;Locke &#038; Key&#8217; Season 2 Confirmed at Netflix" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/01/Lock-and-Key-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Locke and Key" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/01/Lock-and-Key-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Locke and Key" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/03/39367/locke-key-season-2-netflix-order/" title="&#8216;Locke &#038; Key&#8217; Season 2 Confirmed at Netflix">&#8216;Locke &#038; Key&#8217; Season 2 Confirmed at Netflix</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">March 30, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/03/39367/locke-key-season-2-netflix-order/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-03-30T11:24:24+00:00" content="2020-03-30T11:24:24+00:00">March 30, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-03-30T11:24:24+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/01/Lock-and-Key.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39359 post type-post status-publish format-standard has-post-thumbnail category-television tag-showtime tag-tv-trailers">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/03/39359/billions-season-5-premiere-showtime-trailer/" title="&#8216;Billions&#8217; Season 5 to Begin in May on Showtime" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/03/Billions-Season-5-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Billions Season 5" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/03/Billions-Season-5-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Billions Season 5" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/03/39359/billions-season-5-premiere-showtime-trailer/" title="&#8216;Billions&#8217; Season 5 to Begin in May on Showtime">&#8216;Billions&#8217; Season 5 to Begin in May on Showtime</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">March 29, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/03/39359/billions-season-5-premiere-showtime-trailer/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-03-29T20:12:31+00:00" content="2020-03-29T20:12:31+00:00">March 29, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-03-29T20:12:31+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/03/Billions-Season-5.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="647">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39356 post type-post status-publish format-standard has-post-thumbnail category-television tag-cbs">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/03/39356/garth-trisha-live-special-cbs-performance/" title="&#8216;Garth &#038; Trisha LIVE&#8217; Primetime Special to air on CBS in April" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/03/Garth-and-Trisha-Live-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Garth &amp; Trisha LIVE" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/03/Garth-and-Trisha-Live-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Garth &amp; Trisha LIVE" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/03/39356/garth-trisha-live-special-cbs-performance/" title="&#8216;Garth &#038; Trisha LIVE&#8217; Primetime Special to air on CBS in April">&#8216;Garth &#038; Trisha LIVE&#8217; Primetime Special to air on CBS in April</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">March 29, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/03/39356/garth-trisha-live-special-cbs-performance/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-03-29T19:30:27+00:00" content="2020-03-29T19:30:27+00:00">March 29, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-03-29T19:30:27+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/03/Garth-and-Trisha-Live.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="647">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39349 post type-post status-publish format-standard has-post-thumbnail category-television tag-nickelodeon">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/03/39349/kristen-bell-nickelodeon-town-hall-covid-19/" title="Kristen Bell to Host Nickelodeon Town Hall for COVID-19 Education" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/03/Kristen-Bell-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Kristen Bell on ABC" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/03/Kristen-Bell-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Kristen Bell on ABC" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/03/39349/kristen-bell-nickelodeon-town-hall-covid-19/" title="Kristen Bell to Host Nickelodeon Town Hall for COVID-19 Education">Kristen Bell to Host Nickelodeon Town Hall for COVID-19 Education</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">March 28, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/03/39349/kristen-bell-nickelodeon-town-hall-covid-19/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-03-28T21:49:37+00:00" content="2020-03-28T21:49:37+00:00">March 28, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-03-28T21:49:37+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/03/Kristen-Bell.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="647">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39335 post type-post status-publish format-standard has-post-thumbnail category-television tag-hulu tag-tv-trailers">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/03/39335/future-man-season-3-trailer-final-season/" title="&#8216;Future Man: Season 3&#8217; Shares a Preview of the Final Season" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/02/Future-Man-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Future Man Season 3" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/02/Future-Man-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Future Man Season 3" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/03/39335/future-man-season-3-trailer-final-season/" title="&#8216;Future Man: Season 3&#8217; Shares a Preview of the Final Season">&#8216;Future Man: Season 3&#8217; Shares a Preview of the Final Season</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">March 27, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/03/39335/future-man-season-3-trailer-final-season/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-03-27T12:19:49+00:00" content="2020-03-27T12:19:49+00:00">March 27, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-03-27T12:19:49+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/02/Future-Man.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39332 post type-post status-publish format-standard has-post-thumbnail category-television tag-amc tag-bbc tag-tv-trailers">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/03/39332/killing-eve-season-3-early-premiere-date/" title="&#8216;Killing Eve Season 3&#8217; Gets an Early Premiere Date in April" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/02/Killing-Eve-Season-3-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Killing Eve Season 3" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/02/Killing-Eve-Season-3-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Killing Eve Season 3" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/03/39332/killing-eve-season-3-early-premiere-date/" title="&#8216;Killing Eve Season 3&#8217; Gets an Early Premiere Date in April">&#8216;Killing Eve Season 3&#8217; Gets an Early Premiere Date in April</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">March 27, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/03/39332/killing-eve-season-3-early-premiere-date/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-03-27T12:05:23+00:00" content="2020-03-27T12:05:23+00:00">March 27, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-03-27T12:05:23+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/02/Killing-Eve-Season-3.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39323 post type-post status-publish format-standard has-post-thumbnail category-television tag-cw">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/03/39323/cw-stargirl-in-the-dark-premiere-dates/" title="CW Moves Premiere Dates for &#8216;Stargirl&#8217; and &#8216;In the Dark&#8217;" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2019/12/Stargirl-Season-1-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Stargirl Season 1" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2019/12/Stargirl-Season-1-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Stargirl Season 1" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/03/39323/cw-stargirl-in-the-dark-premiere-dates/" title="CW Moves Premiere Dates for &#8216;Stargirl&#8217; and &#8216;In the Dark&#8217;">CW Moves Premiere Dates for &#8216;Stargirl&#8217; and &#8216;In the Dark&#8217;</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">March 26, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/03/39323/cw-stargirl-in-the-dark-premiere-dates/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-03-26T17:34:28+00:00" content="2020-03-26T17:34:28+00:00">March 26, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-03-26T17:34:28+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2019/12/Stargirl-Season-1.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39311 post type-post status-publish format-standard has-post-thumbnail category-television tag-hulu tag-tv-trailers">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/03/39311/into-the-dark-pooka-lives-premiere-trailer/" title="&#8216;Into the Dark: Pooka Lives&#8217; Shares a Preview Ahead of the Premiere" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/03/Into-the-Dark-Pooka-Lives-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Into the Dark Pooka Lives" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/03/Into-the-Dark-Pooka-Lives-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Into the Dark Pooka Lives" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/03/39311/into-the-dark-pooka-lives-premiere-trailer/" title="&#8216;Into the Dark: Pooka Lives&#8217; Shares a Preview Ahead of the Premiere">&#8216;Into the Dark: Pooka Lives&#8217; Shares a Preview Ahead of the Premiere</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">March 26, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/03/39311/into-the-dark-pooka-lives-premiere-trailer/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-03-26T12:50:15+00:00" content="2020-03-26T12:50:15+00:00">March 26, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-03-26T12:50:15+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/03/Into-the-Dark-Pooka-Lives.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="647">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39307 post type-post status-publish format-standard has-post-thumbnail category-television tag-disney-plus tag-tv-trailers">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/03/39307/disneynature-elephant-penguins-dolphin-reef/" title="Disneynature to Premiere &#8216;Elephant&#8217; and &#8216;Dolphin Reef&#8217; During Earth Month on Disney+" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/03/Disney-Nature-Elephant-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Disney Elephant" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/03/Disney-Nature-Elephant-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Disney Elephant" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/03/39307/disneynature-elephant-penguins-dolphin-reef/" title="Disneynature to Premiere &#8216;Elephant&#8217; and &#8216;Dolphin Reef&#8217; During Earth Month on Disney+">Disneynature to Premiere &#8216;Elephant&#8217; and &#8216;Dolphin Reef&#8217; During Earth Month on Disney+</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">March 26, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/03/39307/disneynature-elephant-penguins-dolphin-reef/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-03-26T11:28:40+00:00" content="2020-03-26T11:28:40+00:00">March 26, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-03-26T11:28:40+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/03/Disney-Nature-Elephant.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39299 post type-post status-publish format-standard has-post-thumbnail category-television tag-netflix">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/03/39299/netflix-angry-birds-summer-madness-series/" title="Netflix Orders &#8216;Angry Birds: Summer Madness&#8217; Series" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/03/Angry-Birds-Summer-Madness-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Angry Birds Summer Madness" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/03/Angry-Birds-Summer-Madness-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Angry Birds Summer Madness" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/03/39299/netflix-angry-birds-summer-madness-series/" title="Netflix Orders &#8216;Angry Birds: Summer Madness&#8217; Series">Netflix Orders &#8216;Angry Birds: Summer Madness&#8217; Series</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">March 25, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/03/39299/netflix-angry-birds-summer-madness-series/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-03-25T12:11:44+00:00" content="2020-03-25T12:11:44+00:00">March 25, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-03-25T12:11:44+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/03/Angry-Birds-Summer-Madness.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="647">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39295 post type-post status-publish format-standard has-post-thumbnail category-television tag-hulu tag-tv-trailers">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/03/39295/solar-opposites-hulu-premiere-date-trailer/" title="&#8216;Solar Opposites&#8217; Lands on Hulu in MAY" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/03/Solar-Opposites-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Solar Opposites" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/03/Solar-Opposites-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Solar Opposites" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/03/39295/solar-opposites-hulu-premiere-date-trailer/" title="&#8216;Solar Opposites&#8217; Lands on Hulu in MAY">&#8216;Solar Opposites&#8217; Lands on Hulu in MAY</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">March 25, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/03/39295/solar-opposites-hulu-premiere-date-trailer/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-03-25T11:50:34+00:00" content="2020-03-25T11:50:34+00:00">March 25, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-03-25T11:50:34+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/03/Solar-Opposites.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39293 post type-post status-publish format-standard has-post-thumbnail category-television tag-amc">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/03/39293/amc-national-anthem-anthology-series/" title="AMC Greenlights &#8216;National Anthem&#8217; Family Drama Anthology Series" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/03/AMC-e1585085269255-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="amc" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/03/AMC-e1585085269255-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="amc" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/03/39293/amc-national-anthem-anthology-series/" title="AMC Greenlights &#8216;National Anthem&#8217; Family Drama Anthology Series">AMC Greenlights &#8216;National Anthem&#8217; Family Drama Anthology Series</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">March 24, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/03/39293/amc-national-anthem-anthology-series/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-03-24T17:31:21+00:00" content="2020-03-24T17:31:21+00:00">March 24, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-03-24T17:31:21+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/03/AMC-e1585085269255.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="639">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39288 post type-post status-publish format-standard has-post-thumbnail category-television tag-netflix">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/03/39288/marie-kondo-netflix-renewals-april/" title="Netflix Orders More Marie Kondo, ‘Love Is Blind’, ‘The Circle’ &#038; ‘Rhythm + Flow’" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/03/Marie-Kondo-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Marie Kondo Series" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/03/Marie-Kondo-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Marie Kondo Series" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/03/39288/marie-kondo-netflix-renewals-april/" title="Netflix Orders More Marie Kondo, ‘Love Is Blind’, ‘The Circle’ &#038; ‘Rhythm + Flow’">Netflix Orders More Marie Kondo, ‘Love Is Blind’, ‘The Circle’ &#038; ‘Rhythm + Flow’</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">March 24, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/03/39288/marie-kondo-netflix-renewals-april/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-03-24T14:11:14+00:00" content="2020-03-24T14:11:14+00:00">March 24, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-03-24T14:11:14+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/03/Marie-Kondo.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="647">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39281 post type-post status-publish format-standard has-post-thumbnail category-television tag-hulu tag-tv-trailers">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/03/39281/elle-fanning-the-great-hulu-limited-series/" title="Elle Fanning&#8217;s &#8216;The Great&#8217; Premieres on Hulu in May" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/01/The-Great-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Elle Fanning in The Great" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/01/The-Great-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Elle Fanning in The Great" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/03/39281/elle-fanning-the-great-hulu-limited-series/" title="Elle Fanning&#8217;s &#8216;The Great&#8217; Premieres on Hulu in May">Elle Fanning&#8217;s &#8216;The Great&#8217; Premieres on Hulu in May</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">March 23, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/03/39281/elle-fanning-the-great-hulu-limited-series/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-03-23T14:10:06+00:00" content="2020-03-23T14:10:06+00:00">March 23, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-03-23T14:10:06+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/01/The-Great.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39275 post type-post status-publish format-standard has-post-thumbnail category-television tag-netflix tag-tv-trailers">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/03/39275/the-willoughbys-netflix-movie-trailer/" title="&#8216;The Willoughbys&#8217; Adventure Launches on Netflix in April" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/03/The-Willoughbys-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="The Willoughbys" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/03/The-Willoughbys-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="The Willoughbys" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/03/39275/the-willoughbys-netflix-movie-trailer/" title="&#8216;The Willoughbys&#8217; Adventure Launches on Netflix in April">&#8216;The Willoughbys&#8217; Adventure Launches on Netflix in April</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">March 23, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/03/39275/the-willoughbys-netflix-movie-trailer/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-03-23T10:09:58+00:00" content="2020-03-23T10:09:58+00:00">March 23, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-03-23T10:09:58+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/03/The-Willoughbys.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39264 post type-post status-publish format-standard has-post-thumbnail category-television tag-netflix tag-tv-trailers">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/03/39264/yoon-sung-hyun-time-to-hunt-netflix/" title="Yoon Sung-hyun&#8217;s &#8216;Time to Hunt&#8217; to Premiere on Netflix in April" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/03/Time-to-Hunt-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Time to Hunt" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/03/Time-to-Hunt-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Time to Hunt" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/03/39264/yoon-sung-hyun-time-to-hunt-netflix/" title="Yoon Sung-hyun&#8217;s &#8216;Time to Hunt&#8217; to Premiere on Netflix in April">Yoon Sung-hyun&#8217;s &#8216;Time to Hunt&#8217; to Premiere on Netflix in April</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">March 22, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/03/39264/yoon-sung-hyun-time-to-hunt-netflix/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-03-22T20:38:58+00:00" content="2020-03-22T20:38:58+00:00">March 22, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-03-22T20:38:58+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/03/Time-to-Hunt.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="647">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39259 post type-post status-publish format-standard has-post-thumbnail category-television tag-netflix tag-tv-trailers">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/03/39259/masameer-the-movie-netflix-premiere-trailer/" title="&#8216;Masameer the Movie&#8217; Heads to Netflix" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/03/Masameer-the-Movie-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Masameer the Movie" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/03/Masameer-the-Movie-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Masameer the Movie" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/03/39259/masameer-the-movie-netflix-premiere-trailer/" title="&#8216;Masameer the Movie&#8217; Heads to Netflix">&#8216;Masameer the Movie&#8217; Heads to Netflix</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">March 21, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/03/39259/masameer-the-movie-netflix-premiere-trailer/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-03-21T22:50:50+00:00" content="2020-03-21T22:50:50+00:00">March 21, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-03-21T22:51:19+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/03/Masameer-the-Movie.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39253 post type-post status-publish format-standard has-post-thumbnail category-television tag-netflix tag-tv-trailers">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/03/39253/ghost-in-the-shell-sac_2045-trailer-final/" title="&#8216;Ghost in the Shell: Sac_2045&#8217; Gets One Last Preview Before the Premiere" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/01/Ghost-in-the-Shell-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Ghost in the Shell on Netflix" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/01/Ghost-in-the-Shell-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Ghost in the Shell on Netflix" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/03/39253/ghost-in-the-shell-sac_2045-trailer-final/" title="&#8216;Ghost in the Shell: Sac_2045&#8217; Gets One Last Preview Before the Premiere">&#8216;Ghost in the Shell: Sac_2045&#8217; Gets One Last Preview Before the Premiere</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">March 21, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/03/39253/ghost-in-the-shell-sac_2045-trailer-final/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-03-21T14:05:02+00:00" content="2020-03-21T14:05:02+00:00">March 21, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-03-21T14:05:02+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/01/Ghost-in-the-Shell.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="640">
</span>
</aside>
</div>
</article>
</div><div class="col-sm-4 col-xs-6"><article class="post-wrap post-grid-small-s post-39246 post type-post status-publish format-standard has-post-thumbnail category-television tag-disney-channel">
<div class="post-thumb-outer">
<div class=" post-thumb is-image ruby-holder"><a href="https://theslanted.com/2020/03/39246/mira-royal-detective-disney-junior-premiere/" title="&#8216;Mira, Royal Detective&#8217; Premieres on Disney Junior" rel="bookmark"><span class="thumbnail-resize"><img width="300" height="270" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://theslanted.com/wp-content/uploads/2020/03/Mira-Royal-Detective-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Mira Royal Detective" /><noscript><img width="300" height="270" src="https://theslanted.com/wp-content/uploads/2020/03/Mira-Royal-Detective-300x270.jpg" class="attachment-look_ruby_300_270 size-look_ruby_300_270 wp-post-image lazyload" alt="Mira Royal Detective" /></noscript></span></a></div> </div>
<div class="post-header">
<header class="entry-header">
<h3 class="post-title is-small-title" itemprop="headline"><a href="https://theslanted.com/2020/03/39246/mira-royal-detective-disney-junior-premiere/" title="&#8216;Mira, Royal Detective&#8217; Premieres on Disney Junior">&#8216;Mira, Royal Detective&#8217; Premieres on Disney Junior</a></h3> </header>
<div class="post-meta-info"><span class="meta-info-el meta-info-date">
<span class="meta-date">March 20, 2020</span>
</span>
</div> <aside class="post-meta hidden">
<meta itemprop="mainEntityOfPage" content="https://theslanted.com/2020/03/39246/mira-royal-detective-disney-junior-premiere/">
<span class="vcard author" content="Sarah Fox"><span class="fn">Sarah Fox</span></span>
<time class="date published entry-date" datetime="2020-03-20T15:25:07+00:00" content="2020-03-20T15:25:07+00:00">March 20, 2020</time>
<meta class="updated" itemprop="dateModified" content="2020-03-20T15:25:07+00:00">
<span itemprop="publisher">
<meta content="Slanted">
<span itemprop="logo">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2018/03/Slanted-Greating.png">
</span>
</span>
<span itemprop="image">
<meta itemprop="url" content="https://theslanted.com/wp-content/uploads/2020/03/Mira-Royal-Detective.jpg">
<meta itemprop="width" content="1200">
<meta itemprop="height" content="647">
</span>
</aside>
</div>
</article>
</div> </div>
</div>
</div><aside id="sidebar" class="sidebar-wrap col-sm-4 col-xs-12 clearfix" role="complementary"><div class="sidebar-inner"></div></aside></div></div></div>
<footer id="footer" class="footer-wrap is-dark-text">
<div class="top-footer-wrap">
<div class="top-footer-inner">
</div>
</div>
<div class="footer-inner">
<div class="footer-social-bar-wrap">
<div class="ruby-container">
<div class="footer-social-bar-inner">
<div class="footer-logo">
<a href="https://theslanted.com/" class="logo" title="Slanted">
<img src="https://theslanted.com/wp-content/uploads/2018/02/Slanted-18-Retina.png" height="200" width="670" alt="Slanted">
</a>
</div>
<div class="social-link-info clearfix footer-social-wrap"><a class="color-facebook" title="Facebook" href="https://www.facebook.com/theslanted" target="_blank"><i class="fa fa-facebook"></i></a><a class="color-twitter" title="Twitter" href="https://twitter.com/theslanted" target="_blank"><i class="fa fa-twitter"></i></a><a class="color-instagram" title="Instagram" href="https://www.instagram.com/theslanted" target="_blank"><i class="fa fa-instagram"></i></a><a class="color-youtube" title="Youtube" href="https://www.youtube.com/c/TheSlanted" target="_blank"><i class="fa fa-youtube"></i></a><a class="color-Reddit" title="Reddit" href="https://www.reddit.com/r/Slanted_RSS_Feed/new/" target="_blank"><i class="fa fa-reddit"></i></a><a class="color-Apple News" title="Apple News" href="https://apple.news/TK1UJU7kBTA6GU6eR0IPK8g" target="_blank"><i class="fa fa-apple"></i></a><a class="color-Subscribe" title="Subscribe" href="https://theslanted.com/subscribe/" target="_blank"><i class="fa fa-envelope"></i></a></div> </div>
<div id="footer-copyright" class="footer-copyright-wrap">
<div class='code-block code-block-1' style='margin: 8px 0; clear: both;'>
<p id="breadcrumbs"><span><span><a href="https://theslanted.com/">Slanted</a> &gt; <span><a href="https://theslanted.com/coverage/television/">TV</a> &gt; <span class="breadcrumb_last" aria-current="page">&#8216;The Last Kids on Earth: Season 2&#8217; Starts on April 17th</span></span></span></span></p></div>
<p>the slanted is owned an operated by Grimm Media Publications LLC</p>
</div>
</div>
</div>
</div>
</footer></div>
</div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script defer src='https://theslanted.com/wp-content/plugins/look-ruby-core/assets/core.js?ver=2.2'></script>
<script defer src='https://theslanted.com/wp-content/plugins/sg-cachepress/assets/js/lazysizes.min.js?ver=5.4.6'></script>
<script defer src='https://theslanted.com/wp-content/themes/look/assets/external/external-script.js?ver=5.1'></script>
<script>
var look_ruby_ajax_url = "https:\/\/theslanted.com\/wp-admin\/admin-ajax.php";
var look_ruby_to_top = "1";
var look_ruby_to_top_mobile = "1";
</script>
<script defer src='https://theslanted.com/wp-content/themes/look/assets/js/theme-script.js?ver=5.1'></script>
<script src='https://theslanted.com/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
</body>
</html>